Visualizzazione dei risultati da 1 a 7 su 7

Discussione: [Gentoo] non emergo più niente

  1. #1

    [Gentoo] non emergo più niente

    non riesco più ad emergere un tubo in gentoo.

    Se anche do il comando

    codice:
     emerge --update --deep --newuse world
    l'esito è:

    Calculating world dependencies ...done!
    >>> emerge (1 of 179) sys-devel/m4-1.4.2-r1 to /
    >>> md5 src_uri ;-) m4-1.4.2.tar.gz
    >>> Unpacking source...
    >>> Unpacking m4-1.4.2.tar.gz to /var/tmp/portage/m4-1.4.2-r1/work
    >>> Source unpacked.
    ./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-nls --enable-changeword
    configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
    checking for gawk... gawk
    checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
    checking for C compiler default output file name... configure: error: C compiler cannot create executables
    See `config.log' for more details.

    !!! Please attach the config.log to your bug report:
    !!! /var/tmp/portage/m4-1.4.2-r1/work/m4-1.4.2/config.log

    !!! ERROR: sys-devel/m4-1.4.2-r1 failed.
    !!! Function econf, Line 485, Exitcode 0
    !!! econf failed
    !!! If you need support, post the topmost build error, NOT this status message.


    che fo?
    Nuovo Sistema: iMac 24" dual core intel... e il virus non c'è più.
    un mio articolo su
    sognandolondra

  2. #2


    hai messo ~x86 nel make.conf scommetto


    se hai emerso il sitema unstable succede

    http://forums.gentoo.org/viewtopic.p...ht=executables

    prova a lanciare gcc-config

    o fix_libtool_files.sh

    se è il problema del nuovo gcc il secondo dovrebbe risolvere

  3. #3

    già!

    Originariamente inviato da andy caps


    hai messo ~x86 nel make.conf scommetto


    se hai emerso il sitema unstable succede

    http://forums.gentoo.org/viewtopic.p...ht=executables

    prova a lanciare gcc-config

    o fix_libtool_files.sh

    se è il problema del nuovo gcc il secondo dovrebbe risolvere
    infatti il problema è questo. Ho già seguito vari thread di forum gentoo, ma sembra che niente mi abbia aiutato.

    codice:
    gcc-config -l
    [1] i686-pc-linux-gnu-3.4.3
    [2] i686-pc-linux-gnu-3.4.3-hardened
    [3] i686-pc-linux-gnu-3.4.3-hardenednopie
    [4] i686-pc-linux-gnu-3.4.3-hardenednossp

    codice:
    gcc-config 1
    * Switching to i686-pc-linux-gnu-3.4.3 compiler...

    codice:
     ld.conf
    ld.so.conf autogenerated by env-update; make all changes to
    # contents of /etc/env.d directory
    /usr/local/lib
    /usr/i686-pc-linux-gnu/lib
    /usr/lib/gcc/i686-pc-linux-gnu/3.4.3
    /usr/lib/opengl/nvidia/lib
    /usr/lib/MozillaFirefox
    /usr/lib/mozilla
    /usr/lib
    /opt/blackdown-jdk-1.4.2.01/jre/lib/i386/
    /opt/blackdown-jdk-1.4.2.01/jre/lib/i386/native_threads/
    /opt/blackdown-jdk-1.4.2.01/jre/lib/i386/classic/
    /usr/qt/3/lib
    /usr/kde/3.3/lib
    /usr/games/lib
    /usr/lib/fltk-1.1
    /usr/lib/libstdc++-v3/

    codice:
     ldconfig
    codice:
     source etc/profile
    Nuovo Sistema: iMac 24" dual core intel... e il virus non c'è più.
    un mio articolo su
    sognandolondra

  4. #4
    se sono in una situazione pseudottimale con tutti i pacchetti stabili tranne 1, come faccio a dire ad

    emerge world

    di non farmi il downgrade di quel pacchetto?
    Nuovo Sistema: iMac 24" dual core intel... e il virus non c'è più.
    un mio articolo su
    sognandolondra

  5. #5
    Utente di HTML.it L'avatar di Ilmalcom
    Registrato dal
    Oct 2002
    Messaggi
    1,347
    Originariamente inviato da mschievano
    se sono in una situazione pseudottimale con tutti i pacchetti stabili tranne 1, come faccio a dire ad

    emerge world

    di non farmi il downgrade di quel pacchetto?
    emerge -Up world

    così può fare solo l'upgrade e non il downgrade. E' deprecato, ma fa al caso tuo. Comunque è emerge stesso che ti suggerisce una soluzione se usi l'opzione -U

  6. #6
    Originariamente inviato da Ilmalcom
    emerge -Up world

    così può fare solo l'upgrade e non il downgrade. E' deprecato, ma fa al caso tuo. Comunque è emerge stesso che ti suggerisce una soluzione se usi l'opzione -U
    in effetti posso dire di no qunado tenta di farmi il downgrade.
    thank's
    Nuovo Sistema: iMac 24" dual core intel... e il virus non c'è più.
    un mio articolo su
    sognandolondra

  7. #7
    se ho dando emerde gcc (in slack 10.1)
    codice:
    checking for i486-slackware-linux-strip... no
    checking for strip... strip
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for i486-slackware-linux-gcc... gcc
    checking for C compiler default output file name... configure: error: C compiler cannot create executables
    See `config.log' for more details.
    e

    [code]
    root@ainex:/etc/env.d/gcc# gcc-config -l
    * /usr/bin/gcc-config: Profile does not exist or invalid setting for /etc/env.d/gcc/i686-slackware-linux-3.3.5
    [1] i686-slackware-linux-3.3.5 *
    [2] i686-slackware-linux-3.3.5-hardened
    [3] i686-slackware-linux-3.3.5-hardenednopie
    [4] i686-slackware-linux-3.3.5-hardenednossp
    [5] i686-slackware-linux-3.3.5~
    root@ainex:/etc/env.d/gcc#
    [code]

    e ho già dato

    codice:
    root@ainex:/etc/env.d/gcc# fix_libtool_files.sh 3.3 --oldarch i486-slackware-linux
    Come posso risolvere il primo problema? Sembra che il compilatore cerchi sempre la versione i486, mentre io ho la athlon-xp (i686)
    Nuovo Sistema: iMac 24" dual core intel... e il virus non c'è più.
    un mio articolo su
    sognandolondra

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.