Pagina 2 di 5 primaprima 1 2 3 4 ... ultimoultimo
Visualizzazione dei risultati da 11 a 20 su 45

Discussione: [Tutorial] Usare IIS, ASP e i file MDB di ACCESS su Windows Vista e Windows 7

  1. #11
    C'è un problema

    il pulsante "Connetti come" è disattivato...non posso cliccarlo...come posso risolvere il problema?

  2. #12
    Utente di HTML.it
    Registrato dal
    Sep 2009
    Messaggi
    4
    ciao longline, ho provato a fare i passi elencati da te ma non riesco comunque a connettermi al db access. mi puoi dare una mano

    grazie

  3. #13
    Utente di HTML.it L'avatar di longline
    Registrato dal
    Sep 2001
    Messaggi
    5,378
    Ciao, qual è il problema che ti si presenta?

  4. #14
    Utente di HTML.it
    Registrato dal
    Sep 2009
    Messaggi
    4
    Ciao, mi da l'errore classico (Microsoft OLE DB Provider for ODBC Drivers error '80004005'), non riesce a connettersi al db e non riconosce i driver

    la connessione, la stringa del driver, etc per puntare al db la faccio direttamente con odbc, non so se dipende da questo, per vedere i driver di access da vista ho dovuto puntare al syswow64\odbcad32.exe altrimenti non vedevo i driver, può dipendere da questo

    ti giro la stringa di connessione che utilizzo su XP e che funziona
    Set objConn = Server.CreateObject("ADODB.Connection")
    ObjConn.Open "Crm"

    (crm) connessione con odbc

  5. #15
    Utente di HTML.it L'avatar di longline
    Registrato dal
    Sep 2001
    Messaggi
    5,378
    La soluzione che apre questo thread permette di trasportare i siti da XP a Vista senza modificare assolutamente nulla del codice originale, né alcuna altra impostazione in IIS, tranne quella esplicitamente indicata qui. Se hai fatto altre modifiche, annullale. Forse la cosa migliore sarebbe quella di riprendere il tuo sito dall'XP su cui ancora funzionano.

  6. #16
    Utente di HTML.it
    Registrato dal
    Sep 2009
    Messaggi
    4
    io non ho fatto nulla, ho semplicemente replicato quello che avevo su XP, creata cartella, definita connessione con odbc, settato il sito all'indirizzo 127.0.0.1

  7. #17
    Utente di HTML.it L'avatar di longline
    Registrato dal
    Sep 2001
    Messaggi
    5,378
    Le pagine in ASP, quelle senza connessioni a DB, funzionano senza problemi?

    Edit: Hai comunque assegnato correttamente le permission all'utente IUSR_nomemacchina?

  8. #18
    Utente di HTML.it
    Registrato dal
    Sep 2009
    Messaggi
    4
    le pagine asp funzionano correttamente, ho provato ad isolare la connessione e tutto gira correttamente
    ho aggiunto anche gli utenti classici IUSR, etc. con le permission ma nulla
    voglio provare a connettere il db direttamente da codice ma ho paura che non riesca comunque a trovare i driver

    come tanti altri è tre giorni che sto ruotando attorno alle stesse cose non so veramente come fare

  9. #19
    Utente di HTML.it L'avatar di luisa227
    Registrato dal
    Mar 2002
    Messaggi
    2,283
    ma che versione di Vista hai?
    grazie

  10. #20
    Utente di HTML.it L'avatar di longline
    Registrato dal
    Sep 2001
    Messaggi
    5,378
    Originariamente inviato da luisa227
    ma che versione di Vista hai?
    grazie
    Home Premium

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.