Pagina 3 di 5 primaprima 1 2 3 4 5 ultimoultimo
Visualizzazione dei risultati da 21 a 30 su 45

Discussione: [Tutorial] Usare IIS, ASP e i file MDB di ACCESS su Windows Vista e Windows 7

  1. #21
    Utente di HTML.it
    Registrato dal
    Feb 2006
    Messaggi
    32
    Ragazzi ho lo stesso problema di gaddo solo che io uso Windows Seven, credo che il problema sia lo stesso che si riscontra su Vista.

    In pratica ho un sito scritto in asp con database access che su xp funziona perfettamente mentre su Windows seven mi da problemi, il codice asp viene interpretato perfettamente, è la connessione al database access che non funziona, di seguito riporto l'errore:

    Microsoft OLE DB Provider for ODBC Drivers error '80004005'

    [Microsoft][Driver Manager ODBC] Nome origine dati non trovato e driver predefinito non specificato.

    /index.asp, riga 29

    Alla riga 29 del file index.asp c'è questo:

    objConn.Open"DRIVER={Microsoft Access Driver (*.mdb)};DBQ=" & server.MapPath("db/med.mdb")

    Ovviamente prima di postare ho seguito la guida per la configurazione del iis proposta in prima pagina.

    Aiutatemi per favore altrimenti mi tocca ritornare a xp.

  2. #22
    Utente di HTML.it L'avatar di longline
    Registrato dal
    Sep 2001
    Messaggi
    5,378
    Ciao Ulver,
    questo thread fornisce una soluzione ai problemi di permission che si rilevano passando su Vista i siti progettati su XP. Il messaggio di errore che riporti tu parla innanzitutto di origine dati.
    Forse sarebbe più utile aprire un thread dedicato al tuo problema, che mi sembra diverso da quello trattato da qui: dovresti innanzitutto controllare il nome ed il percorso esatto dell'MDB da usare, ad esempio facendo un response.write (server.MapPath("db/med.mdb")) invece di eseguire la connessione.

  3. #23
    Utente di HTML.it
    Registrato dal
    Feb 2006
    Messaggi
    32
    ho aperto un altra discussione.
    Ho comunque provato con il response.write e il percorso del file mdb è corretto...

  4. #24
    Utente di HTML.it
    Registrato dal
    Sep 2002
    Messaggi
    4

    connessione DB in Wint7

    Salve a tutti,
    ho un problema con la connessione ad un DB Access in localhost con Vista e Win 7;
    le pagine asp funzionano correttamente, mentre se cerco di connettermi ad un Db mi segnaal il seguente errore
    ---> An error occurred on the server when processing the URL. Please contact the system administrator.

    questo è il codice della pagina:
    ---> Dim sc, cn, os

    sc = "driver={Microsoft Access Driver (*.mdb)};dbq=" & Server.MapPath("/project_DbMain/db_main.mdb")
    response.write ("SETTO LA CONNESSIONE")
    Set cn = Server.CreateObject("ADODB.Connection")
    response.write ("APRO LA CONNESSIONE")
    cn.Open sc

    Set os = cn.OpenSchema(20)

    While os.EOF = False
    If Trim(os("TABLE_TYPE")) = "TABLE" Then
    Response.Write os("TABLE_NAME") & "
    "
    End If
    os.MoveNext
    Wend

    Set os = Nothing
    cn.Close
    Set cn = Nothing

    POTETE AIUTARMI????

  5. #25
    Utente di HTML.it L'avatar di longline
    Registrato dal
    Sep 2001
    Messaggi
    5,378

    Re: connessione DB in Wint7

    Originariamente inviato da sov_pas
    ---> An error occurred on the server when processing the URL. Please contact the system administrator.
    Direi che le informazioni per aiutarti non sono sufficienti, devi innanzitutto fare in modo che il server non mandi gli errori http brevi.

    Apri IIS, nella colonna sinistra seleziona il tuo computer, nella colonna centrale apri "ASP", poi attiva l'opzione Proprietà debug > Invia errori al Browser.

  6. #26
    Utente di HTML.it
    Registrato dal
    Dec 2010
    Messaggi
    13
    C'è un problema

    il pulsante "Connetti come" è disattivato...non posso cliccarlo...come posso risolvere il problema?


  7. #27
    Utente di HTML.it L'avatar di longline
    Registrato dal
    Sep 2001
    Messaggi
    5,378
    Originariamente inviato da alfo360
    C'è un problema

    il pulsante "Connetti come" è disattivato...non posso cliccarlo...come posso risolvere il problema?

    Purtroppo non riesco a riprodurre la tua situazione: il pulsante "Connetti come..." da me è sempre attivo.
    Puoi darci altri dettagli sulla tua situazione?

  8. #28
    ciao...io non sono riuscita a risolvere il problema...
    ho seguito tutta la procedura, le pagine .asp normali funzionano senza problemi ma con quelle collegate a un database continua dirmi "impossibile visualizzare il sito potrebbe essere in manutenzione...ecc ecc..."

  9. #29
    Utente di HTML.it L'avatar di longline
    Registrato dal
    Sep 2001
    Messaggi
    5,378
    Originariamente inviato da Giry82
    ciao...io non sono riuscita a risolvere il problema...
    ho seguito tutta la procedura, le pagine .asp normali funzionano senza problemi ma con quelle collegate a un database continua dirmi "impossibile visualizzare il sito potrebbe essere in manutenzione...ecc ecc..."
    Originariamente inviato da longline
    Devi innanzitutto fare in modo che il server non mandi gli errori http brevi.

    Apri IIS, nella colonna sinistra seleziona il tuo computer, nella colonna centrale apri "ASP", poi attiva l'opzione Proprietà debug > Invia errori al Browser.

  10. #30
    Ho eseguito con precisione tutte le manovre consigliate, ma purtroppo, vista la mia inesperienza, non riesco a capire cosa esattamente debbo scrivere per far girare le pagine in asp, in quale cartella debo andare. Quando provo ad eseguire le pagine in asp mi esce il messaggio se voglio aprire o salvare il file (xxxxxx.asp). Premetto che precedentemente avevo montato sullo stesso pc Win xp media center, ed andava tutto ok, adesso ho win 7 ultimate e non so dove mettere le mani. mi sapreste aiutare? Grazie!
    Luigi

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.