Visualizzazione dei risultati da 1 a 9 su 9

Discussione: phpmyadmin, debian 9, php 7e mysqli

  1. #1

    phpmyadmin, debian 9, php 7e mysqli

    ciao!

    scusate ma non ero sicuro della sezione!

    in pratica ho aggiornato debian 8 a debian 9.
    dopo vari dist-upgrade, mi è stato installato anche php7.
    da quel momento phpmyadmin non mi funziona più, in quanto mi dice questo:
    codice:
    The mysqli extension is missing. Please check your PHP configuration. See our documentation for more information.
    sinceramente nn capisco che devo fare, in quanto prima funzionava bene.
    inoltre sembra sia installato tutto:
    codice:
    # aptitude search mysqli
    v   php-mysqli                                                                                         -                                                                                                              
    v   php7.0-mysqli
    qualche idea??

  2. #2
    Utente di HTML.it
    Registrato dal
    Jun 2008
    Messaggi
    1,192
    prova a uncommentare la linea della estensione nel php.ini

  3. #3
    ciao!

    non c'è più in linux la linea.
    c'è la linea con estensione .dll per windows, ma non è il mio caso.

    c'è un'estensione da attivare in mods-available, e l'ho già fatto:
    codice:
    # ls -l /etc/php5/apache2/conf.d/
    lrwxrwxrwx 1 root root 31 Oct  2 12:56 20-mysqli.ini -> ../../mods-available/mysqli.ini
    
    # ls -l /etc/php/7.0/fpm/conf.d/
    lrwxrwxrwx 1 root root 38 Sep 29 17:21 20-mysqli.ini -> /etc/php/7.0/mods-available/mysqli.ini
    non so più dove altro andare a modificare!

  4. #4
    Utente di HTML.it
    Registrato dal
    Jun 2008
    Messaggi
    1,192
    sicuro che togliendo il commento dalla .dll poi non venga lavorata come un .so su linux?

    Comunque, domanda scontata ma a volte ci si può scordare, hai fatto il restart di apache dopo le modifiche?

  5. #5
    Quote Originariamente inviata da zacca94 Visualizza il messaggio
    sicuro che togliendo il commento dalla .dll poi non venga lavorata come un .so su linux?

    Comunque, domanda scontata ma a volte ci si può scordare, hai fatto il restart di apache dopo le modifiche?
    uhm si sono sicuro.
    perchè sennò non mi funzionerebbe neanche il sito che c'è sopra e che usa PDO.
    stesso concetto di mysqli.
    cmq nel file 20-mysqli.ini c'è questo:
    codice:
    ; configuration for php MySQL module
    ; priority=20
    extension=mysqli.so
    per quanto riguarda il riavvio, ho riavviato proprio il server ad un certo punto!!

  6. #6
    cmq mi correggo.

    anche le applicazioni che usano PDO non funzionano.
    mi ero ingannato controllando una pagina che non esegue connessioni al db.

    quindi probabilmente il problema è generalizzato a tutto php!

  7. #7
    allora, ho rimosso tutto apache e php e reinstallati.

    adesso non ho più l'errore di mysqli, ma ho scoperto il vero errore:
    codice:
    SQLSTATE[HY000] [2002] No such file or directory

  8. #8
    ho scoperto il problema, riguarda mariadb che non parte:
    codice:
    # systemctl status mariadb.service
    ● mariadb.service - MariaDB database server
       Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Mon 2017-10-02 16:51:42 CEST; 2min 30s ago
      Process: 999 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited, status=227/NO_NEW_PRIVILEGES)
      Process: 916 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ]   && systemctl set-environment _WSREP_START_POSITION=$VAR || exit 1 (code=exited, s
      Process: 912 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
      Process: 909 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
     Main PID: 999 (code=exited, status=227/NO_NEW_PRIVILEGES)
    
    Oct 02 16:51:41 matteoferrone systemd[1]: Starting MariaDB database server...
    Oct 02 16:51:42 matteoferrone systemd[999]: mariadb.service: Failed at step NO_NEW_PRIVILEGES spawning /usr/sbin/mysqld: Invalid argument
    Oct 02 16:51:42 matteoferrone systemd[1]: mariadb.service: Main process exited, code=exited, status=227/NO_NEW_PRIVILEGES
    Oct 02 16:51:42 matteoferrone systemd[1]: Failed to start MariaDB database server.
    Oct 02 16:51:42 matteoferrone systemd[1]: mariadb.service: Unit entered failed state.
    Oct 02 16:51:42 matteoferrone systemd[1]: mariadb.service: Failed with result 'exit-code'.
    nn so se volete spostarla o volete che ne riapro una nuova!

  9. #9
    ok ho risolto.

    il problema è il kernel di Debian 9, che era settato alla versione 3.2 invece che alla 4.9.
    mi è bastato installare GRUB2 invece di GRUB per risolvere il problema.

    ciao!

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.