Visualizzazione dei risultati da 1 a 4 su 4

Discussione: Problema con Lumen e le routes

  1. #1

    Problema con Lumen e le routes

    ciao!

    sto testando lumen, ma ho un problema con le routes.

    ho creato un progetto così (lanciato dalla webroot di apache):
    codice:
    composer create-project --prefer-dist laravel/lumen api
    questo il model (app/Movimenti.php):
    Codice PHP:
    <?php

    namespace App;

    use 
    Illuminate\Database\Eloquent\Model;

    class 
    Movimenti extends Model {

        protected 
    $fillable = ['mov_tipo''mov_valore''mov_causale_fk''mov_conto_fk''mov_data''mov_note''mov_utente_fk''mov_aggiunta'];

    }
    questo il contoller (app/Http/Controllers/MovimentiController):
    Codice PHP:
    <?php

    namespace App\Http\Controllers;

    use 
    App\Movimenti;

    class 
    MovimentiController extends Controller {

        public function 
    index() {
            
    $movimenti Movimenti::all();
            return 
    response()->json($movimenti);
        }

        public function 
    getMovimento($id) {
            
    $movimento Movimenti::find($id);
            return 
    response()->json($movimento);
        }

    }
    questo il file delle routes (app/routes/web.php):
    Codice PHP:
    <?php

    $router
    ->get('/', function () use ($router) {
        return 
    $router->app->version();
    });

    $router->get('movimenti''MovimentiController@index');
    se vado in http://www.sito.it/api/public è tutto ok
    se vado in http://www.sito.it/api/public/movimenti ottengo un bel Not found.

    qualche idea??

  2. #2
    Moderatore di PHP L'avatar di Alhazred
    Registrato dal
    Oct 2003
    Messaggi
    10,725
    Usa
    $router->get('/movimenti', 'MovimentiController@index');

  3. #3
    Quote Originariamente inviata da Alhazred Visualizza il messaggio
    Usa
    $router->get('/movimenti', 'MovimentiController@index');
    le ho provate tutte.
    poi ho provato anche silex, e stesso problema.
    quindi potrebbe essere un problema di configurazione del server (apache + lets encrypt + cloudlfare).

  4. #4
    Moderatore di PHP L'avatar di Alhazred
    Registrato dal
    Oct 2003
    Messaggi
    10,725
    Se ti funziona solo la root come route potrebbe essere qualche direttiva sbagliata nel .htaccess

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.