Visualizzazione dei risultati da 1 a 10 su 10

Discussione: Include e riga bianca vuota

  1. #1

    Include e riga bianca vuota

    Buongiorno !

    Come da titolo, perche' se, utilizzando un include (semplice o once), perche' mi si aggiunge una fastidiosissima riga bianca dove inizia l'include ?

    Per esempio:

    Codice PHP:

                
    echo "<table bgcolor=\"#e8e8e8\" cellpadding=\"0\" cellspacing=\"0\" align=\"center\" border=\"0\" width=\"100%\">\n";
                  echo 
    "<tr bgcolor=\"ffffff\">\n";         
                  echo 
    "<td align=\"center\" colspan=\"3\">\n";            
                    
                include(
    '_listaFile.php');
                    
                echo 
    "</td>\n"
                  echo 
    "</tr>\n"
                echo 
    "</table>\n"
    Cosi' aggiunge una riga bianca vuota sopra l'include

    Ciao ciao, grazie

  2. #2
    Utente di HTML.it L'avatar di linoma
    Registrato dal
    Mar 2010
    Messaggi
    1,309
    ..forse xche nel tuo include ce una riga bianca
    Per gli Spartani e Sparta usa spartan

  3. #3
    Quote Originariamente inviata da linoma Visualizza il messaggio
    ..forse xche nel tuo include ce una riga bianca
    Ciao e grazie per la risposta.

    Sto semplificando molto, ad ogni modo l'include e' esattamente cosi':

    Codice PHP:

    <?php
                    
        
    echo "lista utenti regiistrati\n";;
                  
    ?>

  4. #4
    Utente di HTML.it L'avatar di linoma
    Registrato dal
    Mar 2010
    Messaggi
    1,309
    ... mi sn limitato ad evidenziare un'errore molto comune che si copie con i files include. Dopo il tag di chiusura PHP sn stati eliminati eventuali caratteri? Normalmente l'errore presenta un newline w/carriage
    Per gli Spartani e Sparta usa spartan

  5. #5
    Quote Originariamente inviata da linoma Visualizza il messaggio
    ... mi sn limitato ad evidenziare un'errore molto comune che si copie con i files include. Dopo il tag di chiusura PHP sn stati eliminati eventuali caratteri? Normalmente l'errore presenta un newline w/carriage
    Dopo la chiusura dell'include ?> non c'e' assolutamente nulla, ne righe vuote, ne caratteri strani, nulla di nulla e il file, non so se puo' servire a qualcosa, e' stato salvato come UTF-8 with bom.

    Questa cosa mi sta facendo scapocciare

  6. #6
    UTF-8 with bom
    Mi sa che il tuo "spazio" misterioso č proprio il carattere "bom"..
    Full Stack Developer presso Advice Lab
    Bonus Bitcoin
    Moon Bitcoin

  7. #7
    Utente di HTML.it L'avatar di linoma
    Registrato dal
    Mar 2010
    Messaggi
    1,309
    Su via nn mi dare ragione
    Per gli Spartani e Sparta usa spartan

  8. #8
    Quote Originariamente inviata da Magicale Visualizza il messaggio
    Mi sa che il tuo "spazio" misterioso č proprio il carattere "bom"..
    No, il no bom e' stato una prova senza nessun risultato, di solito salvo semplicemente le pagine in UTF-8.

  9. #9
    togli il tag di chiusura
    indovina l'etā su https://www.guessmyage.it

  10. #10
    Quote Originariamente inviata da jonnino2004 Visualizza il messaggio
    togli il tag di chiusura
    Quale tag di chiusura ?
    Nella pagina principale o nell'include ?

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.