Visualizzazione dei risultati da 1 a 5 su 5

Discussione: Compatibilità attributi per elenchi puntati dipende da un JS?

  1. #1

    Compatibilità attributi per elenchi puntati dipende da un JS?

    Salve, ho notato che alcune impostazioni per elenchi puntati non sono viste da alcuni browser per smartphone:
    codice:
    ul {
        list-style-type: none;
    }
    li {
        display: inline;
        padding-right: 10px;
        background-color: inherit; 
    }
    li a {
        display: inline-block;
        background-color: inherit; 
    }
    Per esempio sul browser predefinito di Android si vedono le varie voci in linea, mentre su Chrome per Android appare l'elenco puntato nonché le voci incolonnate.
    Il device offerto da Chrome visualizza le voci in linea, mentre il Samsung S3 emulato con Genymotion mostra l'elenco puntato e le voci incolonnate.

    Al momento l'unica spiegazione che ho trovato è una qualche interferenza con un codice JavaScript usato per un menù a tendina, che ne rimpiazza un altro mal funzionante su smartphone (vede le pagine da aprire come pop-up e le blocca).
    Il JS che blocca il menù a tendina ma fa interpretare il css di cui sopra è questo:
    codice:
    <SCRIPT LANGUAGE="JavaScript"><!--function go(what) {
        value = what.options[what.selectedIndex].value;
        if (value == '') return;
        window.open(value, '_blank') = value;
    }
    //--></SCRIPT>
    Mentre il JS che fa funzionare il menù a tendina ma occulta il css è:
    codice:
    <SCRIPT LANGUAGE="JavaScript">    <!--
        function Menu(links) {
            location.href = links[links.selectedIndex].value;
        }
        //-->
    </SCRIPT>
    Entrambi i JS sono presi da guide di HTML.it.
    Studio tecnico 75: servizi per professionisti e aziende
    No richieste di assistenza via MP, grazie.

  2. #2
    Ho corretto language="JavaScript" col più aggiornato type="text/javascript" risolvendo il problema sull'emulatore del Samsung...
    Allego due schermate della situazione che ho sul browser predefinito dello smartphone e sull'app Chrome dello smartphone. Si tratta della zona "footer" della pagina, non contenuta in altri div e senza alcun posizionamento.
    2ufyrr6.jpg 2gtywr4.jpg
    Studio tecnico 75: servizi per professionisti e aziende
    No richieste di assistenza via MP, grazie.

  3. #3
    Moderatore di CSS L'avatar di KillerWorm
    Registrato dal
    Apr 2004
    Messaggi
    3,987
    Ciao, ho l'impressione che il CSS c'entri poco, così come quel JavaScript.
    Potrei invece pensare a qualche errore nel markup HTML, qualche tag chiuso male o robe del genere. Alcuni browser infatti riescono ad interpretare vari tipi di errori restituendo quindi un layout "corretto", mentre altri browser potrebbero non riuscire a correggere questi errori.

    Non ricordo se te l'ho già consigliato, ad ogni modo dovresti prima di tutto controllare la tua pagina (il tuo sito) con un validatore (ad esempio questo) e correggere tutti gli eventuali errori segnalati. Poi, se il problema persiste, si valuterà come procedere avendo comunque un codice perfettamente valido.


    Ho corretto language="JavaScript" col più aggiornato type="text/javascript"
    Se si tratta di HTML5 è opzionale, quindi puoi ometterlo direttamente. L'attributo type in questo caso è di default "application/javascript" per cui non serve specificarlo.
    Puoi semplicemente scrivere: <script></script>

    Io toglierei anche i commenti HTML (<!-- -->) dentro il tag script, sono totalmente inutili per gli attuali browser.
    Prima di postare considera che tra i link utili puoi trovare il 75% delle risposte alle tue domande; il 15% tra i post del forum; il 9% sul web.
    Ti resta l’1% ... usalo bene!

    Le cattive domande sono quelle che non meritano risposta, le buone domande sono quelle che non hanno risposta
    L'Itailano non e nu'opnioine. E' improntate uslaro correattemtne sul froum. Garize!

  4. #4
    Non avevo pensato alla validazione...
    Mi segnala errori nei valori "description" e "keyword" dell'attributo "http-equiv"... Non si inseriscono lì le frasi e le parole per farsi trovare dai motori di ricerca?

    Corretti gli errori, tranne quello sui valori di "http-equiv" che non so come fare, il validatore mi trova errori in parti di codici non mie, relative a presunti "malformed byte sequence" e0 oppure f9.
    In ogni caso, il problema su Chrome persiste identico a come l'ho documentato con le schermate...
    Studio tecnico 75: servizi per professionisti e aziende
    No richieste di assistenza via MP, grazie.

  5. #5
    Moderatore di CSS L'avatar di KillerWorm
    Registrato dal
    Apr 2004
    Messaggi
    3,987
    Sarebbe utile vedere la pagina in questione.

    Mi segnala errori nei valori "description" e "keyword" dell'attributo "http-equiv"...
    Prova ad usare l'attributo name anziché http-equiv.

    il validatore mi trova errori in parti di codici non mie, relative a presunti "malformed byte sequence" e0 oppure f9.
    In una pagina del tuo sito vedo che ci sono caratteri accentati codificati male. E' possibile che la codifica dei contenuti sia differente dal charset dichiarato nel documento.
    Il charset del documento è UTF-8:
    codice:
    <meta charset="UTF-8" />
    Prova magari ad usare iso-8859-1.

    Se il problema persiste posta eventualmente il link della pagina.
    Prima di postare considera che tra i link utili puoi trovare il 75% delle risposte alle tue domande; il 15% tra i post del forum; il 9% sul web.
    Ti resta l’1% ... usalo bene!

    Le cattive domande sono quelle che non meritano risposta, le buone domande sono quelle che non hanno risposta
    L'Itailano non e nu'opnioine. E' improntate uslaro correattemtne sul froum. Garize!

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2018 vBulletin Solutions, Inc. All rights reserved.