Visualizzazione dei risultati da 1 a 6 su 6

Discussione: Layout creato con bootstrap problemi tre colonne

  1. #1
    Utente di HTML.it
    Registrato dal
    Mar 2003
    residenza
    Prato
    Messaggi
    610

    Layout creato con bootstrap problemi tre colonne

    Salve
    Ho creato questo layout usando bootstrap ma il pezzo finale non riesco a capire come mai non mi mette tre colonne una a fianco dell'altra ma una sotto l'altra

    Questo è il link https://www.hostess-models.eu/index.html

    Potete aiutarmi grazie?

    Thank's...

  2. #2
    Utente di HTML.it L'avatar di m4rko80
    Registrato dal
    Aug 2008
    residenza
    Milano
    Messaggi
    2,534
    Ciao, da quel che vedo innanzi tutto hai degli elementi fra le colonne che non dovrebbero esserci. Se hai ad esempio una ROW la quale dovrà avere 3 colonne, dovresti avere un ROW con al suo interno 3 div di classe "col-md-4" per esempio. Tutto il contenuto di questo colonna sarà all'interno di queste "col-md-4". Il fatto che l'ultima sia effettivamente un terzo della larghezza pagina probabilmente è perche' in quel div di classe ROW che hai messo c'è solo una colonna con classe "col-lg-4 col-md-4" e quindi 1/3 della larghezza mentre dovresti avere
    codice:
    <div class="row">
    <div class="col-lg-4">
    LEFT
    </div>
    <div class="col-lg-4">
    CENTER
    </div>
    <div class="col-lg-4">
    RIGHT
    </div>
    </div>
    per fare un esempio

  3. #3
    Utente di HTML.it
    Registrato dal
    Mar 2003
    residenza
    Prato
    Messaggi
    610
    Il codice senza niente è praticamente questo:

    codice HTML:
    <div class="container"><div class="row"><div class="col-lg-4">
    CONTENUTO
    </div>
    <div class="col-lg-4">
    CONTENUTO
    </div>
    <div class="col-lg-4">
    CONTENUTO
    </div></div></div>
    Non capisco dov'è che sbaglio! Se metto solo l'immagini mi mette tre colonne il problema mi appare quando ci metto il testo sotto!!!

    Quote Originariamente inviata da m4rko80 Visualizza il messaggio
    Ciao, da quel che vedo innanzi tutto hai degli elementi fra le colonne che non dovrebbero esserci. Se hai ad esempio una ROW la quale dovrà avere 3 colonne, dovresti avere un ROW con al suo interno 3 div di classe "col-md-4" per esempio. Tutto il contenuto di questo colonna sarà all'interno di queste "col-md-4". Il fatto che l'ultima sia effettivamente un terzo della larghezza pagina probabilmente è perche' in quel div di classe ROW che hai messo c'è solo una colonna con classe "col-lg-4 col-md-4" e quindi 1/3 della larghezza mentre dovresti avere
    codice:
    <div class="row">
    <div class="col-lg-4">
    LEFT
    </div>
    <div class="col-lg-4">
    CENTER
    </div>
    <div class="col-lg-4">
    RIGHT
    </div>
    </div>
    per fare un esempio

  4. #4
    Utente di HTML.it
    Registrato dal
    Mar 2003
    residenza
    Prato
    Messaggi
    610
    Infatti ho messo le immagini in un contenitore separata e quelle si incolonnano cosa che invece non succede nel testo sotto nonostante il contenitore sia uguale... Quindi c'è qualcosa che non va nella formattazione del testo?
    Mi sa che mi conviene ripartire da capo qui!!

  5. #5
    Utente di HTML.it L'avatar di m4rko80
    Registrato dal
    Aug 2008
    residenza
    Milano
    Messaggi
    2,534
    Io vedo fra i vadi div di conolla dei tag <font> che non dovrebbero stare li ma probabilmente all'interno delle colonne.
    Dove inizia <-- inizio colonne immagini ---> vedo solo una row con una col-lg-4, per forza di cose questa colonna sarà un terzo della larghezza del container. C'à qualche errore nelle colonne o contenuti.

    Un banale esempio......
    Se hai una colonna col-lg-4 che sarà un terzo del continer (ipotizzo 400 px) e in questa colonna metto due immagini da 300x250 (i banner che vedo) per forza di cose andranno a capo (300x2 super i 400 disponibili e i 100 che avanzano non bastano per farci stare il successivo).

  6. #6
    Utente di HTML.it
    Registrato dal
    Mar 2003
    residenza
    Prato
    Messaggi
    610
    Le immagini non vanno a capo il problema l'ho nei testi.....

    Quote Originariamente inviata da m4rko80 Visualizza il messaggio
    Io vedo fra i vadi div di conolla dei tag <font> che non dovrebbero stare li ma probabilmente all'interno delle colonne.
    Dove inizia <-- inizio colonne immagini ---> vedo solo una row con una col-lg-4, per forza di cose questa colonna sarà un terzo della larghezza del container. C'à qualche errore nelle colonne o contenuti.

    Un banale esempio......
    Se hai una colonna col-lg-4 che sarà un terzo del continer (ipotizzo 400 px) e in questa colonna metto due immagini da 300x250 (i banner che vedo) per forza di cose andranno a capo (300x2 super i 400 disponibili e i 100 che avanzano non bastano per farci stare il successivo).

Tag per questa discussione

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2018 vBulletin Solutions, Inc. All rights reserved.