PDA

Visualizza la versione completa : problema mambo e permessi


klavs
22-11-2006, 20:55
ciao a tutti, premetti che ho installato una versione mambo 4.5.2 su hosting unix aruba.
Il mio problema è che da qualche tempo a questa parte non riesco a visualizzare più i pdf generati, o meglio il pdf lo crea ma è vuoto c'è sono la scritta in basso, non riesco a vedere la versione stampabile, o meglio apre il popup ma scrive il seguente messaggio Non sei autorizzato a visualizzare questa risorsa.: non dovrebbe scriverlo perché le pagine sono accessibili senza bisogno di registrazione e coumque anche loggandosi da lo stesso errore; stessa cosa per i sondaggi quando si va a votare da il messaggio Non sei autorizzato a visualizzare questa risorsa. . Nel lato amministrazione invece nella pagine relative alla modifica o creazione di articoli se si clicca sul titolo di un articolo per andare a modificarlo entra in una pagina che ha tutti i campi vuoti (come se si stesse creando un nuovo articolo) mentre bisogna per accedere in modifica o per qualsiasi altra operazione bisogna forza spuntare il check box e cliccare sul tasto corrispondente all'operazione da farsi.

La cosa strana è che ho provato il sito da diversi pc in alcuni visualizzo queste anomalie e in altri no. Tra l'altro se pulisco i cookies funziona tutto ma solo una volta cioè apro ad esempio la versione pdf, la chiudo se la riapro un'altra volta mi apre il pdf vuoto.

La cosa più strana è che sino a qualche tempo fa nella barra degli indirizzi l'url appariva nel seguente modo
nomedominio.it/index.php?option=com_content&task=view&id=4&Itemid=29
mentre ora appare così
nomedominio.it/content/view/4/29/

Se volete fare una prova il sito è www.radicagliari.it

Qualcuno mi può dare qualche lume?!?!?

Noffinganzo92
23-11-2006, 14:27
Originariamente inviato da klavs
ciao a tutti, premetti che ho installato una versione mambo 4.5.2 su hosting unix aruba.
Il mio problema è che da qualche tempo a questa parte non riesco a visualizzare più i pdf generati, o meglio il pdf lo crea ma è vuoto c'è sono la scritta in basso, non riesco a vedere la versione stampabile, o meglio apre il popup ma scrive il seguente messaggio Non sei autorizzato a visualizzare questa risorsa.: non dovrebbe scriverlo perché le pagine sono accessibili senza bisogno di registrazione e coumque anche loggandosi da lo stesso errore; stessa cosa per i sondaggi quando si va a votare da il messaggio Non sei autorizzato a visualizzare questa risorsa. . Nel lato amministrazione invece nella pagine relative alla modifica o creazione di articoli se si clicca sul titolo di un articolo per andare a modificarlo entra in una pagina che ha tutti i campi vuoti (come se si stesse creando un nuovo articolo) mentre bisogna per accedere in modifica o per qualsiasi altra operazione bisogna forza spuntare il check box e cliccare sul tasto corrispondente all'operazione da farsi.

La cosa strana è che ho provato il sito da diversi pc in alcuni visualizzo queste anomalie e in altri no. Tra l'altro se pulisco i cookies funziona tutto ma solo una volta cioè apro ad esempio la versione pdf, la chiudo se la riapro un'altra volta mi apre il pdf vuoto.

La cosa più strana è che sino a qualche tempo fa nella barra degli indirizzi l'url appariva nel seguente modo
nomedominio.it/index.php?option=com_content&task=view&id=4&Itemid=29
mentre ora appare così
nomedominio.it/content/view/4/29/

Se volete fare una prova il sito è www.radicagliari.it

Qualcuno mi può dare qualche lume?!?!?



Ti so aiutare solo per l' URL del sito.....premetto che io uso Joomla da un po' di tempo....
Hai installato un compoonente come Joomsef/Opensef?

klavs
23-11-2006, 17:27
no, non ho installato nessuno di questi componenti di cui mi parli

klavs
25-11-2006, 15:11
ho capito dov'è il problema anche se non ho risolto. Avevo aggiunto un include per poter agganciare un pannello statistiche: tpro2 e c'erano problemi perché sia mambo che quel sistema interrogavano i cookies.

rororob
19-12-2006, 16:37
Ciao
Scusami Io ho lo stesso problema con il mio joomla, mi da lo stesso errore quando provo a mandare via il modulo dei contatti del sito
"non sei autorizzato a visualizzare questa risorsa "
Come hai risolto?
grazie

Ar3s
28-12-2006, 12:14
Quando navighi nel tuo sito tieni d'occhio la barra degli indirizzi: a me succedeva che desse l'errore "non sei autorizzato a vedere questa risorsa" nel caso in cui dall'url del sito sparisse "www."; cioè fino a un attimo prima navigavo su http://www.xxxxxxx.it", e poi su "http://xxxxxx.it" senza motivazione, dando errori.

Controlla bene perchè è una cosa che si trova nei forum ufficiali di joomla.

Loading