PDA

Visualizza la versione completa : Installare linux su Tablet PC


pilovis
27-05-2007, 13:23
Ho installato Ubuntu 7.04 Desktop sul mio Samsung Q1 e sembra andare molto bene

Il wi-fi funziona tranne il WPA (accetta solo il WEP)

La scheda di rete viene vista correttamente


Il bluetooth funziona dopo aver installato gnome-bluetooth:
apt-get install gnome-bluetooth

Il video funziona a 640x480 ma e' una risoluzione troppo bassa e le finestre non vengono viste completamente (il pulsante "ok" e' quasi sempre irraggiungibile.
La risoluzione ottimale sarebbe 800x480 ma non capisco come impostarla :cry:

Qualcuno lo ha gia' fatto?

pilovis
27-05-2007, 13:28
Ho visto che per farla andare bisogna installare 915resolution in xorg.conf

apt-get install 915resolution

e poi settare 915resolution 50 800 480 32

Ma non so' come farlo :cry:

Io ho sempre e solo lavorato sui server linux in modalita' console :bh:

mi date un aiuto a configurare xorg.conf?

Grazie :ciauz:

psykopear
27-05-2007, 14:45
Originariamente inviato da pilovis
Ho visto che per farla andare bisogna installare 915resolution in xorg.conf

apt-get install 915resolution

e poi settare 915resolution 50 800 480 32

Ma non so' come farlo :cry:

Io ho sempre e solo lavorato sui server linux in modalita' console :bh:

mi date un aiuto a configurare xorg.conf?

Grazie :ciauz:

ci sono altri due 3ad simili che ti dovrebbero aiutare, se cerchi dovresti trovare la soluzione:D...

sacarde
27-05-2007, 15:34
http://foto-cs.de/blog/item/213

pilovis
27-05-2007, 16:16
quel link lo avevo gia' visto, ma non dice come configurare praticamente xorg.conf per far funzionare la modalita' 915resolution a 800x480

pilovis
27-05-2007, 19:46
Sono riuscito ad installare l'audio:


apt-get install build-essential

poi ho scaricato:

ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.14rc4.tar.bz2
ftp://ftp.alsa-project.org/pub/utils/alsa-utils-1.0.14rc4.tar.bz2
ftp://ftp.alsa-project.org/pub/lib/alsa-lib-1.0.14rc4.tar.bz2

Scompattati:

tar -jxvf ./alsa-driver-1.0.14rc4.tar.bz2
tar -jxvf ./alsa-lib-1.0.14rc4.tar.bz2
tar -jxvf ./alsa-utils-1.0.14rc4.tar.bz2

e instalati:

sudo -s
cd ./alsa-driver-1.0.14rc4
./configure
make
make install

cd ../alsa-lib-1.0.14rc4
./configure
make
make install

cd ../alsa-utils-1.0.14rc4
./configure
make
make install

poi ho aggiunto al file /etc/moprobe.d/alsa-base

la seguente riga:

options snd-hda-intel model=laptop-eapd

riavviato e l'audio ha funzionato

pilovis
02-06-2007, 21:51
Originariamente inviato da pilovis
Sono riuscito ad installare l'audio:


apt-get install build-essential

poi ho scaricato:

ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.14rc4.tar.bz2
ftp://ftp.alsa-project.org/pub/utils/alsa-utils-1.0.14rc4.tar.bz2
ftp://ftp.alsa-project.org/pub/lib/alsa-lib-1.0.14rc4.tar.bz2

Scompattati:

tar -jxvf ./alsa-driver-1.0.14rc4.tar.bz2
tar -jxvf ./alsa-lib-1.0.14rc4.tar.bz2
tar -jxvf ./alsa-utils-1.0.14rc4.tar.bz2

e instalati:

sudo -s
cd ./alsa-driver-1.0.14rc4
./configure
make
make install

cd ../alsa-lib-1.0.14rc4
./configure
make
make install

cd ../alsa-utils-1.0.14rc4
./configure
make
make install

poi ho aggiunto al file /etc/moprobe.d/alsa-base

la seguente riga:

options snd-hda-intel model=laptop-eapd

riavviato e l'audio ha funzionato

NOTA: e' necessario installare curses prima di compilare l'ultimo pacchetto alsa-utils-1.0.14rc4
io ho usato il comando:

sudo apt-get install curses?

Ho usato il punto interrogativo per installare tutto senza andare troppo per il sottile :)

pilovis
02-06-2007, 22:03
>PRIMA PARTE> Installazione bluetooh

ecco la sequenza di comandi e configurazioni:

sudo apt-get install gnome-bluetooth

sudo apt-get install bluez-utils bluez-pin bluez-gnome gnome-bluetooth nautilus-sendto obexftp

poi andare in Sistema > Preferenze > Sessioni e scegliere nuovo; nel campo comando basta scrivere

gnome-obex-server

qui trovate maggiori info: http://ubuntubox.wordpress.com/2007/03/31/il-bluetooth-funziona-con-ubuntu/

pilovis
02-06-2007, 22:12
<SECONDA PARTE> Connessione al modem del cellulare.

NOTA: accendete il cell e attivate il bluetooh

aprite la shell e digitate

hcitool inq

Il risultato dovrebbe essere piu o meno questo:

Inquiring
00:11:22:33:44:55 clock offset: 00359 class: 050020c

andate nella cartella /etc/bluetooth

cd /etc/bluetooth

Ci dovrebbero essere 2 files: rfcomm.conf e hcid.conf

Ecco come ho impostato i miei:

* rfcomm.conf

rfcomm0 {
bind yes;
# # Bluetooth address of the device
device 00:11:22:33:44:55;
# # RFCOMM channel for the connection
channel 1;
# # Description of the connection
comment "Nokia";
}

Ovvamente impostate il vostro indirizzo dove specificato (device).

Adesso aprite la Shell e digitate:

rfcomm bind rfcomm0 00:11:22:33:44:55 1

Per verificare che la creazione del dispositivo rfcomm sia avvenuta correttamente, digitate

rfcomm

Il risultato dovrebbe essere questo:

rfcomm0: 00:11:22:33:44:55 channel 1 clean

Se il canale dovesse essere closed, operate in questo modo:

rfcomm release all
rfcomm bind rfcomm0 00:11:22:33:44:55 1

A questo punto sempre con il comando rfcomm verificate che il canale sia clean

Quindi il modem del cell e' /dev/rfcomm0

la configurazione bluetooth terminata

l'articolo completo qui: http://3v1n0.tuxfamily.org/blog/inf...-via-bluetooth/

pilovis
02-06-2007, 22:17
<TERZA PARTE>Connessione ad Internet con il cell

connesisone GPRS/EDGE/UMTS

installare wvdial e Gnome-ppp

sudo apt-get install wvdial
sudo apt-get install gnome-ppp

aprite Gnome-ppp e impostelo in questo modo:

- Nome utente e password: Quelli richiesti dalla vostra connessione gprs. Per Tim possiamo metterli casualmente, tanto non servono.
- Numero di telefono:
*99#

Adesso cliccate su Configura e inserite nel riquadro del modem la stringa:
/dev/rfcomm0

Cliccate su Stringhe di Inizializzazione e inserite nella riga Init 2, la stringa di
connessione al GPRS del vostro gestore. Nel mio caso (TIM) :
AT+cgdcont=,"ip","ibox.tim.it"

Chiudete pure la finestra opzioni e cliccate su Connetti !

Il link al post originale: http://3v1n0.tuxfamily.org/blog/informatica/linux/connessione-gprsedgeumts-su-ubuntu-con-nokia-6630-via-bluetooth/

Loading