PDA

Visualizza la versione completa : raggiungibilita sito locale da esterno


 
AvOJaromil
07-11-2007, 18:26
salve

utilizzando l'account di no-ip.com volevo raggiungere da remoto il mio server web locale.
l'host name e l'indirizzo di no-ip funziona; se faccio un ping su miosito.no-ip.biz viene risolto.
quando invece utilizzo una connessione tramite http (http://miosito.no-ip.biz) si apre la pagina di configurazione del mio router.
ho provato allora ad aggiungere una nat sul router (usrobotics sureconnection) inserendo come ip l'indirizzo del mio serverweb 192.168.1.3 (mentre quello del router è 192.168.1.1) e come porta 8080 ma ancora niente.

come posso fare?

mille grazie

arrows
08-11-2007, 23:33
Se ti si apre la pagina di configurazione del router vuol dire che stai usando un pc collegato alla Lan. Devi provare con un pc connesso da una rete diversa.

morpheus106
09-11-2007, 10:55
oppure http://miosito.no-ip.biz:8080 e verifica se pure così funge.

Cmq fai la verifica da un'altra rete, è forviante fare la prova dalla rete interna.

AvOJaromil
09-11-2007, 11:49
avevo già provato con 8080. ho provato anche su un altra rete, ma stessa storia.

morpheus106
09-11-2007, 12:06
riesci a fare un print screen della maschera di configurazione del router?

AvOJaromil
09-11-2007, 14:29
ce ne sono parecchie di pagine di configurazione
ti posto quelle che credo utili
dimmi se manca qualcosa....

http://clipmarks.com/clipmark/F1E21629-7C07-4EA5-A620-71D3C11C68BA/
http://clipmarks.com/clipmark/F1398945-233D-4DB4-94F1-E9AC0D01CD06/
http://clipmarks.com/clipmark/0D28E9E5-C15E-4111-AA50-A2637B1C78D0/


mille grazie

morpheus106
09-11-2007, 16:06
come ho visto dai file stai dirottando (soprattutto) il traffico della porta 8080 verso il pc 192.168.1.3, dove credo risiede il server web, ma il servizio sei sicuro che stia girando su quel pc su quella porta 8080?
magari sta girando sulla 80, ma se tu lo specifichi nelle regole può creare conflitto con la porta 80 del accesso web del router.
Quindi o togli la spunta su wan al servizio http della prima figura (attento a non togliere lan altrimenti non accedi + al web del router) oppure verifichi se il servizio web sta girando sulla 8080.

Io fossi in te prima verificherei su che porta gira il servizio e semmai fai una prova a cambiare porta assegnandogli la 8080 e da come ho visto la configurazione di quella porta sul router sembra ok.

Fammi sapere.

arrows
09-11-2007, 16:15
Cioè aspetta, se digiti il tuo indirizzo ip da un altra rete esce la pagina di configurazione del router?

AvOJaromil
09-11-2007, 16:26
sono sicuro che il web server apache gira all'indirizzo 192.168.1.3 alla porta 8080

ecco il risultato di alcune prove,
con il browser tento di connettermi ai seguenti indirizzi:

http://127.0.0.1 --> "pagina iniziale iis"
http://127.0.0.1:8080 --> "pagina iniziale apache"

http://192.168.1.1 --> pagina di configurazione router
http://192.168.1.1:8080 --> "errore: connessione fallita"
http://192.168.1.3 --> "errore: No web site is configured at this address."
http://192.168.1.3:8080 --> "pagina iniziale apache"

http://151.51.40.153(indirizzo no-ip.com) --> pagina di configurazione router
http://151.51.40.153:8080 --> "errore: connessione fallita"
http://qvaioe.no-ip.biz(alias no-ip.com) --> pagina di configurazione router
http://qvaioe.no-ip.biz:8080 --> "errore: connessione fallita"

avast e firewall di windows disattivati


Quindi o togli la spunta su wan al servizio http della prima figura
..tolta

morpheus106
09-11-2007, 16:30
è meglio quando pubblichi se mascheri gli ultimi ip pubblici del tuo router, per questioni di sicurezza fin quando non finisci di configurare tutto

Loading