PDA

Visualizza la versione completa : file di sistema danneggiati in vista


 
Old Rub
05-08-2008, 11:22
Installando il SP1 di vista mi da errore e mi consiglia di eseguire lo strumento Controllo file di sistema. Al termine del controllo mi dice che è impossibile ripristinare alcuni file danneggiati trovati e mi dice che i dettagli sono nel file CBS.log a questo punto vado a cercare il file e quando lo apro mi dice accesso negato. A questo punto vorrei sapere se qualcuno è in grado di dirmi come poter accedere al file e dopo aver fatto l'accesso mi può spiegare come poter risolvere il mio problema.

Il percorso del file è C:\Windows\Logs\CBS\CBS.log

:dhò:

Alfabeta1
05-08-2008, 20:03
a questo punto vado a cercare il file e quando lo apro mi dice accesso negato
Questo accade, come in xp del resto, perchè accedendo come quest, non hai i diritti per visualizzare questo file.
Puoi ovviare in 2 modi.
1. accedi come amministrator.
2. assumi i diritti di lettura e modifica per quella cartella, se non è possibile, per quella immediatamente superiore.


A questo punto vorrei sapere se qualcuno è in grado di dirmi come poter accedere

In queste due pagine è spiegato come fare.

1 (http://www.blogvista.it/come-diventare-proprietari-di-un-file-anche-di-sistema-su-windows-vista-allo-scopo-di-poterlo-modificare-2313.html)

2 (http://windowshelp.microsoft.com/Windows/it-IT/help/31ad4562-aee7-4fed-8316-89114dc973031040.mspx)


e dopo aver fatto l'accesso mi può spiegare come poter risolvere il mio problema

Qui dipende, se scandisk non è in grado di risolvere il problema, molto probabilmente i file sono talmente danneggiati da richiedere la loro sostituzione.
Come farlo, dipende molto da quali file sono danneggiati, leggi il log e poi vedremo.

Ciao

Old Rub
05-08-2008, 21:03
Grazie mille, sono finalmente riuscito ad accedere... ora se c'è qualche buona anima disposta ad aiutarmi le sarei infinitamente grato.
Siccome c'è scritto troppa roba e lasciando solo gli errori superavo il limite di caratteri per post ho caricato su un mio sito il file. Questo è il link (http://dsp.netsons.org/CBS.log)

Alfabeta1
06-08-2008, 01:25
ora se c'è qualche buona anima disposta ad aiutarmi le sarei infinitamente grato......

Di " buone anime ", ne conosco molte, ma ormai saranno tutte in ferie, beati loro.... :cry: :cry:


Siccome c'è scritto troppa roba e lasciando solo gli errori superavo il limite di caratteri per post ho caricato su un mio sito il file

Ho visto... veramente molta roba.
Non tutta necessaria, il log è lungo perchè ci sono tutte le voci di ogni tentativo di installare il sp1 che hai fatto, la prossima volta, opera cosi: elimina il log, fai il tentativo, e posti il relativo log. in questo modo avrai solo il log del tentativo fatto.


dopo aver fatto l'accesso mi può spiegare come poter risolvere il mio problema

Possiamo provarci......

Mi par di capire che il tuo problema e essenzialmente di proprietà ed autorizzazioni ad operare sui file di sistema, prendendo in esame solo l'ultimo tentativo nel log, essenzialmente dice che non riesce a spostare file dalla cartella temp a cartelle di sistema.

Io per superare il problema opererei cosi:

1. Farei uno scandisk completo sul disco che mi da gli errori, per avviarlo:
in una cartella che visualizzi tutti i dischi presenti nel computer, clic dx sul disco da controllare, proprietà, strumenti, esegui scandisk, con tutte le opzioni selezionate, se dovesse dirti che non può essere fatto in quel momento, per via di file in uso, e di programmarlo all'avvio, fallo all'avvio del computer.
In questo modo saremo sicuri che tutto quello che può venire sistemato verrà sistemato.

2. Ora dobbiamo superare le limitazioni in scrittura che hai sulle cartelle di sistema, puoi farlo in due modi:
1. Entrare nel sistema come amministratore, in questo modo l'sp1 verrebbe correttamente installato.

2. Se non sai o non puoi farlo, diventa proprietario, con account attuale di tutte le cartelle del disco dove è installato Vista, supponendo che vista è installato in "C", aprilo in esplora risorse e assumi il controllo completo di ogni cartella presente, con la procedura descritta nel precedente post, assumi sia il controllo in lettura che in scrittura.
Ora dovresti essere in grado di installare il service pack 1.

Ora per la sicurezza, se non sei entrato con un account di amministratore, dovresti tornare a rimettere i privilegi come erano prima di modificarli.
Vista, finalmente sui sistemi windows, gestisce bene la differenza tra utente amministratore e utente utilizzatore, ed è un peccato non farne uso.

Però, non riesco a spiegarmi i tuoi problemi di privilegi, se una operazione ha bisogno di privilegi di amministratore, vista , di solito, lo chiede, acconsentendo alla richiesta l'operazione viene portata a buon termine.
Certo la gestione account non deve essere stata modificata.

Prova a vedere se riesci ad installare il SP1 finalmente.

Ciao

Old Rub
06-08-2008, 06:59
Di problemi di privilegi ne ho avuti tanti, per esempio già con hijackthis cliccavo per eseguirlo come amministratore e puntualmente non lo faceva, per fortuna che ho un solo account sul pc :confused:

comunque ora provo come hai detto te sperando che me lo installi

Old Rub
06-08-2008, 08:18
Come non detto... non me lo installa lo stesso e lo scanDisck non mi sembra che abbia detto che ci sono errori :dhò:

Alfabeta1
06-08-2008, 11:10
.....non me lo installa lo stesso.....

Bene... anzi male... anche vista ha preso lo stesso vizio di xp, fa quello che dice lui......
forse di più..... :dhò: :dhò:

Non è molto che uso vista, quindi devo informarmi e spulciare bene il log, che è chilometrico.
Intanto ti lascio altre pagine di soluzioni per problemi di installazione del service pack, chissà se queste procedure possano esserti utili.

1 (http://support.microsoft.com/kb/947366)
2 (http://www.winvistaclub.com/t67.html)
Nella seconda pagina ci sono altri link.

Mi aiuteresti molto se riuscissi a postarmi l'errore esatto che esce, anche uno sguardo al visualizzatore eventi, dopo un fallito tentativo, sicuramente ci sarà un registro che riporterà l'errore, se riesci a postarlo, avremo " id" e "modulo" che ha provocato l'errore.

Per ultimo potresti provare ad attivare l'account amministratore, in queste pagine è spiegato come fare:
1 (http://www.tech-faq.com/lang/it/enable-windows-vista-administrator-account.shtml&usg=ALkJrhjTpxEaPJ0UyZojOH-VlWs9G7RPqA)
2 (http://www.chatincanto.com/2008/03/02/sbloccare-l%E2%80%99account-amministratore-segreto-presente-in-windows-vista/)
Oppure creare ex-novo un account amministratore, tramite la voce account, presente nel pannello di controllo.

Ciao

Old Rub
06-08-2008, 11:58
questo è il messaggio di errore che viene durante l'installazione:
http://img247.imageshack.us/my.php?image=dsdfbc8.jpg

Alfabeta1
06-08-2008, 13:05
La copia di windows vista è regolarmente attivato con regolare licenza?
Ciao

Old Rub
06-08-2008, 13:11
Tutto originale

Loading