PDA

Visualizza la versione completa : Connessione a internet tramite rete lan


 
spiderontheweb
09-08-2008, 15:05
Ciao a tutti :)

Un po' di tempo fa ho creato una rete lan tra 2 pc con un router wi-fi. Un pc desktop collegato con cavo ethernet e un notebook collegato con wi-fi. Oggi ho collegato il notebook con cavo ethernet e sono successe 2 cose:
1) la rete lan funziona e riesco ad accede ai dischi
2) con il notebook non riesco a connettermi a internet

Come posso risolvere il punto 2? :confused:

:ciauz:

cleaner
09-08-2008, 22:58
prima, quando collegavi solo il laptop tramite wifi al router, funzionava internet? nella maggior parte dei router devi indicare tu il permesso di condividere la connessione internet, non è automatica la cosa; l'accesso alle risorse condivise non è prerogativa di accesso "all'esterno".
per cui, io procederei così:
una volta collegato il router al laptop prova a pingarne l'ip_gateway, magari è un problema di scheda eth..iniziamo ad eliminare possibilità in tanto ^^

Andrea786
10-08-2008, 10:57
Originariamente inviato da cleaner
prima, quando collegavi solo il laptop tramite wifi al router, funzionava internet? nella maggior parte dei router devi indicare tu il permesso di condividere la connessione internet, non è automatica la cosa; l'accesso alle risorse condivise non è prerogativa di accesso "all'esterno".
per cui, io procederei così:
una volta collegato il router al laptop prova a pingarne l'ip_gateway, magari è un problema di scheda eth..iniziamo ad eliminare possibilità in tanto ^^

Mi sa che piu questione di condivisione della connessione di rete deve settare la scheda di rete bene perche se il collegamento con il cavo di rete lo fa sul router non serve la condivisione perche il notebook vada in internet poiche non è connesso tramite il pc ma direttamente al router . Probabilmente avra configurato sul notebook lo stesso ip che ha sul pc fisso o si è dimenticato di mettere i dns .

Meglio che ci metta la configurazione della scheda di rete del notebook e del fisso .

spiderontheweb
10-08-2008, 16:20
Con il wifi funziona tutto e riesco a fare il ping.

Se collego con il cavo, dal router non riesco a pingare il pc e viceversa

Andrea786
10-08-2008, 16:44
Originariamente inviato da spiderontheweb
Con il wifi funziona tutto e riesco a fare il ping.

Se collego con il cavo, dal router non riesco a pingare il pc e viceversa

Mettici qua la configurazione di rete che hai nel pc fisso e quella del notebook quando lo connetti via cavo

spiderontheweb
11-08-2008, 12:59
Cosa intendi per configurazione di rete?

Andrea786
11-08-2008, 14:34
Originariamente inviato da spiderontheweb
Cosa intendi per configurazione di rete?

Ip della scheda di rete del pc fisso e del notebook
Subnet mask della scheda di rete del pc fisso e del notebook
Gateway della scheda di rete del pc fisso e del notebook

In questa maniera vediamo se la configurazione è corretta , vedi foto sotto :

http://img509.imageshack.us/img509/573/snap1heo4.th.jpg (http://img509.imageshack.us/my.php?image=snap1heo4.jpg)

spiderontheweb
11-08-2008, 16:01
IP:
-) scheda di rete notebook 192.168.0.157
-) scheda di rete pc fisso 192.168.0.101

SUBNET MASK:
-) scheda di rete notebook 255.255.255.0
-) scheda di rete pc fisso 255.255.255.0

GATEWAY:
-) scheda di rete notebook 192.168.0.1
-) scheda di rete pc fisso 192.168.0.1

Andrea786
11-08-2008, 16:07
Prova a impostare le schede ethernet ( via cavo ) cosi :


IP:
-) scheda di rete notebook 192.168.0.102
-) scheda di rete pc fisso 192.168.0.101

SUBNET MASK:
-) scheda di rete notebook 255.255.255.0
-) scheda di rete pc fisso 255.255.255.0

GATEWAY:
-) scheda di rete notebook 192.168.0.1
-) scheda di rete pc fisso 192.168.0.1

Probabilmente avendo 156 Ip di differenza tra la scheda di rete del fisso e il notebook sul cavo di rete il modem non ti vede come un pc abilitato per internet .

In questa maniera dovresti risolvere il problema , ti consiglio comunque di impostare la LAN in manuale in modo che hai la possibilita di configuare anche le porte sul Nat :D

spiderontheweb
11-08-2008, 16:57
1) Ho impostato gli indirizzi sul router (da dinamico a statico)
2) All'avvio il notebook non riusciva a rilevare le impostazioni automaticamente e ho messo gli indirizzi ip manualmente
3) Ho riavviato

Non funziona. Funziona solo la LAN.

Ho notato che se vado in "connessioni di rete" sul pc fisso c'è un'icona "gateway internet", ma non so più come l'avevo creata... Sul notebook non c'è :bhò:

Loading