PDA

Visualizza la versione completa : knoppix installato: switch impostazioni?


mschievano
08-04-2004, 10:35
Se ho installato knoppix con modalitÓ "knoppix" e volessi passare a modalitÓ "debian", posso farlo?

Knoppix Ŕ giÓ installato sull' HD

raistlin76
08-04-2004, 11:16
Scusa, ma non capisco cosa vuoi dire. Knoppix E' Debian.
La Debian che adesso ti ritrovi installato Ŕ di tipo testing (Sarge).

:ciauz:

Valentino1
08-04-2004, 11:20
cosa significa di tipo testing ?

Ŕ una versione limitata?

urodelo
08-04-2004, 11:22
Ci sono 3 versioni:
-stabile
-non stabile
-test

che corrispondono a
-Woody
-Sid
-Sarge

mschievano
08-04-2004, 11:27
script di installazione di knoppix permette di installare knoppix in modo simile al CD (stesso desktop,sfondo, ecc) o in modalitÓ distribuzione classica.

[]v[]aStEr
08-04-2004, 11:40
Credo dovresti reinstallarla da capo, come distribuzione classica.

urodelo
08-04-2004, 11:45
questa mi giunge nuova...

e qual Ŕ la differenza? In modalitÓ debian ti permette di installare solo i pacchetti che vuoi?

Alessio Gi
08-04-2004, 20:52
Knoppix Ŕ giÓ installato sull' HD

Quale versione di knoppix hai installato la 3.3 o la 3.4? Quale script hai usato per installarlo knx-hdinstall o knoppix-installer?
Se fai una ricerca sul forum troverai tutte le risposte ai tuoi dubbi su knoppix, anche su come installarla su hd.
Ad esempio qui (http://forum.html.it/forum/showthread.php?s=&threadid=621362) .


Ciao. :ciauz:

francofait
09-04-2004, 21:42
Originariamente inviato da Alessio Gi
Quale versione di knoppix hai installato la 3.3 o la 3.4? Quale script hai usato per installarlo knx-hdinstall o knoppix-installer?
Se fai una ricerca sul forum troverai tutte le risposte ai tuoi dubbi su knoppix, anche su come installarla su hd.
Ad esempio qui (http://forum.html.it/forum/showthread.php?s=&threadid=621362) .


Ciao. :ciauz:

Mi sembra chiaro che ha installato Knoppix 3.3 con knoppix-installer -

Per portarlo in modalita debian , dovresi scaricarti rcconf - disabilitare il demone x l'avvio in modalitÓ knoppix ( in pratica con tutta la procedura knoppix ,di riconoscimento delle periferiche ad avvio sistema)
apt-get rcconf - lo lanci da console - a quel punto giÓ che sei li , disabiliti anche tutti i servizi che non utilizzi)

mschievano
07-05-2004, 22:43
root@ttyp0[knoppix]# apt-get -f install
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Correzione delle dipendenze in corso... Fatto
I seguenti pacchetti verranno inoltre installati:
karm kdelibs-data kdepim-kfile-plugins kdepim-kio-plugins kgpgcertmanager
kmail kmailcvt knode knotes konsolekalendar kontact korn ktnef libkcal2
libkdenetwork2 libkdepim1 libkdgantt0 libkgantt0 libkpimexchange1 libksieve0
libmal1 libmimelib1 libncurses5 libncurses5-dev
I seguenti pacchetti saranno RIMOSSI:
kdepim-libs
I seguenti pacchetti NUOVI (NEW) saranno installati:
kdepim-kio-plugins knode konsolekalendar kontact korn ktnef libkcal2
libkdepim1 libkdgantt0 libkgantt0 libkpimexchange1 libksieve0 libmal1
The following packages will be upgraded:
karm kdelibs-data kdepim-kfile-plugins kgpgcertmanager kmail kmailcvt knotes
libkdenetwork2 libmimelib1 libncurses5 libncurses5-dev
11 aggiornati, 13 installati, 1 da rimuovere e 651 non aggiornati.
22 non completamente installati o rimossi.
╚ necessario prendere 0B/13,2MB di archivi.
Dopo l'estrazione, verranno occupati 12,5MB di spazio su disco.
Continuare? [S/n] S
(Lettura del database ... 103278 file e directory attualmente installati.)
Preparativi per il rimpiazzo di kdelibs-data 4:3.1.5-1 (usando .../kdelibs-data_
4%3a3.2.2-2_all.deb) ...
Spacchetto il rimpiazzo di kdelibs-data ...
Rimpiazzo i file nel vecchio pacchetto koffice-data ...
dpkg: errore processando /var/cache/apt/archives/kdelibs-data_4%3a3.2.2-2_all.de
b (--unpack):
tentata sovrascrittura di `/usr/share/mimelnk/application/vnd.sun.xml.calc.desk
top', che si trova anche nel pacchetto openoffice-de-en
dpkg-deb: il sottoprocesso paste Ŕ stato terminato dal segnale (Pipe rotta)
Sono occorsi degli errori processando:
/var/cache/apt/archives/kdelibs-data_4%3a3.2.2-2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)




root@ttyp0[knoppix]# apt-get remove openoffice-de-en
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
╚ consigliabile eseguire 'apt-get -f install' per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
kaddressbook: Dipende: libkdepim1 (>= 4:3.2.2) ma non sta per essere installato
kalarm: Dipende: libkcal2 (>= 4:3.2.2) ma non sta per essere installato
Dipende: libkdenetwork2 (>= 4:3.2.2) ma 4:3.1.5-1 sta per essere installato
Dipende: libkdepim1 (>= 4:3.2.2) ma non sta per essere installato
kandy: Dipende: libkdepim1 (>= 4:3.2.2) ma non sta per essere installato
kdelibs4: Dipende: kdelibs-data (>= 4:3.2.1) ma 4:3.1.5-1 sta per essere installato
kdepim: Dipende: karm (>= 4:3.2.2-2) ma 4:3.1.5-1 sta per essere installato
Dipende: kdepim-kfile-plugins (>= 4:3.2.2-2) ma 4:3.1.5-1 sta per essere installato
Dipende: kdepim-kio-plugins (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: kgpgcertmanager (>= 4:3.2.2-2) ma 4:3.1.5-1 sta per essere installato
Dipende: kmail (>= 4:3.2.2-2) ma 4:3.1.5-1 sta per essere installato
Dipende: kmailcvt (>= 4:3.2.2-2) ma 4:3.1.5-1 sta per essere installato
Dipende: knode (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: knotes (>= 4:3.2.2-2) ma 4:3.1.5-1 sta per essere installato
Dipende: konsolekalendar (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: kontact (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: korn (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: ktnef (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: libkcal2 (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: libkdenetwork2 (>= 4:3.2.2-2) ma 4:3.1.5-1 sta per essere installato
Dipende: libkdepim1 (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: libkdgantt0 (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: libkgantt0 (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: libkpimexchange1 (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: libksieve0 (>= 4:3.2.2-2) ma non sta per essere installato
Dipende: libmimelib1 (>= 4:3.2.2-2) ma 4:3.1.5-1 sta per essere installato
korganizer: Dipende: libkcal2 (>= 4:3.2.2) ma non sta per essere installato
Dipende: libkdepim1 (>= 4:3.2.2) ma non sta per essere installato
Dipende: libkdgantt0 (>= 4:3.2.2) ma non sta per essere installato
Dipende: libkgantt0 (>= 4:3.2.2) ma non sta per essere installato
Dipende: libkpimexchange1 (>= 4:3.2.2) ma non sta per essere installato
kpilot: Dipende: libkcal2 (>= 4:3.2.2) ma non sta per essere installato
Dipende: libmal1 ma non sta per essere installato
Dipende: libncurses5 (>= 5.4-1) ma 5.3.20030719-5 sta per essere installato
ksync: Dipende: libkcal2 (>= 4:3.2.2) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare 'apt-get -f install' senza pacchetti (o specificare una soluzione).
root@ttyp0[knoppix]#

:dh˛:

Loading