PDA

Visualizza la versione completa : skype "Sound device is not defined"


nik600
19-11-2004, 16:59
ciao

dopo aver formattato non mi funziona + skype! guardando i log all'avvio leggo:



Sound device is not defined



nelle impostazioni ho visto la sezione audio devices che contiene:

/dev/dsp

inoltre la device "ringing" Ŕ in grigetto e non la posso modificare...forse Ŕ impostata una device sbagliata?

come posso sapere la mia device audio?

(che funziona correttamente...ad esempio ora sto ascoltando musica con xmms)

thnks

gigyz
19-11-2004, 19:42
skype usa oss quindi se usi alsa assicurati di aver caricato il modulo di compatibilitÓ OSS, poi controlla i permessi sul device.

nik600
20-11-2004, 11:28
ciao questa Ŕ la configurazione del mio kernel..sbaglio o i moduli sono inseriti direttamente nel kernel? come verifico che i moduli siano stati caricati?

grazie


<*> Advanced Linux Sound Architecture │ │
│ │ <*> Sequencer support │ │
│ │ < > Sequencer dummy client │ │
│ │ <*> OSS Mixer API │ │
│ │ <*> OSS PCM (digital audio) API │ │
│ │ OSS Sequencer API │ │
│ │ [ ] Verbose printk │ │
│ │ [ ] Debug │ │
│ │ Generic devices ---> │ │
│ │ ISA devices ---> │ │
│ │ PCI devices ---> │ │
│ │ ALSA USB devices --->



posto lsmod



Module Size Used by
b44 23556 0
ipw2100 144752 0
firmware_class 11520 1 ipw2100
ieee80211 20228 1 ipw2100
ieee80211_crypt 7172 1 ieee80211
ntfs 161304 1
fglrx 233564 9
freq_table 5536 0
cpufreq_powersave 2944 0



:ciauz:

gigyz
20-11-2004, 12:41
sono compilati staticamente quindi i moduli giustamente non esistono perchŔ i "driver" fanno parte integrante del kernel, hai controllato i permessi sul device, prova pure a lanciare skype da root e vedi che succede

nik600
21-11-2004, 15:41
skype da root:



root@criminal:/programmi/skype-0.92.0.12$ ./skype
Engine::init invoked. user is
Sound device is not defined
Engine::init success
UI: Engine::Engine credentials loaded
SkyWindowBase::onlineStatusChanged setting pixmap
DialPad: DialPad
QFont::setPointSize: Point size <= 0 (-1)
language selected: 5
Engine::init invoked. user is nik600
Sound device is not defined



:dh˛:

gigyz
21-11-2004, 20:00
anche a me scrive cosý, ma poi se metto l'utente mi compare la cornetta verde, finchŔ non specifichi chi vuoi chiamare le icone sono grigie

Loading