PDA

Visualizza la versione completa : desktop?!


Geppo Hylar
10-01-2006, 15:06
Allora vi spiego l amia situazione: Dopo aver scaricato con bit torrent i 2 DvD della debian, nell'installare si blocca perchè sembra che il primo dvd sia corrotto.
Allora reinstallo tutto con la versione minimale da 100Mb.
Mi ritrovo quindi davanti la console comandi:
Installto con get-install kdm, kdebase, x-window-system-core
Cosa mi manca per vedere uno straccio di interfaccia grafica????
Io scrivo startx dalla console comandi e non parte una fava...
Scusate lo sfogo, ma è una settimana che provo, leggo roba in rete ecc... ed ancora neinte.

metal milita
10-01-2006, 15:40
ti compare un messaggio di errore?
scrivilo qui.

francofait
10-01-2006, 15:47
fai prima con tasksel e selezionare desktop dal menu, te lo scarica e te lo scodella pronto x l'uso da se.

submax82
10-01-2006, 18:39
potevi installare una distro più "facile" se sei nuovo di linux come kubuntu.

hai configurato il server x??? cosa ti dice startx???

andy caps
10-01-2006, 19:49
dpkg-reconfigure xserver-free86

hai provato a darlo

devi configurare correttamente il serverx se è installato
in genere lo fa da se ma se sbagli qualcosa durante l'installazione devi farlo manualmente

non usare il framebuffer quando lo chiede
usa un driver vesa che va con tutte le schede durante il dpkg-reconfigure xserver-free86

Geppo Hylar
11-01-2006, 15:43
Si ho provato a configurare il serverx con il comando:
dpkg-reconfigure xserver-free86
ma pur tentando con tutti i tipi di risoluzioni ed in vari modi, alla fine dando il comando startx da sempre un errore, che ora non ricordo, ma la prox volta me la annoterò su carta e la trascrivo su questo post.
PS
Ora allora provo con un driver vesa

Geppo Hylar
11-01-2006, 18:59
Originariamente inviato da andy caps
usa un driver vesa che va con tutte le schede durante il dpkg-reconfigure xserver-free86

ANDY TI AMOOOOOOOOOOO
:zizi: :yuppi:
sono entrato nel magico modo di linux
Funziona!
Sai però che ora si aprono un nuovo capitolo di infinite domande, vero!?
La prima è che anche se ho abilitato gli eventi della rotella del mause durante la configurazione di:
dpkg-reconfigure xserver-free86
non ne vuole sapere di funzionare. Come mai?

andy caps
11-01-2006, 20:26
dovevi scegliere il protocollo ImPS2 non ps2
comunque puoi anche modificare il file di configurazione manualmente

installa magari mc se non c'è
poi in un terminale di root

(scrivi su (esse u ) in un terminale e edita il file

mcedit /etc/X11/XF86Config-4

per editarlo

poi nella sezione del mouse correggi cosi

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection


per salvare il file basta premere F2 e F10 per uscire da mc

Geppo Hylar
11-01-2006, 21:17
Mitico! Ho installato mc e dopo un po di perizie con il filexf86Config-4 ora la rotella del mouse funziona!!
Pensa che la prima volta avevo cancellato la sezione
Identifier "Generic Mouse"
perchè mi sembrava un inutile doppione!
Quando ho visto che non funzionava più niente, mi era venuto il panico :oVVoVe: ma per fortuna mi ricordavo come andava riscritto tutto :)
Devo a tutti un sincero "grazie!", ma a te Andy credo proprio che questa notte ti sognerò!

...mio salvatore! :cry: :smack:

Loading