Credo che sia il modo migliore. Per comodità, magari utilizza un nome per il campo che non differisca per il solo "case" (maiuscolo/minuscolo), ad esempio chiamandolo _MyDbAdapter o m_MyDbAdapter o mMyDbAdapter.Originariamente inviato da EmanueleTo
in effetti CREDO di aver risolto proprio facendo come dice Alka, ma forse in modo meno "publico"
codice:.................... private OleDbDataAdapter mydbadapter; public OleDbDataAdapter MyDBAdapter { get { return mydbadapter; } } .................
o dichiarto nella mia classe base
Puoi anche scrivere più semplicementeOriginariamente inviato da EmanueleTo
richiutilizzandolo poi nell'altra classe....
il risultato sembra essere corretto...codice:........................... base.Adattatore.Update(); ...................
senza utilizzare base, in quanto si tratta sempre della stessa proprietà.codice:...... MyDbAdapter.Update(); ......
Ciao!![]()

Rispondi quotando