Visualizzazione dei risultati da 1 a 7 su 7

Discussione: z-index su flash

  1. #1

    z-index su flash

    Ho un div viene visualizzato o nascosto al click su un link, ma rimane sempre dietro al flash contenuto nella pagina. Non è possibile posizionare un div sopra un oggetto flash?

  2. #2
    Utente di HTML.it L'avatar di Xinod
    Registrato dal
    Sep 2000
    Messaggi
    13,651
    lo z-index, come nel caso delle select, e' ininfluente;
    devi pubblicare l' swf con l' opzione finestra settata a opaque windowless o transparent windowless

    o manipolare direttamente il codice che incorpora l' swf
    codice:
    <OBJECT ...><PARAM NAME=wmode VALUE=opaque>...<EMBED ... wmode="opaque" ...></EMBED></OBJECT>
    da quel punto in poi decide la versione del flash player installato sul browser:
    con la 7 vedo i livelli sopra agli swf, almeno con IE e mozilla vari su piattaforma windows

    ciao

  3. #3
    Grazie, funziona. Già che ci siamo, c'è un modo per far "digerire" flash a IE6 sp2, senza l'alert per sbloccare il contenuto?

  4. #4
    Utilizza lo javascript che trovi a questo link
    http://www.fcservice.com/AC_RunActiveContent.zip
    e l'oggetto swf nel file html lo richiami come sotto, ovviamente i valori li devi sostituire con i toui:


    <div align="center">
    <script type="text/javascript">
    AC_FL_RunContent(
    'classid','clsid:d27cdb6e-ae6d-11cf-96b8-444553540000',
    'codebase','http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0',
    'id','squares',
    'movie','squares',
    'src','squares',
    'quality','high',
    'bgcolor','#8d0f09',
    'width','550',
    'height','450',
    'name','squares',
    'align','middle',
    'allowScriptAccess','sameDomain',
    'type','application/x-shockwave-flash',
    'pluginspage','http://www.macromedia.com/go/getflashplayer'
    );
    </script>
    </div>

  5. #5

    AIUTOOOOOOOOOO

    anche io avevo lo stesso tipo di problema ma ho risolto impostando il wmode trasparent. Ora però mi è nato un secondo problema... ho una visualizzazione perfetta con tutti i browser solamente che con ie nn riesco a clikkare sui pulsanti del sottomenu perche si che appaiono al passaggio del mouse ma scompaiono quando cerco di andarci sopra...le ho provate tutte e ho la testa che scoppia...per favore datemi una mano!!!!

    SCUSATE se sbaglio a postare

  6. #6
    Ciao a tutti..
    Ho un piccolo problema:

    Cioé ho un menu a tendina fatto coi css in un div. Il div sottostante ha una slide flash...
    Le tendine vanno sotto al flash...

    Pensavo di aver risolto con il metodo
    codice:
    <OBJECT ...><PARAM NAME=wmode VALUE=opaque>...<EMBED ... wmode="opaque" ...></EMBED></OBJECT>
    proposta da voi.

    Ma su ie decide di non funzionare (nello specifico 7 e 8...)
    su chrome va che é una meraviglia, su firefox pure.
    Avete idea di come sia possibile??!?!

    Aiuto, please!!!!
    :-)

  7. #7
    Amministratore L'avatar di Vincent.Zeno
    Registrato dal
    May 2003
    residenza
    Emilia-Romagna (tortellini und cappelletti land!)
    Messaggi
    20,056
    @vita.solitaria

    thread troppo vecchio:
    riproponine uno nuovo,
    questo lo chiudo

    ciao

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2021 vBulletin Solutions, Inc. All rights reserved.