Visualizzazione dei risultati da 1 a 6 su 6
  1. #1
    Utente di HTML.it
    Registrato dal
    Jan 2004
    Messaggi
    378

    407 Proxy Authentication Required su terminale

    Salve a tutti!
    Ho provato a lanciare apg-get update ma mi restituisce un messaggio di errore di questo tipo:
    root@lunatico-laptop:~# apt-get update
    Ign http://it.archive.ubuntu.com edgy Release.gpg
    Ign http://security.ubuntu.com edgy-security Release.gpg
    Ign http://easyubuntu.cafuego.net main Release.gpg
    Ign http://it.archive.ubuntu.com edgy/main Translation-it
    Ign http://security.ubuntu.com edgy-security/main Translation-it
    Ign http://easyubuntu.cafuego.net main/easyubuntu Translation-it
    Ign http://it.archive.ubuntu.com edgy/restricted Translation-it
    Ign http://security.ubuntu.com edgy-security/restricted Translation-it
    Ign http://easyubuntu.cafuego.net main Release
    Ign http://it.archive.ubuntu.com edgy-updates Release.gpg
    Ign http://security.ubuntu.com edgy-security Release
    Ign http://easyubuntu.cafuego.net main/easyubuntu Packages
    Ign http://it.archive.ubuntu.com edgy-updates/main Translation-it
    Ign http://security.ubuntu.com edgy-security/main Packages
    Err http://easyubuntu.cafuego.net main/easyubuntu Packages
    407 Proxy Authentication Required
    Ign http://it.archive.ubuntu.com edgy-updates/restricted Translation-it
    Ign http://security.ubuntu.com edgy-security/restricted Packages
    Ign http://it.archive.ubuntu.com edgy Release
    Ign http://security.ubuntu.com edgy-security/main Sources
    Ign http://it.archive.ubuntu.com edgy-updates Release
    Ign http://it.archive.ubuntu.com edgy/main Packages
    Ign http://security.ubuntu.com edgy-security/restricted Sources
    Ign http://it.archive.ubuntu.com edgy/restricted Packages
    Err http://security.ubuntu.com edgy-security/main Packages
    407 Proxy Authentication Required
    Ign http://it.archive.ubuntu.com edgy/main Sources
    Ign http://it.archive.ubuntu.com edgy/restricted Sources
    Err http://security.ubuntu.com edgy-security/restricted Packages
    407 Proxy Authentication Required
    Ign http://it.archive.ubuntu.com edgy-updates/main Packages
    Err http://security.ubuntu.com edgy-security/main Sources
    407 Proxy Authentication Required
    Ign http://it.archive.ubuntu.com edgy-updates/restricted Packages
    Ign http://it.archive.ubuntu.com edgy-updates/main Sources
    Err http://security.ubuntu.com edgy-security/restricted Sources
    407 Proxy Authentication Required
    Ign http://it.archive.ubuntu.com edgy-updates/restricted Sources
    Err http://it.archive.ubuntu.com edgy/main Packages
    407 Proxy Authentication Required
    Err http://it.archive.ubuntu.com edgy/restricted Packages
    407 Proxy Authentication Required
    Err http://it.archive.ubuntu.com edgy/main Sources
    407 Proxy Authentication Required
    Err http://it.archive.ubuntu.com edgy/restricted Sources
    407 Proxy Authentication Required
    Err http://it.archive.ubuntu.com edgy-updates/main Packages
    407 Proxy Authentication Required
    Err http://it.archive.ubuntu.com edgy-updates/restricted Packages
    407 Proxy Authentication Required
    Err http://it.archive.ubuntu.com edgy-updates/main Sources
    407 Proxy Authentication Required
    Err http://it.archive.ubuntu.com edgy-updates/restricted Sources
    407 Proxy Authentication Required
    Impossibile ottenere http://easyubuntu.cafuego.net/dists/...86/Packages.gz 407 Proxy Authentication Required
    Impossibile ottenere http://security.ubuntu.com/ubuntu/di...86/Packages.gz 407 Proxy Authentication Required
    Impossibile ottenere http://security.ubuntu.com/ubuntu/di...86/Packages.gz 407 Proxy Authentication Required
    Impossibile ottenere http://security.ubuntu.com/ubuntu/di...rce/Sources.gz 407 Proxy Authentication Required
    Impossibile ottenere http://it.archive.ubuntu.com/ubuntu/...86/Packages.gz 407 Proxy Authentication Required
    Impossibile ottenere http://security.ubuntu.com/ubuntu/di...rce/Sources.gz 407 Proxy Authentication Required
    Impossibile ottenere http://it.archive.ubuntu.com/ubuntu/...86/Packages.gz 407 Proxy Authentication Required
    Impossibile ottenere http://it.archive.ubuntu.com/ubuntu/...rce/Sources.gz 407 Proxy Authentication Required
    Impossibile ottenere http://it.archive.ubuntu.com/ubuntu/...rce/Sources.gz 407 Proxy Authentication Required
    Impossibile ottenere http://it.archive.ubuntu.com/ubuntu/...86/Packages.gz 407 Proxy Authentication Required
    Impossibile ottenere http://it.archive.ubuntu.com/ubuntu/...86/Packages.gz 407 Proxy Authentication Required
    Impossibile ottenere http://it.archive.ubuntu.com/ubuntu/...rce/Sources.gz 407 Proxy Authentication Required
    Impossibile ottenere http://it.archive.ubuntu.com/ubuntu/...rce/Sources.gz 407 Proxy Authentication Required
    Lettura della lista dei pacchetti in corso... Fatto
    E: Impossibile scaricare alcune file di indice, essi verranno ignorati, oppure si useranno quelli precedenti.
    Da quello che ho capito,dato che mi connetto tramite la rete della residenza universitaria che è firewallata da proxy con autenticazione,dovrei configurare il terminale per connettersi al proxy.
    Ho girato un pò su internet ma non sono riuscito a trovare nulla su ciò,come devo muovermi?


    EDITO:
    nessuno sa come devo impostare la connessione al proxy su ubuntu 6.10?

  2. #2
    Utente di HTML.it L'avatar di cobra
    Registrato dal
    Aug 2006
    Messaggi
    217
    Crea o modifica il file /etc/apt/apt.conf con una riga simile a questa:
    Acquire::http::Proxy "http://iltuoproxyorta@utenteassword";
    ricordati il punto e virgola finale e non scrivere nessun altro carattere prima di questa riga.

    Ciao

  3. #3
    Utente di HTML.it
    Registrato dal
    Jan 2004
    Messaggi
    378
    Continua a darmi gli stessi errori!

  4. #4
    Utente di HTML.it L'avatar di cobra
    Registrato dal
    Aug 2006
    Messaggi
    217
    Allora prova con questi comandi:
    #http_proxy="http://proxyorta@userassword"
    #export http_proxy

  5. #5
    Utente di HTML.it
    Registrato dal
    Jan 2004
    Messaggi
    378
    lunatico@lunatico-laptop:~$ apt-get update
    E: Errore di sintassi /etc/apt/apt.conf:4: caratteri extra alla fine del file
    mi restituisce questo errore.

  6. #6
    Utente di HTML.it L'avatar di cobra
    Registrato dal
    Aug 2006
    Messaggi
    217
    Significa che hai sbagliato a digitare la riga che t'avevo postato

    Deve essere esattamente così: Acquire::http::Proxy "http://proxyorta@utenteassword";

    In alternativa puoi impostare il proxy come variabile d'ambiente, vedi il mio secondo post

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.