Pagina 1 di 2 1 2 ultimoultimo
Visualizzazione dei risultati da 1 a 10 su 19
  1. #1
    Utente di HTML.it L'avatar di MatCap83
    Registrato dal
    Jun 2005
    residenza
    Firenze
    Messaggi
    1,319

    Problemi ad accedere a ntfs

    Dal centro di controllo di mandriva ho installato i driver ntfs-3g, con tutti i pacchetti necessari, ma non riesco in nessun modo ad accedere in scrittura alle partizioni con NTFS !!! Ho provato e riprovato, ma nulla
    "Nessuno mi ha visto farlo, e non puoi provarlo in nessun modo!" (Bart Simpson)

    >>> www.ombresulweb.com <<<

  2. #2
    Utente di HTML.it L'avatar di GunMan
    Registrato dal
    Dec 2005
    Messaggi
    2,645
    una volta installato il modulo fuse con i relativi driver, è necessario specificare di voler usare tali driver in sede di mount della partizione.

    puoi anche modificare ad uopo fstab in modo che essa venga montata all'avvio seguendo tali direttive.

    Chaos A.D. Disorder unleashed.
    Starting to burn. Starting to lynch.
    Silence means death. Stand on your feet.
    Inner fear. Your worst enemy.

    Refuse / Resist

  3. #3
    Utente di HTML.it
    Registrato dal
    Jan 2001
    Messaggi
    7,725
    guarda in /etc/fstab se ti ha aggiunto la riga relativa a ntfs-3g. Nom ricordo la sintassi corretta, ma se fai una ricerca sul forum, se ne è discusso.
    ... S'i' fosse Giorgio, com'i' sono e fui,
    torrei le donne giovani e leggiadre:
    le vecchie e laide lasserei altrui....
    Non mandatemi PVT, mi dimentico sempre di leggerli ... mandatemi e-mail, se è il caso

  4. #4
    Utente di HTML.it L'avatar di MatCap83
    Registrato dal
    Jun 2005
    residenza
    Firenze
    Messaggi
    1,319
    Ok, sono riuscito a farlo funzionare il modulo, ho modificato tutto e ora in scrittura funziona!! Però quando sono andato a rimontare le partizione ntfs mi è apparsa 'sta scritta:

    "WARNING: Deficient Linux kernel detected. Some driver features are
    not available (swap file on NTFS, boot from NTFS by LILO), and
    unmount is not safe unless it's made sure the ntfs-3g process
    naturally terminates after calling 'umount'. If you wish this
    message to disappear then you should upgrade to at least kernel
    version 2.6.20, or request help from your distribution to fix
    the kernel problem. The below web page has more information:
    http://ntfs-3g.org/support.html#fuse26
    "

    Devo preoccuparmi se lascio la versione che ho ora del kernel ?? Per la precisione la 2.6.17...
    "Nessuno mi ha visto farlo, e non puoi provarlo in nessun modo!" (Bart Simpson)

    >>> www.ombresulweb.com <<<

  5. #5
    Utente di HTML.it L'avatar di GunMan
    Registrato dal
    Dec 2005
    Messaggi
    2,645
    non dovresti avere problemi teoricamente è solo un warning che ti informa che con la versione del kernel che hai installato alcune features non sono disponibili.

    Chaos A.D. Disorder unleashed.
    Starting to burn. Starting to lynch.
    Silence means death. Stand on your feet.
    Inner fear. Your worst enemy.

    Refuse / Resist

  6. #6
    Utente di HTML.it L'avatar di MatCap83
    Registrato dal
    Jun 2005
    residenza
    Firenze
    Messaggi
    1,319
    Nuovo problema , la scrittura sulle partizioni ntfs non funziona quando avvio il sistema . Se smonto manualmente una partizione e poi la rimonto con questo comando:

    mount -t ntfs-3g /dev/hda1 /mnt/partizione

    tutto ok. Ma quando accedo il sistema dopo un riavvio non funziona, in particolare ho modificato il file fstab così:

    /dev/sda5 / ext3 noatime 1 1
    /dev/sda7 /home ext3 noatime 1 2
    /dev/hda /media/cdrom auto umask=0022,users,iocharset=utf8,noauto,ro,exec 0 0
    /dev/sda1 /mnt/win_c ntfs-3g umask=0022,nls=utf8,ro 0 0
    /dev/sdb1 /mnt/win_c2 ntfs-3g umask=0022,nls=utf8,ro 0 0
    /dev/sda2 /mnt/win_d ntfs-3g umask=0022,nls=utf8,ro 0 0
    none /proc proc defaults 0 0
    none /tmp tmpfs defaults 0 0
    /dev/sda6 swap swap defaults 0 0


    in particolare ho aggiunto la voce ntfs-3g dopo le partizioni ntfs, per il caricamento del modulo all'avvio, ma non va . Che devo fare??
    "Nessuno mi ha visto farlo, e non puoi provarlo in nessun modo!" (Bart Simpson)

    >>> www.ombresulweb.com <<<

  7. #7
    Utente di HTML.it
    Registrato dal
    Jan 2001
    Messaggi
    7,725
    dove le hai prese quelle righe relative ad ntfs-3g che hai in /etc/fstab. Sicuro che siano corrette ? te le monta in sola lettura ? non te le monta proprio ?

    prova magari a mettere

    /dev/sda1 /mnt/win_c -t ntfs-3g umask=0022,nls=utf8,ro 0 0

    hai caricato il modulo fuse ?

    Prova fare qualche ricerca sui forum o su google.it/linux. Mi ricordo che poco tempo fa ho letto qualcosa in merito
    ... S'i' fosse Giorgio, com'i' sono e fui,
    torrei le donne giovani e leggiadre:
    le vecchie e laide lasserei altrui....
    Non mandatemi PVT, mi dimentico sempre di leggerli ... mandatemi e-mail, se è il caso

  8. #8
    Utente di HTML.it L'avatar di MatCap83
    Registrato dal
    Jun 2005
    residenza
    Firenze
    Messaggi
    1,319
    Sono riuscito a risolvere, dopo 1000 tentativi , finalmente ... Ho cercato un po' su google, e ho capito che bisogna aggiungere ad esempio alla fine del file fstab la riga:

    /dev/sda1 /mnt/partizione ntfs-3g default 0 0

    in questo modo è possibile scrivere fin dall'inizio. L'unica cosa che ho notato facendo in questo modo è che durante il caricamento del sistema mi appare scritto che il file fstab non contiene la linea di chiusura, e come devo fare?
    "Nessuno mi ha visto farlo, e non puoi provarlo in nessun modo!" (Bart Simpson)

    >>> www.ombresulweb.com <<<

  9. #9
    Utente di HTML.it
    Registrato dal
    Jan 2001
    Messaggi
    7,725
    semplicissimo (almeno credo e spero !), riapri fstab con un editor da root e dai un <invio> alla fine dell'ultima riga, se no la riga non viene chiusa correttamente.

    Scusa, ma questa riga

    /dev/sda1 /mnt/win_c ntfs-3g umask=0022,nls=utf8,ro 0 0

    te l'ha messa mandriva in automatico o l'hai trovata da qualche parte ?

    Se non funziona così prova a mettere la riga con l'ntfs dopo quelle degli altri dischi e non alla fine di fstab
    ... S'i' fosse Giorgio, com'i' sono e fui,
    torrei le donne giovani e leggiadre:
    le vecchie e laide lasserei altrui....
    Non mandatemi PVT, mi dimentico sempre di leggerli ... mandatemi e-mail, se è il caso

  10. #10
    Utente di HTML.it L'avatar di GunMan
    Registrato dal
    Dec 2005
    Messaggi
    2,645
    più che altro mi pare che l'opzione ro (read only) non sia particolarmente indicata.

    proverei con qualcosa di simile

    codice:
    /dev/sda1 /mnt/partizione ntfs-3g user,auto,silent,umask=0,locale=it_IT.utf8 0 0
    Chaos A.D. Disorder unleashed.
    Starting to burn. Starting to lynch.
    Silence means death. Stand on your feet.
    Inner fear. Your worst enemy.

    Refuse / Resist

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.