Visualizzazione dei risultati da 1 a 9 su 9
  1. #1
    Utente di HTML.it L'avatar di zac57
    Registrato dal
    Nov 2005
    Messaggi
    100

    Ubuntu 8.10 e ruter alice gate plus

    Mi capita un problema strano: avevo installato su di un computer che si collega ad internet, via cavo ethernet,con un ruter dilink, ubuntu 8.10 e tutto ha funzionato alla grande fino alla sostituzione del ruter con quello della telecom (alice gate plus) tutto incluso.
    In pratica la pagina in internet si carica a metÓ e dopo si pianta. Se rimonto il dilink va che Ŕ una scheggia. Ho sostituito il network menager con l wicd ma il problema rimane uguale.
    Qualcuno ha avuto lo stesso problema? E come ha risolto?
    Grazie!
    La vera conoscenza sta nel conoscere l'estensione della propria ignoranza. (Disraeli)

  2. #2
    1. (ad ogni riavvio bisogna replicare) Apri un terminale in modalitÓ root e scrivi:
    echo 1 > /proc/sys/net/ipv4/tcp_syncookies
    echo 0 > /proc/sys/net/ipv4/tcp_window_scaling
    echo 0 > /proc/sys/net/ipv4/tcp_ecn
    A questo punto naviga tranquillo... per˛ ricorda, ad ogni riavvio la procedura va replicata, per cui puoi farti uno script... oppure:
    2. Edita, oppure crea, sempre in modalitÓ superuser, il file /etc/sysctl.conf ed aggiungi le righe seguenti:
    net.ipv4.tcp_syncookies = 1
    net.ipv4.tcp_window_scaling = 0
    net.ipv4.tcp_ecn = 0

  3. #3
    Utente di HTML.it L'avatar di zac57
    Registrato dal
    Nov 2005
    Messaggi
    100
    Innanzi tutto grazie per la risposta.
    Ti volevo chiedere:
    1) la prima opzione mi viene facile ma a quanto pare devo ripeterla ad ogni avvio. E qui ci siamo.
    2) la seconda non ho capito bene. Rimana la cosa definitiva? E dove lo trovo il " file /etc/sysctl.conf " a cui devo aggiungere le tre righe che mi hai indicato? Grazie!
    La vera conoscenza sta nel conoscere l'estensione della propria ignoranza. (Disraeli)

  4. #4
    Se avessi letto con pi¨ attenzione, avresti notato che ho scritto:
    Edita, oppure crea,.....
    Apri un terminale, diventa root, posizionati nella directory /etc e digita
    nano sysctl.conf
    si aprirÓ un file (vuoto se il file non esiste ancora)
    aggiungi le righe che ti ho postato
    premi i tasti
    [CTRL] e [X], poi conferma con [S] oppure [Y] e premi [ENTER]

  5. #5
    Utente di HTML.it L'avatar di zac57
    Registrato dal
    Nov 2005
    Messaggi
    100
    Non ho combinato nulla. Apro il terminale d˛ il comando sudo e poi inserisco le stringhe che mi hai dato, d˛ invio, metto la password e non succede nulla.
    La vera conoscenza sta nel conoscere l'estensione della propria ignoranza. (Disraeli)

  6. #6
    Utente di HTML.it
    Registrato dal
    Jun 2002
    Messaggi
    371
    Originariamente inviato da zac57
    Non ho combinato nulla. Apro il terminale d˛ il comando sudo e poi inserisco le stringhe che mi hai dato, d˛ invio, metto la password e non succede nulla.
    Onestamente mi sembra che livellozero era stato abbastanza chiaro, comunque mi sembra che hai saltato questo passaggio

    posizionati nella directory /etc e digita
    sudo nano sysctl.conf
    si aprirÓ un file (vuoto se il file non esiste ancora)
    aggiungi le righe che ti ho postato
    premi i tasti
    [CTRL] e [X], poi conferma con [S] oppure [Y] e premi [ENTER]

  7. #7
    Utente di HTML.it L'avatar di zac57
    Registrato dal
    Nov 2005
    Messaggi
    100
    Sicuramente Ŕ stato chiaro. Il problema sono io che sono alle prime armi.
    "posizionati nella directory /etc e digita..." Qual Ŕ questa directory? Dove la trovo?
    Grazie!
    La vera conoscenza sta nel conoscere l'estensione della propria ignoranza. (Disraeli)

  8. #8
    Utente di HTML.it
    Registrato dal
    Jun 2002
    Messaggi
    371
    Originariamente inviato da zac57
    Sicuramente Ŕ stato chiaro. Il problema sono io che sono alle prime armi.
    "posizionati nella directory /etc e digita..." Qual Ŕ questa directory? Dove la trovo?
    Grazie!
    Quando hai aperto il terminale digiti cd /etc e sei nella dir. /etc (oppure si pu˛ fare direttamente sudo nano /etc/sysctl.conf)

  9. #9
    Utente di HTML.it L'avatar di zac57
    Registrato dal
    Nov 2005
    Messaggi
    100

    Risolto

    Un grazie veramente sentito a livellozero e a gio14, ho risolto il problema.
    Un cordiale saluto ad entrambi.
    La vera conoscenza sta nel conoscere l'estensione della propria ignoranza. (Disraeli)

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.