Visualizzazione dei risultati da 1 a 2 su 2

Discussione: connessione mdb

  1. #1
    Utente di HTML.it L'avatar di allejo
    Registrato dal
    Jul 2001
    Messaggi
    747

    connessione mdb

    Buongiorno a tutti...
    è la prima volta che uso php.
    E volevo soltanto semplicemente connettere a un db access su aruba che volevo solo provare.
    mi da errore
    Fatal error: Class 'COM' not found in D:\inetpub\webs\xxxxxxx\xxxxx\adodb.php on line 4

    allora imposto questo codice:


    codice:
    <!doctype html public "-//W3C//DTD HTML 4.0 Transitional//EN">
    <?php
    $percorso_database = realpath("prova.mdb");
    $connessione = new COM("ADODB.Connection");
    $stringa_di_connessione = "DRIVER={Microsoft Access Driver (*.mdb)};DBQ=".$percorso_database;
    $connessione->Open($stringa_di_connessione);
    $interrogazione = "select * from amici";
    $recordset = new COM("ADODB.Recordset");
    $recordset->Open($interrogazione,$connessione);
    $html_risultato ='';
    while (!$recordset->eof) {
        $html_risultato .= '<tr>';
        $html_risultato .= '<td> '.$recordset->fields["nome"]->value.'</td>';
        $html_risultato .= '</tr>';
        $recordset->movenext();
    }
    $recordset->close();
    $connessione->close();
    unset($recordset);
    unset($connessione);
    
    
    // HTML ?>
    
    
    <html>
    <head>
    <title> Test Connessione ADODB </title>
    <meta name="Generator" content="EditPlus">
    <meta name="Author" content="">
    <meta name="Keywords" content="">
    <meta name="Description" content="">
    </head>
    
    
    <body>
    <table border="1">
        <tr>
            <th>
                <h3>Tabella Risultati Query: <?=$interrogazione?></h3>
            </th>
        </tr>
        <tr>
            <th>Nome</th>
        </tr>
        <?=$html_risultato?>
    </table>
    </body>
    </html>
    Allejo

  2. #2
    Moderatore di PHP L'avatar di Alhazred
    Registrato dal
    Oct 2003
    Messaggi
    12,044
    Vedi se nel file php.ini esiste questa riga
    extension=php_com_dotnet.dll

    se c'è ed è commentata (; all'inizio) decommentala, se proprio non c'è, prova ad aggiungerla, poi riavvia Apache.
    Se anche dopo aver sistemato questa cosa non dovesse funzionare, probabilmente l'estensione non è proprio installata e va fatto.

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.