Pagina 2 di 2 primaprima 1 2
Visualizzazione dei risultati da 11 a 18 su 18
  1. #11
    Il motivo di questo delirio è che ho ereditato un db dove dentro il campo ci sono già delle parole con l'apice messo così: '\
    Per esempio: CINECITTA'\
    Se io metto l'apice corretto quando farò una query su quel campo mi darà errore perché l'apice in quel campo è inserito in maniera differente.
    <a href="http://www.robertodidonato.it" target="_blank">Roberto Di Donato</a>

  2. #12
    Utente di HTML.it
    Registrato dal
    Sep 2016
    Messaggi
    760
    Ho fatto anche una prova per essere sicuro di quello che ti avevo detto.
    Io se faccio l'escape della stringa TRINITA\' e poi la inserisco nel db quando vado a controllare ho la stringa corretta, ovvero TRINITA\'

    Secondo me c'è qualche problema con gli apici o qualcosa di simile, magari prova a postarci il codice.

  3. #13
    Utente di HTML.it L'avatar di luca200
    Registrato dal
    Apr 2002
    Messaggi
    4,135
    Quote Originariamente inviata da bibuz Visualizza il messaggio
    Il motivo di questo delirio è che ho ereditato un db dove dentro il campo ci sono già delle parole con l'apice messo così: '\
    Per esempio: CINECITTA'\
    Se io metto l'apice corretto quando farò una query su quel campo mi darà errore perché l'apice in quel campo è inserito in maniera differente.
    Quello che hai scritto qui sopra (apice + backslash) è diverso da quello che avevi scritto prima (backslash + apice). In ogni caso, qualsiasi porcheria ci sia nel db, la soluzione è ripulirlo.

  4. #14
    Scusa intendevo \'
    Questo è il codice:
    codice:
    $paesaggioNew = mysql_real_escape_string($_POST['A_77']);
    $sqlqueryMetaPaesaggioIns = "SELECT * FROM metadata WHERE meta_tag LIKE 'A_77'";
    $resultMetaPaesaggioIns = mysql_query($sqlqueryMetaPaesaggioIns);
    $recordMetaPaesaggioIns = mysql_fetch_array($resultMetaPaesaggioIns);
    $paesaggioIns = $recordMetaPaesaggioIns['meta_lista_valori'];
    $paesaggioInsDef = addslashes($paesaggioIns);
    $paesaggioInsNew = $paesaggioInsDef . $_POST['A_77'] . ';';
    $paesaggioInsNewDef = mysql_real_escape_string($paesaggioInsNew);
    echo $paesaggioInsNewDef.'<br>';
    $queryUpdatePaesaggio = "UPDATE metadata SET meta_lista_valori = '$paesaggioInsNewDef' WHERE meta_tag LIKE 'A_77' ";
    //echo $queryUpdatePaesaggio;
    $resultUpdatePaesaggio = mysql_query($queryUpdatePaesaggio);
    if (!$resultUpdatePaesaggio) {
     die("Errore nella query $queryUpdatePaesaggio: " . mysql_error());
    }
    <a href="http://www.robertodidonato.it" target="_blank">Roberto Di Donato</a>

  5. #15
    Ecco il codice corretto
    codice:
    $paesaggioNew = mysql_real_escape_string($_POST['A_77']);
    
    $sqlqueryMetaPaesaggioIns = "SELECT * FROM metadata WHERE meta_tag LIKE 'A_77'";
    $resultMetaPaesaggioIns = mysql_query($sqlqueryMetaPaesaggioIns);
    $recordMetaPaesaggioIns = mysql_fetch_array($resultMetaPaesaggioIns);
    $paesaggioIns = $recordMetaPaesaggioIns['meta_lista_valori'];
    $paesaggioInsDef = addslashes($paesaggioIns);
    
    $paesaggioInsNew = $paesaggioInsDef . $paesaggioNew . ';';
    $queryUpdatePaesaggio = "UPDATE metadata SET meta_lista_valori = '$paesaggioInsNew' WHERE meta_tag LIKE 'A_77' ";
    //echo $queryUpdatePaesaggio;
    $resultUpdatePaesaggio = mysql_query($queryUpdatePaesaggio);
    if (!$resultUpdatePaesaggio) {
     die("Errore nella query $queryUpdatePaesaggio: " . mysql_error());
    }
    <a href="http://www.robertodidonato.it" target="_blank">Roberto Di Donato</a>

  6. #16
    Praticamente la nuova stringa va ad aggiungersi a quella già esistente.
    L' addSlash sulla stringa esistente è necessario perché altrimenti nel db tutto ciò che inserito come \' diventa '
    <a href="http://www.robertodidonato.it" target="_blank">Roberto Di Donato</a>

  7. #17
    Alla fine ho risolto pulendo il db alla fine ha funzionato tutto
    <a href="http://www.robertodidonato.it" target="_blank">Roberto Di Donato</a>

  8. #18
    Quote Originariamente inviata da bibuz Visualizza il messaggio
    Alla fine ho risolto pulendo il db alla fine ha funzionato tutto
    wow!

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.