Visualizzazione dei risultati da 1 a 3 su 3

Discussione: Immagine con link inviata per email con PHP: link non viene ripreso

  1. #1

    Immagine con link inviata per email con PHP: link non viene ripreso

    Ciao,

    tramite la funzione mail di PHP invio un mailing.
    Nell'invio email c'é, fra le altre cose, questa riga:

    $messaggio1 .= "<img src=\"http://www.miosito.com/immagini/pulsante.jpg\" width=\"120\" height=\"35\" onClick=\"location.href='http://www.miosito.com'\" onMouseOver=\"this.style.cursor='pointer'\"/>";

    Ora, il mail arriva correttamente, l'immagine da cliccare arriva correttamente, ma non viene calcolato il link e nemmeno l'effetto onMouseOver.

    E' un problema con l'invio di PHP oppure sarà un problema di html/javascript?

  2. #2
    Moderatore di XHTML e HTML L'avatar di Vincent.Zeno
    Registrato dal
    May 2003
    residenza
    Emilia-Romagna (tortellini und cappelletti land!)
    Messaggi
    18,635
    la posta è sempre un sorvegliato speciale da parte del client. la maggior parte degli eventi sono inibiti per ovvie ragioni di sicurezza.

    usa una semplice ancora che contenga l'immagine. non mettere altro.

  3. #3
    Vincent, ho fatto come hai detto tu e funziona benissimo.
    Grazie mille

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2018 vBulletin Solutions, Inc. All rights reserved.