Visualizzazione dei risultati da 1 a 6 su 6
  1. #1

    [VBA] Selezione di estremi intermedi in un elenco numerico per la gestione di un archivio

    Ciao a tutti,
    come potrete immaginare sono nuova nel forum ed ho bisogno della vostra immensa pazienza e professionalita'...provero' a spiegarvi la mia situazione nel modo piu' semplice possibile...
    io ho un file excel nel quale sono inseriti circa 400/500 numeri (a volte anche di piu') a 6 cifre che corrispondono a numeri di documenti di trasporto della merce, tutti inseriti su un unica colonna ed in riga uno dopo l'altro...questo elenco viene creato ogni giorno a seconda dei ddt giornalieri che interessano la mia attivita' lavorativa, pertanto a volte e' "corto", altre volte meno....ovviamente nella fase di inserimento saranno numeri inseriti cosi' come vengono, in ordine casuale...ho inserito un pulsante con sottostante un codice vba che li ordina in senso crescente....e adesso viene il bello ed ho bisogno di voi.....dovrei fare i seguenti passaggi ed ovviamente ho bisogno di scrivere il relativo codice vba:

    - evidenziare (magari in verde) le celle che contengono "gli estremi di ogni centinaia di migliaia", ovvero il numero piu' piccolo ed il numero piu' grande dei 100.000, poi il numero piu' piccolo ed il numero piu' grande dei 200.000, poi il numero piu' piccolo ed il numero piu' grande dei 300.000 e cosi' via fino alla serie dei ddt che stanno per 900.000 (oltre non si va!)

    - creare una finestra in cui vengono visualizzati tutti gli estremi evidenziati nel passaggio precedente, in modo da avere una casella di riepilogo che poi posso stampare come archivio, cioe' piu' o meno cosi':
    DDT DEL GIORNO xxx
    da 123.981 a 124.056
    da 207.890 a 207.986
    da 376.605 a 376.859
    etc etc etc

    - stampare questa finestra di riepilogo degli estremi da allegare alle cartelle di archivio dei documenti di trasporto cartacei

    Spero di non essere stata complicata nell'esporvi quale e' la mia problematica e confido nel vostro prezioso supporto!
    Grazie di cuore

  2. #2
    Utente di HTML.it L'avatar di gibra
    Registrato dal
    Apr 2008
    residenza
    Italy
    Messaggi
    4,207
    Scusa, tu parli di supporto, ma di codice scritto da te non c'è nulla.
    Pensi/speri che qualcun'altro faccia il lavoro al posto tuo?

    Altrimenti devi spiegare COSA non sai fare.

  3. #3
    Utente di HTML.it
    Registrato dal
    Oct 2014
    Messaggi
    431
    non riesco a caricare l'immagine del foglio, ma provo a scrivere tutti i passaggi

    devo "rubare" 1 riga e 3 colonne per rendere tutto piu semplice

    la riga 1 deve contenere i titoli delle colonne (NO NUMERI DI DDT)
    "DDT", "calcolo", "min", "max"

    la colonna A contiene tutti i ddt a partire dalla riga 2 ordinati in ordine ascendente

    nella cella B2 inserisci la formula che identifica la prima cifra del DDT
    =INT(A2/100000)
    copia/incolla su tutte le celle della colonna B quando presente il DDT sulla A

    nella cella C2 inserisci la formula che identifica il DDT minimo
    =SE(B2=B1;0;B2)
    copia/incolla per colonna C come detto x B

    nella cella D2 inserisci la formula che identifica il DDT massimo
    =SE(B2=B3;0;B2)
    copia/incolla per colonna D come detto x B

    ora siamo pronti per creare la tabellina di riepilogo

    su una colonna laterale (esempio F) nella cella F2, F3, F4 ….. inserisci 1, 2, 3..... fino a 9

    nella cella G2 troviamo il minimo della serie (1) inserendo la formula
    =SOMMA.SE(C:C;F2;A:A)
    copia/incolla nelle 8 celle sottostanti per trovare gli altri minimi

    nella cella H2 troviamo il massimo della serie (1) inserendo la formula
    =SOMMA.SE(D : D;F2;A:A)
    copia/incolla nelle 8 celle sottostanti per trovare gli altri massimi

    ora per evitare problemi chiudo questo post, sul successivo ti allego la tabella excel

    ps io uso office 365
    Ultima modifica di marino51; 04-03-2019 a 21:27

  4. #4
    Utente di HTML.it
    Registrato dal
    Oct 2014
    Messaggi
    431
    non riesco a caricare neppure la tabella excel,
    scrivere un post e' una fatica

    ma credo che la soluzione sia semplice ed io mi sono .... divertito

    Cattura.GIF
    Cattura.GIF

    il vba lo scrivi tu, hai tutto per farlo (ed esiste la funzione registra macro ….)
    Ultima modifica di marino51; 04-03-2019 a 21:49

  5. #5
    Utente di HTML.it
    Registrato dal
    Oct 2014
    Messaggi
    431
    ultima riflessione, puoi anche tenere un "template" con tutte le formule,
    quando ti serve,
    copia/incolla della sequenza DDT (dalla cella A2)
    click su ordina da A->Z
    estendi le formule delle colonne B,C e D nelle celle necessarie
    ed ottieni il risultato
    senza vba (oppure il vba esegue queste operazioni, stampa compresa)

  6. #6
    Sei stato un artista, erano giorni che non riuscivo a venirne fuori, eppure era così semplice....ero entrata in palla nel vero senso...sisi per il codice vba non c'è problema, era la struttura di fondo del file che non riuscivo a strutturare....grazie, grazie davvero....e sono contenta che tu ti sia divertito

Tag per questa discussione

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.