Visualizzazione dei risultati da 1 a 10 su 10
  1. #1

    Riavvio audio dopo sospensione

    ciao!

    da un pò di tempo mi capita che quando sveglio il pc dalla sospensione, l'audio non funziona più.
    nessun player musicale, o browser.
    alla fine devo riavviare il pc.
    secondo come posso riavviare l'audio in questi casi?

    uso arch linux con cinnamon.

  2. #2
    che vedi da: systemctl --user status pulseaudio.service

  3. #3
    Quote Originariamente inviata da sacarde Visualizza il messaggio
    che vedi da: systemctl --user status pulseaudio.service
    ciao!

    allora, mi dava che era attivo:
    codice:
    $ systemctl --user status pulseaudio.service
    ● pulseaudio.service - Sound Service
       Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
       Active: active (running) ...............
    allora ieri ho fatto un bel aggiornamento di sistema e pare sia tornato tutto alla normalità.
    tra gli aggiornamento c'era anche il kernel.

    forse un aggiornamento precedente aveva scasinato qualcosa!

  4. #4
    allora, il problema si è riproposto.
    e mi dava pulse attivo.

    però, in verità, penso sia un problema più generico.
    perchè ho notato che dopo la sospensione mi capita:
    - l'audio non si sente
    - tutti i programmi basati su java non funzionano (tipo phpstorm, intellij, netbeans, ecc)
    - non si avvia nessun browser

    ma non sempre, solo a volte.
    e queste cose non capitano neanche tutte insieme.
    come se a volte, dopo la sospensione, qualcosa si impallasse.
    bha....

  5. #5
    provato a avviare i programmi incriminati da consolle e vedere se danno particolari messaggi di errore?

  6. #6
    Quote Originariamente inviata da sacarde Visualizza il messaggio
    provato a avviare i programmi incriminati da consolle e vedere se danno particolari messaggi di errore?
    si, ad esempio per quelli che necessitano di java, dice non trova più la jre.
    come se si fosse perso il path.

    per i brwoser, non ho provato.

  7. #7
    il path ( echo $PATH ) e' a posto ?

  8. #8
    Quote Originariamente inviata da sacarde Visualizza il messaggio
    il path ( echo $PATH ) e' a posto ?
    ciao, scusa il ritardo.
    ho fatto un po di prove.
    il PATH mi sembra corretto.

    oggi ad esempio mi è successo questo.
    apro phpstorm e sembra funzionare bene.
    usandolo però mi accorgo che diverse funzioni non fanno quello che devono, come ad esempio la formattazione del codice, il richiamo delle funzioni, ecc.
    riavvio e tutto funziona correttamente.

  9. #9
    devi trovare messaggi di errore (quando lo lanci da riga di comando) o dal comando "dmesg" (ultime righe)

  10. #10
    allora, prendiamo phpstorm.

    questo è quello che mi da in console oggi che mi da problemi:
    codice:
    (java:3441): Gtk-WARNING **: 09:43:07.932: Impossibile trovare il motore del tema in module_path: «murrine»,
    queste le ultime righe del dmesg:
    codice:
    [32601.764354] ata4: link is slow to respond, please be patient (ready=0)
    [32603.351020] ata4: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
    [32603.353271] ata4.00: configured for UDMA/133
    [32606.958406] kauditd_printk_skb: 1 callbacks suppressed
    [32606.958409] audit: type=1131 audit(1556177944.636:89): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
    [32684.405563] r8169 0000:03:00.0 enp3s0: Link is Up - 100Mbps/Full - flow control rx/tx
    [32684.405584] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready
    [32684.442188] audit: type=1130 audit(1556178022.120:90): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
    [32694.958671] audit: type=1131 audit(1556178032.636:91): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
    a me non sembra ci siano cose relative a questi problemi!

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.