Visualizzazione dei risultati da 1 a 3 su 3
  1. #1
    Utente di HTML.it
    Registrato dal
    Jun 2011
    Messaggi
    12

    Warning: mysqli_connect(): The server requested authentication method unknown to the client [caching_sha2_password] in C:\wamp64\www\videonoleggio\index.php on line 15

    Salve ragazzi, qualcuno sa darmi la spiegazione di questo errore?
    Questa è la mia pagina index

    <!doctype html>
    <html>
    <head>


    <script type="text/javascript">
    </script>
    </head>


    <h1><marquee>VIDEONOLEGGIO</marquee></h1>


    <body>


    <?php


    $con=mysqli_connect("localhost","adastoli","andrea 90");
    mysqli_select_db($con,"videonoleggio");


    ?>


    <a href="ricerca_titolo.php">ricerca per titolo</a><br>
    <a href="ricerca_genere.php">ricerca per genere</a><br>
    <a href="carica_film.php">carica film</a><br>
    <a href="scarico_film.php">scarica film</a><br>
    <a href="noleggio_film.php">noleggia film</a><br>
    <a href="restituzione_film.php">restituisci film</a><br>
    <a href="incassi.php">incassi</a><br>
    <a href="elenco_clienti.php">elenco clienti</a>


    </body>


    </html>

    ho creato questo DB che fino a ieri funzionava e invece stamattina mi ritrovo questo errore.

  2. #2
    Moderatore di PHP L'avatar di Alhazred
    Registrato dal
    Oct 2003
    Messaggi
    11,593
    Il sito in questione si trova su un server online oppure ce l'hai in locale?
    Questo errore potrebbe essere conseguenza di un aggiornamento a MySQL 8, che di default usa il modulo di autenticazione caching_sha2_password, attivato con questa direttiva nel file di configurazione di MySQL

    default_authentication_plugin=caching_sha2_passwor d

    Questo sistema è supportato da PHP dalla versione 7.1.16 per quanto riguarda PHP 7.1.x e dalla 7.2.4 per PHP 7.2.x

    La soluzione è aggiornare la versione di PHP oppure editare il file di configurazione di MySQL sostituendo la direttiva citata in precedenza con quella vecchia

    default_authentication_plugin=mysql_native_passwor d

    fatto ciò il server va riavviato.

    Per ulteriori informazioni:
    https://mysqlserverteam.com/upgradin...onsiderations/

    https://www.php.net/manual/en/mysqli.requirements.php

  3. #3
    Utente di HTML.it
    Registrato dal
    Jun 2011
    Messaggi
    12
    ok grazie, risolto

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.