Visualizzazione dei risultati da 1 a 6 su 6
  1. #1
    Utente di HTML.it
    Registrato dal
    Nov 2016
    residenza
    Italy
    Messaggi
    102

    Errore installazione pacchetto coreutils

    Ciao a tutti, spero di aver postato nella giusta sezione.

    Sto realizzando un progetto di rete, utilizzando il simulatore di rete Netkit, ed avrei bisogno di installare il pacchetto coreutils (ho necessità del comando timeout), e per l'installazione sto utilizzando la guida ufficiale dal sito.
    Ho il problema che quando vado a dare il comando: make o il make install, ottengo rispettivamente gli errori seguenti:

    codice:
    --nel make--
    tee.c:35:12 error: conflicting types for 'tee'
    static int tee (int nfiles, const char **files)
    ^~~
    
    --nel make install--
    Makefile:1263: recipe for target 'tee.o' failed
    make[1]:*** [tee.o] Error1
    make[1]: uscita dalla directory "/home/vmachine/coreutils/coreutils-5.0/src"
    Makefile:244:recipe for target 'install-recursive' failed
    make:*** [install-recursive] Error 1
    Grazie a tutti per l'aiuto

  2. #2
    - su che distro sei?
    - come mai vuoi compilarlo ? non c'e' il binario?
    - nella dir dei sorgenti in genere c'e' un README dove spiega come compilarlo

    in genere i passi della compilazione sono:
    ./configure
    make
    make install

  3. #3
    Utente di HTML.it
    Registrato dal
    Nov 2016
    residenza
    Italy
    Messaggi
    102
    Quote Originariamente inviata da sacarde Visualizza il messaggio
    - su che distro sei?
    - come mai vuoi compilarlo ? non c'e' il binario?
    - nella dir dei sorgenti in genere c'e' un README dove spiega come compilarlo

    in genere i passi della compilazione sono:
    ./configure
    make
    make install
    Ciao sacarde,
    ho seguito i passi ./configure, make e make install, e mi ha dato errore...sballandomi il filesystem delle macchine virtuali netkit, per quello che riguarda il binario non sono riuscito a trovarlo, ma ho trovato solo i tar.bz2, .gz ecc.
    Infine ho eseguito i comandi per ottenere la Distro di Linux, ma riesco solo ad ottenere la versione del kernel, che è 2.6.26.5-netkit-K2.8

    Hai qualche idea su come possa risolvere?

  4. #4
    - su che distribuzione sei?

    - il mio esempio dei 3 passi era generico, ogni sorgente hai suoi comandi da dare

    - io avevo provato questo netkit4tic molti anni fa, non so se e' ancora mantenuto

  5. #5
    Utente di HTML.it
    Registrato dal
    Nov 2016
    residenza
    Italy
    Messaggi
    102
    Quote Originariamente inviata da sacarde Visualizza il messaggio
    - su che distribuzione sei?

    - il mio esempio dei 3 passi era generico, ogni sorgente hai suoi comandi da dare

    - io avevo provato questo netkit4tic molti anni fa, non so se e' ancora mantenuto
    Io ho utilizzato i tre passi perché anche dalla documentazione ufficiale indicava questa procedura di installazione dei pacchetti aggiuntivi sulla vm, andando a modificare il filesystem delle vm.
    La distro non riesco a vederla, ho provato i vari comandi da terminale per farla mostrare, ma non mi da nulla in output...riesco solo a vedere quale sia il filesystem.
    Purtroppo netkit4kit non l'ho mai trovato, credo ora sia disponibile solo netkit

  6. #6
    per vedere il kernel: uname -a

    per vedere la distro: lsb_release -a

    oppure in /etc ci sono i file: lsb-release o os-release

Tag per questa discussione

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.