Visualizzazione dei risultati da 1 a 2 su 2
  1. #1

    Pulsante "torna su" funzionante solo su Edge

    Ho un template in bootstrap ed uno script in jquery per far comparire il pulsante torna su quando l'utente scrolla la pagina.
    jQuery non da problemi mentre CSS si. Con Edge funziona tutto ma su Chrome no. Il div non compare come fixed ma compare fisso in fondo al documento.
    Ecco il codice:
    codice:
    #top {
        width:100px;
        border:1px solid #d2d2d2;
        background:#f7f7f7;
        text-align:center;
        padding:5px;
        position:fixed;
        bottom:10px;
        right:10px;
        cursor:pointer;
        display:none;
        color:#333;
        font-family:verdana;
        font-size:12px;
    }
    come risolvo?
    Ho preso lo script da qui:
    http://marcocecchetti.it/Post/Artico...h?grid-page=96
    Ho anche provato questo ma non funziona:
    https://italia.github.io/bootstrap-i...ione-con-ombra
    Non capisco questa complicanza:
    codice HTML:
    <svg class="icon icon-light"><use xlink:href="/bootstrap-italia/dist/svg/sprite.svg#it-arrow-up"></use></svg>
    Perché non un semplice tag img ed una foto png?
    Mi spiegate?
    grazie
    Più pratica in futuro...

  2. #2
    Frontend samurai L'avatar di fcaldera
    Registrato dal
    Feb 2003
    Messaggi
    12,974
    Quote Originariamente inviata da giannino1995 Visualizza il messaggio
    Ho un template in bootstrap ed uno script in jquery per far comparire il pulsante torna su quando l'utente scrolla la pagina.
    jQuery non da problemi mentre CSS si. Con Edge funziona tutto ma su Chrome no. Il div non compare come fixed ma compare fisso in fondo al documento.
    Ecco il codice:
    codice:
    #top {
        width:100px;
        border:1px solid #d2d2d2;
        background:#f7f7f7;
        text-align:center;
        padding:5px;
        position:fixed;
        bottom:10px;
        right:10px;
        cursor:pointer;
        display:none;
        color:#333;
        font-family:verdana;
        font-size:12px;
    }
    come risolvo?
    Ho preso lo script da qui:
    http://marcocecchetti.it/Post/Artico...h?grid-page=96
    Ho anche provato questo ma non funziona:
    https://italia.github.io/bootstrap-i...ione-con-ombra
    Non capisco questa complicanza:
    codice HTML:
    <svg class="icon icon-light"><use xlink:href="/bootstrap-italia/dist/svg/sprite.svg#it-arrow-up"></use></svg>
    Perché non un semplice tag img ed una foto png?
    Mi spiegate?
    grazie
    Dovresti mostrarci una pagina che hai fatto tu con il codice che non funziona, altrimenti come possiamo capire dov'è il problema?

    Il fatto di usare SVG non è una complicanza. Chi ha sviluppato la pagina ha deciso di usare un'immagine vettoriale (e quindi scalabile senza perdita di qualità) rispetto ad una png che non è un formato vettoriale.
    ISSlive , un bot per Telegram per trovare tutti i passaggi visibili della Stazione Spaziale Internazionale.

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.