Visualizzazione dei risultati da 1 a 4 su 4
  1. #1
    Utente di HTML.it
    Registrato dal
    May 2007
    Messaggi
    122

    Wordpress Messaggio di errore

    su un sito giornalistico con diversi utenti compare (a tutti i lettori, anche i non loggati) una riga di codice nel layout del sito che recita:

    <b>Notice</b>: WP_User->id è stato chiamato con un argomento <strong>deprecato</strong> dalla versione 2.1.0! Utilizza invece <code>WP_User->ID</code>.. in <b>/home/lavocedibolzano.it/htdocs/wp-includes/functions.php</b> on line <b>4045</b><br/>

    sapete dirmi da cosa può dipendere?

    Grazie

  2. #2
    Moderatore di PHP L'avatar di Alhazred
    Registrato dal
    Oct 2003
    Messaggi
    11,667
    Probabilmente da un plugin installato e non aggiornato.

  3. #3
    Utente di HTML.it
    Registrato dal
    May 2007
    Messaggi
    122
    grazie... in effetti era così...ma con l'aggiornamento il difetto resta!

  4. #4
    Moderatore di PHP L'avatar di Alhazred
    Registrato dal
    Oct 2003
    Messaggi
    11,667
    Assicurati che il plugin in questione supporti la versione di Wordpress che stai usando.
    Potresti essere ricaduto in un caso in cui hai aggiornato, ma comunque anche l'ultima versione del plugin è troppo vecchia (plugin abbandonato o poco seguito dallo sviluppatore).
    Se così fosse dovrai trovare un altro plugin che faccia la stessa cosa, ma che sia compatibile con la tua versione di WP.

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.