Visualizzazione dei risultati da 1 a 3 su 3
  1. #1

    [jQuery] Scroll non funziona

    ciao!

    sto cercando di fare in modo che quando si clicca su un bottone, questo vada ad un div più sotto nella pagina:
    codice:
            // SCRIPT SCROLL
            jQuery(function() {
                jQuery('#wpforms-987-field_22_4').on('click', function() {
                    var comp = '#wpforms-987-field_23-container';               
                    jQuery('document').animate({
                        scrollTop: jQuery(comp).offset().top
                    }, 2000);
                    console.log('ok');
                });
            });
    il console.log si vede, e non ci sono errori.
    però la pagina non si muove.
    ed ovviamente il div a cui punta c'è.
    qualche idea??

  2. #2
    Moderatore di CSS L'avatar di KillerWorm
    Registrato dal
    Apr 2004
    Messaggi
    4,522
    Ciao, anziché document usa html o, meglio ancora, entrambi gli elementi html e body, perché alcuni browser applicano lo scorrimento all'uno piuttosto che all'altro. E' consigliato anche applicare uno stop() prima di animate(), perché se si clicca consecutivamente più volte, prima che sia completamente terminata l'animazione, si crea una coda di animazioni uguali che può causare problemi nell'esecuzione.

    codice:
    jQuery('html, body').stop().animate({...
    Prima di postare considera che tra i link utili puoi trovare il 75% delle risposte alle tue domande; il 20% tra i post del forum; il 15% sul web.
    Ti resta... humm spè

    Le cattive domande sono quelle che non meritano risposta, le buone domande sono quelle che non hanno risposta
    L'Itailano non e nu'opnioine. E' improntate uslaro correattemtne sul froum. Garize!

  3. #3
    ciao!

    in realtà ho scoperto che il codice funzionava.
    come funziona anche il tuo.

    il problema non è che quel codice, ma quel codice più il plugin wpforms di wordpress.
    più precisamente i "conditionals" che bloccano lo scrolling.
    infatti levati sti conditionals, tutto funziona.

    quindi devo capire come far funzionare entrambi.
    cmq grazie!

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.