Visualizzazione dei risultati da 1 a 3 su 3
  1. #1
    Utente di HTML.it
    Registrato dal
    May 2011
    Messaggi
    14

    [IIS] Error 403.14 quando eseguo una pagina

    Ciao a tutti, sperando di aver azzeccato la sezione (ero indeciso fra questa ed ASP .NET) passo subito alla descrizione del problema: ho lavorato, al corso che sto frequentando, ad una Web Application scritta in C# che si connette ad un DB e permette l'inserimento, modifica e cancellazione di un ipotetico cliente dal DB. Sul PC portatile funziona tutto correttamente: quando da VS19 faccio click su Esegui ottengo l'errore descritto nel titolo.

    Il portatile ed il fisso hanno entrambi Windows 10 Pro x64 e la versione di VS utilizzata è la stessa.

    Googlando un po' ho provato le seguenti soluzioni, che non hanno funzionato:
    - avviare VS19 come amministratore
    - spostare il progetto da una cartella condivisa in rete (prima era nella cartella di Google Drive)
    - abilitare "Esplora Directory" per tutti i siti che compaiono nell'ISS manager
    - aggiungere la stringa "<modules runAllManagedModulesForAllRequests="true"/>" o "<directoryBrowse enabled="true" />" dentro <system.web> ⟶ errore HTTP Error 500.19 "Impossibile leggere la sezione di configurazione poiché manca una dichiarazione di sezione"

    Ho provato anche le soluzioni descritte nella prima immagine, fatta eccezione per la seconda dato che non so che nome mettere dentro la stringa "SITE_NAME".

    Come procedo?
    Grazie in anticipo e buona serata

  2. #2
    Utente di HTML.it
    Registrato dal
    May 2011
    Messaggi
    14
    Dato che non si può editare il messaggio iniziale fornisco alcune informazioni in più: innanzitutto ho dimenticato di specificare che "su portatile funziona tutta correttamente, quando da fisso avvio VS19 e faccio click su Esegui (IIS Express (Google Chrome)) ottengo l'errore". Ho seguito la procedura qui indicata e la versione .NET selezionata del DefaultAppPool è la v4. Mi sono anche assicurato che "<directoryBrowse enabled="true" />" sia nel file web.config in "C:\inetpub\wwwroot" ed nello stesso file nella cartella "C:\inetpub\wwwroot\aspnet_client"


    Sempre sotto suggerimento di uno dei commenti della pagina Stack Overflow sopra indicata ho lanciato il comando "%windir%\Microsoft.NET\Framework64\v4.0.30319\asp net_regiis.exe -ir " ed ho ricevuto questo messaggio in risposta...
    Ultima modifica di MC23; 26-11-2019 a 20:58

  3. #3
    Utente di HTML.it
    Registrato dal
    May 2011
    Messaggi
    14
    Alla fine ho risolto aggiungendo una pagina Default.aspx senza niente al suo interno. Non ho capito come mai, quindi nonostante il problema sia risolto (ed il thread chiudibile) se qualcuno avesse una spiegazione del perché ciò ha funzionato (considerando che sul portatile non ho nessuna pagina del genere) mi interesserebbe comunque leggerla

Tag per questa discussione

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.