Pagina 2 di 2 primaprima 1 2
Visualizzazione dei risultati da 11 a 19 su 19
  1. #11
    Utente di HTML.it L'avatar di ninja72
    Registrato dal
    May 2020
    residenza
    -
    Messaggi
    136
    Mi dispiace, volevo retificare parte della mia ultima risposta, dicendo che è possibile assegnare piu font(file) ad una singola font-family in riferimento al suo font-weight, in modo che il css sia più leggibile.

    codice:
    @font-face {
                font-family: Ruda;
                src: url('fonts/Ruda-Regular.ttf') font-weight-normal,
                    url('fonts/Ruda-Bold.ttf') font-weight-bold,
                    url('fonts/Ruda-Black.ttf') font-weight(900);
            }
    
            .font-ruda-normal {
                font-family: 'Ruda', sans-serif;
                font-size: 2em;
                font-weight: normal;
            }
    
            .font-ruda-bold {
                font-family: 'Ruda', sans-serif;
                font-size: 2em;
                font-weight: bold;
            }
    
            .font-ruda-black {
                font-family: 'Ruda', sans-serif;
                font-size: 2em;
                font-weight: 900
            }

  2. #12
    Utente di HTML.it
    Registrato dal
    Oct 2007
    residenza
    Trieste
    Messaggi
    655
    Quote Originariamente inviata da ninja72 Visualizza il messaggio
    .... è possibile assegnare piu font(file) ad una singola font-family in riferimento al suo font-weight, in modo che il css sia più leggibile.
    Certo, ed è proprio la situazione che ho. Un folder con i fonts ed il rispettivo stylesheet.css che li include tutti. Sul sito, mi prende i font-weight bassi (400,500,600) ma non i bold (800,900)

  3. #13
    Utente di HTML.it L'avatar di ninja72
    Registrato dal
    May 2020
    residenza
    -
    Messaggi
    136
    E' possibile vedere il codice relativo al font incriminato ? Come viene caricato ? come viene richiamato ?

  4. #14
    Utente di HTML.it
    Registrato dal
    Oct 2007
    residenza
    Trieste
    Messaggi
    655
    niente di speciale, lo chiamo con
    codice HTML:
    * {font-family:'Ruda',Arial,sans-serif;src:url(/fonts/ruda/Ruda.woff2) format('woff2'), url(/fonts/ruda/Ruda.woff) format('woff');}
    e nella cartella il css è
    codice HTML:
    @font-face {
        font-family: 'Ruda';
        src: url('Ruda-Regular.woff2') format('woff2'),
            url('Ruda-Regular.woff') format('woff');
        font-weight: normal;
        font-style: normal;
        font-display: swap;
    }
    
    @font-face {
        font-family: 'Ruda';
        src: url('Ruda-Medium.woff2') format('woff2'),
            url('Ruda-Medium.woff') format('woff');
        font-weight: 500;
        font-style: normal;
        font-display: swap;
    }
    
    @font-face {
        font-family: 'Ruda';
        src: url('Ruda-SemiBold.woff2') format('woff2'),
            url('Ruda-SemiBold.woff') format('woff');
        font-weight: 600;
        font-style: normal;
        font-display: swap;
    }
    
    @font-face {
        font-family: 'Ruda';
        src: url('Ruda-Bold.woff2') format('woff2'),
            url('Ruda-Bold.woff') format('woff');
        font-weight: bold;
        font-style: normal;
        font-display: swap;
    }
    
    @font-face {
        font-family: 'Ruda';
        src: url('Ruda-ExtraBold.woff2') format('woff2'),
            url('Ruda-ExtraBold.woff') format('woff');
        font-weight: 800;
        font-style: normal;
        font-display: swap;
    }
    
    @font-face {
        font-family: 'Ruda';
        src: url('Ruda-Black.woff2') format('woff2'),
            url('Ruda-Black.woff') format('woff');
        font-weight: 900;
        font-style: normal;
        font-display: swap;
    }

  5. #15
    Utente di HTML.it L'avatar di ninja72
    Registrato dal
    May 2020
    residenza
    -
    Messaggi
    136
    Ho fatto la conversione dei font tramite quel tuo link, li ho messi dentro la cartella fonts e funziona tutto. L'unica cosa ho cancellato la prima riga del css il selettore universale anche perchè faceva riferimento ad un font inesistente per me.
    Ma il discorso di utilizzare sia woff che woff2 è per compatibilità dei browser suppongo, con il solo woff dovresti andare bene.

    codice:
    @font-face {
        font-family: 'Ruda';
        src: url('fonts/Ruda-Regular.woff2') format('woff2'),
            url('fonts/Ruda-Regular.woff') format('woff');
        font-weight: normal;
        font-style: normal;
        font-display: swap;
    }
    
    @font-face {
        font-family: 'Ruda';
        src: url('fonts/Ruda-Medium.woff2') format('woff2'),
            url('fonts/Ruda-Medium.woff') format('woff');
        font-weight: 500;
        font-style: normal;
        font-display: swap;
    }
    
    @font-face {
        font-family: 'Ruda';
        src: url('fonts/Ruda-SemiBold.woff2') format('woff2'),
            url('fonts/Ruda-SemiBold.woff') format('woff');
        font-weight: 600;
        font-style: normal;
        font-display: swap;
    }
    
    @font-face {
        font-family: 'Ruda';
        src: url('fonts/Ruda-Bold.woff2') format('woff2'),
            url('fonts/Ruda-Bold.woff') format('woff');
        font-weight: bold;
        font-style: normal;
        font-display: swap;
    }
    
    @font-face {
        font-family: 'Ruda';
        src: url('fonts/Ruda-ExtraBold.woff2') format('woff2'),
            url('fonts/Ruda-ExtraBold.woff') format('woff');
        font-weight: 800;
        font-style: normal;
        font-display: swap;
    }
    
    @font-face {
        font-family: 'Ruda';
        src: url('fonts/Ruda-Black.woff2') format('woff2'),
            url('fonts/Ruda-Black.woff') format('woff');
        font-weight: 900;
        font-style: normal;
        font-display: swap;
    }
    
    p {
        padding: 0;
        margin: 0;
    }
    
    .ruda-normal {
        font-family: Ruda;
        font-weight: normal;
        font-size: 2em;
    }
    
    .ruda-500 {
        font-family: Ruda;
        font-weight: 500;
        font-size: 2em;
    }
    
    .ruda-600 {
        font-family: Ruda;
        font-weight: 600;
        font-size: 2em;
    }
    
    .ruda-bold {
        font-family: Ruda;
        font-weight: bold;
        font-size: 2em;
    }
    
    .ruda-800{
        font-family: Ruda;
        font-weight: 800;
        font-size: 2em;
    }
    
    .ruda-900 {
        font-family: Ruda;
        font-weight: 900;
        font-size: 2em;
    }
    codice:
    <!DOCTYPE html>
    <html lang="en">
    
    <head>
        <meta charset="UTF-8">
        <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <title>Document</title>
        <link rel="stylesheet" href="style.css">
    </head>
    
    <body>
        <p class="ruda-normal">titolo</p>
        <p class="ruda-500">titolo</p>
        <p class="ruda-600">titolo</p>
        <p class="ruda-bold">titolo</p>
        <p class="ruda-800">titolo</p>
        <p class="ruda-900">titolo</p>
    </body>
    
    </html>

  6. #16
    Utente di HTML.it
    Registrato dal
    Oct 2007
    residenza
    Trieste
    Messaggi
    655
    Ti ringrazio per tempo e pazienza. Si, i due woff sono per compatibilità di browser più recenti. Se crei una classe per ogni weight, sicuramente funziona. Io vorrei evitare anche perchè sto usando Wordpress con un page builder, e vorrei capire dov'è il conflitto per i tipi bold. Anche perchè la stessa tecnica sul sito vecchio funzionava.

  7. #17
    Utente di HTML.it L'avatar di ninja72
    Registrato dal
    May 2020
    residenza
    -
    Messaggi
    136
    Figurati, purtroppo però di wordpress non ho compentenza, mi spiace.

  8. #18
    Utente di HTML.it
    Registrato dal
    Oct 2007
    residenza
    Trieste
    Messaggi
    655
    Il problema l'ho risolto includendo @import url stylesheet.css per il font in questione. Resta il mistero del perchè per gli altri font non fosse necessario, in quanto stylesheet.css sta nelle rispettive cartelle e viene correttamente caricato senza @import, mentre per il font incriminato sto praticamente facendo due chiamate.

  9. #19
    Utente di HTML.it
    Registrato dal
    Oct 2007
    residenza
    Trieste
    Messaggi
    655
    Incredibile ma vero, sono passati mesi ed il problema si ripresenta. I bold non li prende più. Eppure non ho toccato niente, maledetto

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.