Visualizzazione dei risultati da 1 a 5 su 5
  1. #1
    Utente di HTML.it L'avatar di exFelino
    Registrato dal
    Jul 2014
    residenza
    Aci Catena (CT)
    Messaggi
    681

    [EXCEL] Conteggio ore all'interno di una settimana

    Ciao, tramite excel, sto realizzando una sorta di registro di lavoro, dove appunto diverse informazioni inerenti la mia giornata lavorativa e avere così un report personale.

    Ho uno sheet dedicato a ciascun mese, all'interno del quale segno le ore lavorare giornalmente.
    Vorrei inserire nella riga corrispondente alla domenica (le ore lavorare all'interno di quella settimana) e questo non credo sia un problema.
    Visto che vorrei fare qualcosa di dinamico, cioè per il mese successivo, duplico lo sheet e cambia solo la colonna A con i giorni del mese in questione.

    Come posso fare?

    Ecco qui quello che ho creato:


    Grazie.

  2. #2
    Utente di HTML.it L'avatar di exFelino
    Registrato dal
    Jul 2014
    residenza
    Aci Catena (CT)
    Messaggi
    681
    Rileggendo...forse non è chiaro il mio problema...


    E' vero che ho scritto:
    "Vorrei inserire nella riga corrispondente alla domenica (le ore lavorare all'interno di quella settimana) e questo non credo sia un problema."
    il che potrebbe far pensare che questo punto è facilmente risolvibile, ma il problema è proprio qui...


    Riposto nuovamente lo screenshot del foglio di lavoro con le righe e colonne:



    Volendo sommare le ore lavorate per domenica 8 (quindi da lunedì 2 a domenica 8), basterebbe la formula:
    codice:
    =SOMMA(SOMMA(C3:C9)-SOMMA(B3:B9))+SOMMA(SOMMA(E3:E9)-SOMMA(D3:D9))

    Questo perchè so quali sono le celle che mi interessano....


    Ma a febbraio ad esempio il range le celle da considerare sanno altre...quindi vorrei in qualche modo generalizzare la formula sopra...


    Non so se c'è un modo per identificare la cella che contiene il giorno che cade di domenica e quindi da lì ricavare il range di celle desiderato (cioè quella - 7 giorni)...


    Che dite?

  3. #3
    Utente di HTML.it L'avatar di Misterxxx
    Registrato dal
    Oct 2003
    Messaggi
    3,644
    Quote Originariamente inviata da exFelino Visualizza il messaggio
    Rileggendo...forse non è chiaro il mio problema...


    E' vero che ho scritto:
    "Vorrei inserire nella riga corrispondente alla domenica (le ore lavorare all'interno di quella settimana) e questo non credo sia un problema."
    il che potrebbe far pensare che questo punto è facilmente risolvibile, ma il problema è proprio qui...


    Riposto nuovamente lo screenshot del foglio di lavoro con le righe e colonne:



    Volendo sommare le ore lavorate per domenica 8 (quindi da lunedì 2 a domenica 8), basterebbe la formula:
    codice:
    =SOMMA(SOMMA(C3:C9)-SOMMA(B3:B9))+SOMMA(SOMMA(E3:E9)-SOMMA(D3:D9))

    Questo perchè so quali sono le celle che mi interessano....


    Ma a febbraio ad esempio il range le celle da considerare sanno altre...quindi vorrei in qualche modo generalizzare la formula sopra...


    Non so se c'è un modo per identificare la cella che contiene il giorno che cade di domenica e quindi da lì ricavare il range di celle desiderato (cioè quella - 7 giorni)...


    Che dite?
    non so se GIORNO.SETTIMANA e ROW facciano al caso tuo
    se la cosa si fa troppo complessa, forse è il caso di scrivere una funzione ad-hoc

    ps. non dovrebbe essere?
    codice:
    =SOMMA(SOMMA(C3:C8)-SOMMA(B3:B8))+SOMMA(SOMMA(E3:E8)-SOMMA(D3:D8))
    Ultima modifica di Misterxxx; 16-01-2021 a 14:20
    Io ne ho viste cose che voi umani non potreste immaginare. Navi da combattimento in fiamme al largo dei bastioni di Orione e ho visto i raggi B, balenare nel buio vicino le porte di Tannhäuser. E tutti quei momenti ... andranno ... perduti nel tempo, come lacrime nella pioggia. È tempo di morire. (Roy Batty).

  4. #4
    Ciao, bel lavoro. Se ti interessa noi abbiamo un programma per Windows e Mac che esegue questi calcoli. C'è pure un'app con la quale il dipendente può timbrare e caricarti la timbratura in automatico.
    Se ti interessa fammi sapere.
    Ciao ciao.

  5. #5
    Utente di HTML.it L'avatar di exFelino
    Registrato dal
    Jul 2014
    residenza
    Aci Catena (CT)
    Messaggi
    681
    Quote Originariamente inviata da Misterxxx Visualizza il messaggio
    non so se GIORNO.SETTIMANA e ROW facciano al caso tuo
    se la cosa si fa troppo complessa, forse è il caso di scrivere una funzione ad-hoc

    ps. non dovrebbe essere?
    codice:
    =SOMMA(SOMMA(C3:C8)-SOMMA(B3:B8))+SOMMA(SOMMA(E3:E8)-SOMMA(D3:D8))
    Si, GIORNO.SETTIMANA quasi sicuramente...

    Nella formula considero anche la domenica...purtroppo non è un giorno di riposo.


    Quote Originariamente inviata da denis76 Visualizza il messaggio
    Ciao, bel lavoro. Se ti interessa noi abbiamo un programma per Windows e Mac che esegue questi calcoli. C'è pure un'app con la quale il dipendente può timbrare e caricarti la timbratura in automatico.
    Se ti interessa fammi sapere.
    Ciao ciao.
    Grazie, ma serve qualcosa di molto semplice per un uso prettamente personale.

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2021 vBulletin Solutions, Inc. All rights reserved.