Visualizzazione dei risultati da 1 a 3 su 3
  1. #1

    Archlinux cinnamon, nvidia e accelerazione hardware che non funziona

    ciao, e buon anno!

    è da circa 10 giorni che ho problemi con la scheda video e l'accerelazione hardware sulla mia archlinux con cinnamon.
    vi ho messo in allegato l'intero messaggio.

    ho già provato a guardare al wiki ufficiale (https://wiki.archlinux.org/index.php/NVIDIA), ma senza successo.
    vi giro un pò di info:
    codice:
    $ lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
    01:00.0 VGA compatible controller: NVIDIA Corporation GM200 [GeForce GTX TITAN X] (rev a1)
    questi i pacchetti nvidia installati:
    codice:
    $ pacman -Qs nvidia
    local/egl-wayland 1.1.6-1
        EGLStream-based Wayland external platform
    local/libvdpau 1.4-1
        Nvidia VDPAU library
    local/libxnvctrl 455.45.01-1
        NVIDIA NV-CONTROL X extension
    local/nvidia 455.45.01-10
        NVIDIA drivers for linux
    local/nvidia-settings 455.45.01-1
        Tool for configuring the NVIDIA graphics driver
    local/nvidia-utils 455.45.01-1
        NVIDIA drivers utilities
    e questi vdpau:
    codice:
    $ pacman -Qs vdpau
    local/libva-vdpau-driver 0.7.4-5
        VDPAU backend for VA API
    local/libvdpau 1.4-1
        Nvidia VDPAU library
    vainfo mi da questo errore:
    codice:
    $ vainfo
    vaInitialize failed with error code -1 (unknown libva error),exit
    ho già provato a ricreare il file xorg.conf con nvidia-xconfig:
    codice:
    $ cat /etc/X11/xorg.conf
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 455.45.01
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    ho anche provato a cancellare il file .nvidia-settings-rc (previo backup) che sta nella mia home.
    e a ricrearlo con nvidia-settings:
    codice:
    $ cat /home/fermat/.nvidia-settings-rc
    #
    # /home/fermat/.nvidia-settings-rc
    #
    # Configuration file for nvidia-settings - the NVIDIA X Server Settings utility
    # Generated on Fri Jan  1 10:52:45 2021
    #
    
    # ConfigProperties:
    
    RcFileLocale = C
    DisplayStatusBar = Yes
    SliderTextEntries = Yes
    IncludeDisplayNameInConfigFile = Yes
    ShowQuitDialog = Yes
    UpdateRulesOnProfileNameChange = Yes
    Timer = PowerMizer_Monitor_(GPU_0),Yes,1000
    Timer = Thermal_Monitor_(GPU_0),Yes,1000
    Timer = Memory_Used_(GPU_0),Yes,3000
    
    # Attributes:
    
    matte-arch:0.0/SyncToVBlank=1
    matte-arch:0.0/LogAniso=0
    matte-arch:0.0/FSAA=0
    matte-arch:0.0/TextureClamping=1
    matte-arch:0.0/FXAA=0
    matte-arch:0.0/AllowFlipping=1
    matte-arch:0.0/FSAAAppControlled=1
    matte-arch:0.0/LogAnisoAppControlled=1
    matte-arch:0.0/OpenGLImageSettings=1
    matte-arch:0.0/FSAAAppEnhanced=0
    matte-arch:0.0/ShowGraphicsVisualIndicator=0
    matte-arch:0[DPY:DVI-I-0]/Dithering=0
    matte-arch:0[DPY:DVI-I-0]/DitheringMode=0
    matte-arch:0[DPY:DVI-I-0]/DitheringDepth=0
    matte-arch:0[DPY:DVI-I-0]/SynchronousPaletteUpdates=0
    matte-arch:0[DPY:DVI-I-1]/Dithering=0
    matte-arch:0[DPY:DVI-I-1]/DitheringMode=0
    matte-arch:0[DPY:DVI-I-1]/DitheringDepth=0
    matte-arch:0[DPY:DVI-I-1]/ColorSpace=0
    matte-arch:0[DPY:DVI-I-1]/ColorRange=0
    matte-arch:0[DPY:DVI-I-1]/SynchronousPaletteUpdates=0
    matte-arch:0[DPY:HDMI-0]/RedBrightness=0.000000
    matte-arch:0[DPY:HDMI-0]/GreenBrightness=0.000000
    matte-arch:0[DPY:HDMI-0]/BlueBrightness=0.000000
    matte-arch:0[DPY:HDMI-0]/RedContrast=0.000000
    matte-arch:0[DPY:HDMI-0]/GreenContrast=0.000000
    matte-arch:0[DPY:HDMI-0]/BlueContrast=0.000000
    matte-arch:0[DPY:HDMI-0]/RedGamma=1.000000
    matte-arch:0[DPY:HDMI-0]/GreenGamma=1.000000
    matte-arch:0[DPY:HDMI-0]/BlueGamma=1.000000
    matte-arch:0[DPY:HDMI-0]/Dithering=0
    matte-arch:0[DPY:HDMI-0]/DitheringMode=0
    matte-arch:0[DPY:HDMI-0]/DitheringDepth=0
    matte-arch:0[DPY:HDMI-0]/DigitalVibrance=0
    matte-arch:0[DPY:HDMI-0]/ColorSpace=0
    matte-arch:0[DPY:HDMI-0]/ColorRange=0
    matte-arch:0[DPY:HDMI-0]/SynchronousPaletteUpdates=0
    matte-arch:0[DPY:DP-0]/Dithering=0
    matte-arch:0[DPY:DP-0]/DitheringMode=0
    matte-arch:0[DPY:DP-0]/DitheringDepth=0
    matte-arch:0[DPY:DP-0]/ColorSpace=0
    matte-arch:0[DPY:DP-0]/ColorRange=0
    matte-arch:0[DPY:DP-0]/SynchronousPaletteUpdates=0
    matte-arch:0[DPY:DP-1]/Dithering=0
    matte-arch:0[DPY:DP-1]/DitheringMode=0
    matte-arch:0[DPY:DP-1]/DitheringDepth=0
    matte-arch:0[DPY:DP-1]/ColorSpace=0
    matte-arch:0[DPY:DP-1]/ColorRange=0
    matte-arch:0[DPY:DP-1]/SynchronousPaletteUpdates=0
    matte-arch:0[DPY:DP-2]/Dithering=0
    matte-arch:0[DPY:DP-2]/DitheringMode=0
    matte-arch:0[DPY:DP-2]/DitheringDepth=0
    matte-arch:0[DPY:DP-2]/ColorSpace=0
    matte-arch:0[DPY:DP-2]/ColorRange=0
    matte-arch:0[DPY:DP-2]/SynchronousPaletteUpdates=0
    matte-arch:0[DPY:DP-3]/Dithering=0
    matte-arch:0[DPY:DP-3]/DitheringMode=0
    matte-arch:0[DPY:DP-3]/DitheringDepth=0
    matte-arch:0[DPY:DP-3]/ColorSpace=0
    matte-arch:0[DPY:DP-3]/ColorRange=0
    matte-arch:0[DPY:DP-3]/SynchronousPaletteUpdates=0
    matte-arch:0[DPY:DP-4]/Dithering=0
    matte-arch:0[DPY:DP-4]/DitheringMode=0
    matte-arch:0[DPY:DP-4]/DitheringDepth=0
    matte-arch:0[DPY:DP-4]/ColorSpace=0
    matte-arch:0[DPY:DP-4]/ColorRange=0
    matte-arch:0[DPY:DP-4]/SynchronousPaletteUpdates=0
    matte-arch:0[DPY:DP-5]/Dithering=0
    matte-arch:0[DPY:DP-5]/DitheringMode=0
    matte-arch:0[DPY:DP-5]/DitheringDepth=0
    matte-arch:0[DPY:DP-5]/ColorSpace=0
    matte-arch:0[DPY:DP-5]/ColorRange=0
    matte-arch:0[DPY:DP-5]/SynchronousPaletteUpdates=0
    ho eseguito tutti gli aggiornamenti ad oggi.

    non so più che fare.
    qualche idea??
    Immagini allegate Immagini allegate

  2. #2
    Ciao, è da un po' che non si mette mano al file xorg.
    Stai usando i driver ufficiali nvidia? Se no, anche se riuscirai a configurare quelli open non avrai le performances dei closed.

  3. #3
    Quote Originariamente inviata da denis76 Visualizza il messaggio
    Ciao, è da un po' che non si mette mano al file xorg.
    Stai usando i driver ufficiali nvidia? Se no, anche se riuscirai a configurare quelli open non avrai le performances dei closed.

    ciao!

    grazie ma alla fine ho formattato.
    le ho provate tutte.
    cmq erano circa 4 anni che non formattavo.
    male non gli ha fatto.

    poi ci ho messo opensuse tumbletweed.
    al primo aggiornamento non partiva più kde.
    dopo 10 ho formattato perchè non ne uscivamo.

    sono tornato ad arch linux con kde.
    per ora tutto bene.

    cmq in tutti i casi sempre driver nvidia presi dai repo.

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2021 vBulletin Solutions, Inc. All rights reserved.