Visualizzazione dei risultati da 1 a 4 su 4
  1. #1

    Impossibile recupero valori GET da url

    Buongiorno.
    Solitamente per recuperare i valori nelle URL ho sempre utilizzato questo semplice metodo:
    Codice PHP:
    //www.miosito.com?id=2&ids=5
    echo $_GET['id'] ."-".$_GET['ids']; 
    Oggi, in localhost non mi permette di farlo.
    Ho letto da qualche parte che le register_globals presenti nel php.ini dovrebbero essere impostate su On.
    Io le ho su Off, ma cambiando lo stato da Off a On, e riavviando il WS, Apache si ricollega per un attimo, ma poi si disconnette.

    Avete qualche soluzione in merito?
    Grazie.
    Ultima modifica di ANTAGONIA; 09-02-2021 a 13:38

  2. #2
    Moderatore di PHP L'avatar di Alhazred
    Registrato dal
    Oct 2003
    Messaggi
    12,133
    register_globals non incide su post e get usati in quel modo lì.
    Inciderebbe se usassi direttamente $id ed $ids, che ti verrebbero valorizzati dalla direttiva in questione.

    Il tuo problema, che non specifichi, è da un'altra parte, ad iniziare forse, se non dovesse essere un refuso, dal - invece del . per concatenare la stringa.
    Earth2: 3QCNSPFQUH

  3. #3
    No, aspè, quello era un semplice esempio, con l'errore che tu giustamente hai evidenziato.
    Ma io non riesco proprio a recuperare i valori come ho sempre fatto con $_GET['id'].

  4. #4
    Quando hai detto, il problema è da un altra parte, ho puntato sul htaccess
    Ho cambiato i parametri
    Codice PHP:
    //DA
    RewriteRule ^menu.phppage.php?p=$[L]

    //A
    RewriteRule ^menu.phppage.php?p=$[L,QSA,NC
    Adesso funziona tutto.
    Grazie come sempre.

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2021 vBulletin Solutions, Inc. All rights reserved.