Pagina 2 di 3 primaprima 1 2 3 ultimoultimo
Visualizzazione dei risultati da 11 a 20 su 23
  1. #11
    Utente di HTML.it
    Registrato dal
    Jun 2006
    Messaggi
    87
    Faccio la connectstring in questo modo:

    Public ConnString As String = "Provider=Microsoft.ACE.OLEDB.12.0;Data Source= C:\Aziendale\Aziendale.mdb;Persist Security Info=false;"
    Public Cn As New OleDb.OleDbConnection(ConnString)
    Public dr As OleDb.OleDbDataReader
    Public cmd As OleDb.OleDbCommand
    Public sql As String

  2. #12
    Utente di HTML.it
    Registrato dal
    Jun 2006
    Messaggi
    87
    Io uso solo questa:
    Public ConnString As String = "Provider=Microsoft.ACE.OLEDB.12.0;Data Source= C:\Aziendale\Aziendale.mdb;Persist Security Info=false;"
    Public Cn As New OleDb.OleDbConnection(ConnString)
    Public dr As OleDb.OleDbDataReader
    Public cmd As OleDb.OleDbCommand
    Public sql As String

  3. #13
    Utente di HTML.it
    Registrato dal
    Jun 2006
    Messaggi
    87
    Io uso solo ACE.OLEDB.12.0

  4. #14
    Utente di HTML.it
    Registrato dal
    Jun 2006
    Messaggi
    87

    Il provider Microsoft.ACE.OLEDB.12.0 non è registrato nel computer locale.

    Io uso solo Microsoft.ACE.OLEDB.12.0

  5. #15
    controlla cosa c'è nelle referenze del progetto

  6. #16
    Utente di HTML.it
    Registrato dal
    Jun 2006
    Messaggi
    87
    Microsoft Activex data objects 6.1 library
    Microsoft dao 3.6 object library
    Microsoft jet and replication object 2.6 library
    Microsoft office 16.0 access database engine object library
    Microsoft office 16.0 object library

  7. #17
    Utente di HTML.it L'avatar di oregon
    Registrato dal
    Jul 2005
    residenza
    Roma
    Messaggi
    36,353
    Bisogna controllare il progetto di persona perché avrai sicuramente impostato qualcosa con qualche wizard e non te ne rendi conto.

    P.S. Discutere della stessa problematica contemporaneamente su due forum non aiuta
    No MP tecnici (non rispondo nemmeno!), usa il forum.

  8. #18
    Utente di HTML.it
    Registrato dal
    Jun 2006
    Messaggi
    87
    Mi sono accorto di una cosa.

    Quando faccio il dataset seleziono database> nuova connessione e seleziono il db, nel wizard la connessione è:

    Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Aziendale\Aziendale.mdb mi sa che è qui il problema, che devo fare per risolvere?

    Sono andato sulle proprietà del dataset e ho modificato la connectionstring in:

    Provider="Provider=Microsoft.ACE.OLEDB.12.0";Data Source=C:\Aziendale\Aziendale.mdb ma mi da lo

    stesso errore:

    Il provider 'Provider=Microsoft.ACE.OLEDB.12.0' non è registrato nel computer locale.
    Ultima modifica di jekisi; 24-05-2021 a 10:33

  9. #19
    Utente di HTML.it
    Registrato dal
    Jun 2006
    Messaggi
    87
    Vorrei allegare il progetto ma supera la dimensione, mi date il vostro indirizzo e - mail che ve lo mando?

  10. #20
    Utente di HTML.it L'avatar di oregon
    Registrato dal
    Jul 2005
    residenza
    Roma
    Messaggi
    36,353
    Quote Originariamente inviata da jekisi Visualizza il messaggio
    Vorrei allegare il progetto ma supera la dimensione, mi date il vostro indirizzo e - mail che ve lo mando?
    Vedi risposta su altro forum
    No MP tecnici (non rispondo nemmeno!), usa il forum.

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2021 vBulletin Solutions, Inc. All rights reserved.