Visualizzazione dei risultati da 1 a 5 su 5

Discussione: classi in css

  1. #1
    Utente di HTML.it
    Registrato dal
    Jun 2021
    Messaggi
    3

    classi in css

    Buongiorno a tutti,
    Mi sono appena iscritto a questo forum perché sto riscontrando alcuni problemi con un progetto su cui sto lavorando.
    Io sto usando un foglio di stile esterno in css, che funziona per quanto riguarda header, footer, body ecc..., ma non funziona per quanto riguarda le classi "personalizzate", nonostante mi pare siano dichiarate correttamente.

    Vi faccio copia incolla di una parte del codice (ancora molto semplice perché non riuscendo a sistemare questo problema sono ancora bloccato all'inizio)

    <p class="nomi"> <a href= appng.html> Appartamento N.G. </a> </p> (codice html)

    .nomi {
    text-decoration: underline; } (parte relativa alla classe nomi in css)

    Teoricamente la scritta dovrebbe essere venire sottolineata, ma questo non succede, non capisco il perché
    Ringrazio in anticipo chiunque riesca a darmi una mano


  2. #2
    Utente di HTML.it L'avatar di ninja72
    Registrato dal
    May 2020
    residenza
    -
    Messaggi
    179
    Di norma il tag anchor ha di default il testo sottolineato, ma bisogna sempre vedere tutto l'insieme del progetto e che librerie o eventuali framework si stanno utilizzando.
    Inoltre sarebbe utile capire con che browser stai lavorando.

    Vedo due errori, uno è quello che delle virgolette assenti nell' href dell'anchor tag, l'altro riguarda l'errato puntamento che fai nella tua classe css.

    codice:
    .nomi a {
                text-decoration: underline!important;
            }

  3. #3
    Utente di HTML.it
    Registrato dal
    Jun 2021
    Messaggi
    3
    Allora, innanzitutto io stò lavorando con Google Chrome. Per quanto riguarda poi le sottolineature di default, in questo progetto non tutti gli anchor devono essere sottolineati, ma comunque io questo l'ho messo solo come esempio, potevo anche mettere qualsiasi altra cosa (colori, posizioni, grandezze......).

    Poi parlando dei due errori, le virgolette le avevo messe inizialmente, visto che la regola dice di metterle, ma il collegamento non funzionava, ho provato quindi a toglierle e il problema si è risolto (par strano anche a me), mentre invece per il puntamento dopo proverò a sistemarlo (ora non ho il mio computer con me, lo farò stasera o domani mattina) e poi ti farò sapere.

    Grazie mille per l'aiuto

  4. #4
    Utente di HTML.it
    Registrato dal
    Jun 2021
    Messaggi
    3

    aggiornamento

    Ho provato a modificare e correggere come hai detto tu, ma anche in questo caso non funziona, grazie comunque.
    Se qualcun' altro dovesse avere altre idee o altre correzioni, io sono qui.

  5. #5
    Moderatore di CSS L'avatar di KillerWorm
    Registrato dal
    Apr 2004
    Messaggi
    4,917
    Ciao e benvenuto.
    Le indicazioni che hai fornito non bastano per comprendere dove sta il problema. Potrebbe essere un problema di cache oppure di override di altre regole css nel tuo progetto.

    Prova a fornire ulteriori dettagli. Stai usando qualche piattaforma? Puoi fornire un link della pagina in questione?
    Prima di postare considera che tra i link utili puoi trovare il 75% delle risposte alle tue domande; il 20% tra i post del forum; il 15% sul web. Ti resta... humm spè
    Le cattive domande sono quelle che non meritano risposta, le buone domande sono quelle che non hanno risposta
    L'Itailano non e nu'opnioine. E' improntate uslaro correattemtne sul froum. Garize!

    "Mi son documentato"

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2021 vBulletin Solutions, Inc. All rights reserved.