Visualizzazione dei risultati da 1 a 2 su 2
  1. #1

    Redirect verso https non funziona , pagine duplicate

    Salve,
    sul modulo htaccess ho inserito:
    codice:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{HTTPS} off
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>
    Uso wordpress sul mio sito ma purtroppo il redirect alla https funziona solo sulla homepage, se clicco su un collegamento in http viene mostrata la pagina http e non quella https, se clicco su un collegamento https viene mostrata la pagina https (quindi un duplicato)?
    Grazie
    Agriturismo Toscana tra siena e volterra

  2. #2
    Amministratore L'avatar di Vincent.Zeno
    Registrato dal
    May 2003
    residenza
    Emilia-Romagna (tortellini und cappelletti land!)
    Messaggi
    20,164
    sposto su server apache

  3. #3
    Quote Originariamente inviata da Toscana2011 Visualizza il messaggio
    Salve,
    sul modulo htaccess ho inserito:
    codice:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{HTTPS} off
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>
    Uso wordpress sul mio sito ma purtroppo il redirect alla https funziona solo sulla homepage, se clicco su un collegamento in http viene mostrata la pagina http e non quella https, se clicco su un collegamento https viene mostrata la pagina https (quindi un duplicato)?
    Grazie
    l'ultima sezione, riguardante http/https, dovrebbe essere questa
    codice:
    RewriteCond %{HTTP_HOST} ^tuo_dominio\.com$ [NC]
    codice:
    RewriteRule ^(.*)$ http://www.tuo_dominio.com$1 [R=301,NE,L]
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L,NE]

    Questo perchè così ogni richiesta a http(s)://tuohost.com/qualcosa verrà rediretta a www.tuohost.com/qualcosa (l'indirizzo cioè diventa www.tuohost) e, se la richiesta non è https, lo diventa. Hai messo un ^ in più nelle tue regole, un $ in più nella regex iniziale e manca un flag di redirect (NE) che serve per evitare l'escaping per esempio di & o # nelle url, che altrimenti vengono convertite nei rispettivi codici esadecimali.
    Verifica inoltre di avere
    FollowSymLinks abilitato

    Per una descrizione accurata delle regole e della sintassi vedi
    http://httpd.apache.org/docs/2.4/mod/mod_rewrite.html
    http://httpd.apache.org/docs/2.4/rewrite/intro.html

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2021 vBulletin Solutions, Inc. All rights reserved.