Pagina 2 di 3 primaprima 1 2 3 ultimoultimo
Visualizzazione dei risultati da 11 a 20 su 25
  1. #11
    Utente di HTML.it L'avatar di U235
    Registrato dal
    Mar 2006
    Messaggi
    1,394
    Quote Originariamente inviata da Kahm Visualizza il messaggio
    oh mannaggia funziona
    era proprio questo, eppure pensavo che bastava metterlo nel web.config
    nel web.config regoli la durata del ticket, poi il cookie serve a trasportare il ticket.


    p.s.
    perche mannaggia? Non sei contento che funziona?

    ovviamente scherzo… ho capito perché lo hai scritto.
    Ultima modifica di U235; 06-05-2022 a 12:17

  2. #12
    Moderatore di ASP.net L'avatar di djciko
    Registrato dal
    Nov 2002
    Messaggi
    6,865
    era
    codice:
    User.Identity.Name

    per il nome utente con cui si è loggato.

    https://docs.microsoft.com/en-us/dot...tframework-4.8

  3. #13
    Utente di HTML.it L'avatar di Kahm
    Registrato dal
    Dec 2004
    residenza
    Rome
    Messaggi
    3,514
    Rianimo il thread per dire che è successa una cosa strana
    in locale FUNZIONA benissimo , nessun problema, tutto ok
    pubblico nel server (non voglio fare nomi ma è un server italiano economico) e non funziona NULLA!

    in pratica mi sono anche ricordato di modificare il web.config
    per leggere i cookies ho bisogno di permessi particolari? oppure potrebbe essere una restrizione del server?
    non si spiega, ho passato tutto il sabato mattina a casa a cercare di capire e bestemmiare
    NN vi diro mai chi sono in realta,
    tutti i miei 3D sono orfani, non insistete per farmi rispondere ai 3D aperti da me

  4. #14
    Utente di HTML.it L'avatar di U235
    Registrato dal
    Mar 2006
    Messaggi
    1,394
    Quote Originariamente inviata da Kahm Visualizza il messaggio
    Rianimo il thread per dire che è successa una cosa strana
    in locale FUNZIONA benissimo , nessun problema, tutto ok
    pubblico nel server (non voglio fare nomi ma è un server italiano economico) e non funziona NULLA!

    in pratica mi sono anche ricordato di modificare il web.config
    per leggere i cookies ho bisogno di permessi particolari? oppure potrebbe essere una restrizione del server?
    non si spiega, ho passato tutto il sabato mattina a casa a cercare di capire e bestemmiare
    Con non funziona presumo intenda dire che ottieni il risultato come nel primo post, ovvero chiudi il browser e quando lo riapri non hai più il cookie. Diversamente specifica...
    Potrebbe essere che il browser si comporta diversamente con i cookie di quello specifico sito. Poi dicci cosa hai controllato. Ad esempio hai controllato cosa avviene dietro le quinte con strumenti tipo Fiddler?
    Hai controllato le impostazioni del browser? hai qualche messaggio in console del browser?
    Puoi fornire l'indirizzo (anche in privato) per fare in modo che possiamo controllare anche noi?
    Quel provider (che credo sia il tuo) per quanto ne so fornisce meno libertà di altri... anche se onestamente non credo sia quello il problema.
    Hai provato ad usare strumenti nella quale hai più controllo del browser? qualcosa tipo postman in cui puoi gestire meglio alcuni aspetti delle chiamate.

    Hai passato un buon venerdì notte? non è che sognavi? non è che sei un essere inutile e non hai un opinione in merito? ah no quello è un altra cosa
    Ultima modifica di U235; 07-05-2022 a 13:32

  5. #15
    Utente di HTML.it L'avatar di Kahm
    Registrato dal
    Dec 2004
    residenza
    Rome
    Messaggi
    3,514
    Quote Originariamente inviata da U235 Visualizza il messaggio
    Con non funziona presumo intenda dire che ottieni il risultato come nel primo post, ovvero chiudi il browser e quando lo riapri non hai più il cookie. Diversamente specifica...
    Potrebbe essere che il browser si comporta diversamente con i cookie di quello specifico sito. Poi dicci cosa hai controllato. Ad esempio hai controllato cosa avviene dietro le quinte con strumenti tipo Fiddler?
    Hai controllato le impostazioni del browser? hai qualche messaggio in console del browser?
    Puoi fornire l'indirizzo (anche in privato) per fare in modo che possiamo controllare anche noi?
    Quel provider (che credo sia il tuo) per quanto ne so fornisce meno libertà di altri... anche se onestamente non credo sia quello il problema.
    Hai provato ad usare strumenti nella quale hai più controllo del browser? qualcosa tipo postman in cui puoi gestire meglio alcuni aspetti delle chiamate.

    Hai passato un buon venerdì notte? non è che sognavi? non è che sei un essere inutile e non hai un opinione in merito? ah no quello è un altra cosa
    si, è come ti ho detto, in locale il cookie lo crea e lo legge senza problemi, in basso immagine di cookie del sito
    online non me lo crea e sto cercando di capirne il motivo
    pensavo che qualche host non li facesse gestire per protezione

    NN vi diro mai chi sono in realta,
    tutti i miei 3D sono orfani, non insistete per farmi rispondere ai 3D aperti da me

  6. #16
    Utente di HTML.it L'avatar di U235
    Registrato dal
    Mar 2006
    Messaggi
    1,394
    Quote Originariamente inviata da Kahm Visualizza il messaggio
    non me lo crea e sto cercando di capirne il motivo
    pensavo che qualche host non li facesse gestire per protezione
    Non ho capito come mai evidenzi quel cookie (NuovoCookie), ma forse è un caso che fosse "selezionato".
    In ogni caso vedo che hai i cookie (.ASPXAUTH) del sito in locale, hai provato a cancellarli?
    Hai provato anche con altro browser?
    Non c'è modo di poterlo vedere direttamente sul sito per noi? magari con un account creato al volo che poi cancelli.
    Poi non ho capito se non te lo crea proprio (come dici nel quote) oppure fa come prima, ovvero lo crea ma non persiste dopo la chiusura.

  7. #17
    Moderatore di ASP.net L'avatar di djciko
    Registrato dal
    Nov 2002
    Messaggi
    6,865
    kahm, potresti postare tutto il codice della pagina di login e quello del global.asax ?

  8. #18
    Utente di HTML.it L'avatar di Kahm
    Registrato dal
    Dec 2004
    residenza
    Rome
    Messaggi
    3,514
    Quote Originariamente inviata da djciko Visualizza il messaggio
    kahm, potresti postare tutto il codice della pagina di login e quello del global.asax ?
    si ok, datemi un momento in quanto avendo duplicato sullo stesso gestore di servizi da un account funziona, ma nel loro ufficiale (del cliente) NO (sto cercando di capire se hanno toccato qualcosa)

    per ora non trovo nulla
    grazie del supporto
    siete gentilissimi
    Ultima modifica di Kahm; 10-05-2022 a 08:09
    NN vi diro mai chi sono in realta,
    tutti i miei 3D sono orfani, non insistete per farmi rispondere ai 3D aperti da me

  9. #19
    Utente di HTML.it L'avatar di Kahm
    Registrato dal
    Dec 2004
    residenza
    Rome
    Messaggi
    3,514
    dopo il mio ultimo tentativo isso bandiera bianca
    vi mando in PM i 2 siti web con altrettanti login
    potete notare che in uno crea il cookie ma non nell'altro

    eppure il gestore dei servizi è lo stesso
    NN vi diro mai chi sono in realta,
    tutti i miei 3D sono orfani, non insistete per farmi rispondere ai 3D aperti da me

  10. #20
    Utente di HTML.it L'avatar di U235
    Registrato dal
    Mar 2006
    Messaggi
    1,394
    Ciao,
    quando vuoi manda pure i PM.

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2022 vBulletin Solutions, Inc. All rights reserved.