Visualizzazione dei risultati da 1 a 10 su 10
  1. #1
    Utente di HTML.it
    Registrato dal
    Oct 2007
    residenza
    Trieste
    Messaggi
    790

    pagina backend Wordpress non si apre

    Ho una pagina nel backend che si apre blank. E' la pagina di impostazioni di un plugin fondamentale per il tema, e per il 98% delle volte non si apre.
    Con la consolle, mi dice Stato 500 Internal Server Error + Versione HTTP/1.1 ma non saprei come risolvere. Qualcuno ha idea di cosa può causare il problema?

  2. #2
    Hai accesso ai log di sistema? Se sì, verifica error.log di apache e del virtual host (se del caso), solitamente ti dice quale sia il problema

  3. #3
    Utente di HTML.it
    Registrato dal
    Oct 2007
    residenza
    Trieste
    Messaggi
    790
    Quote Originariamente inviata da Dascos Visualizza il messaggio
    Hai accesso ai log di sistema? Se sì, verifica error.log di apache e del virtual host (se del caso), solitamente ti dice quale sia il problema
    avrei accesso al file, ma cosa devo fare? Replicare l'evento e cercare il log relativo a quel momento?

  4. #4
    esatto...."carichi" il plugin/apri la pagina che ti da errore, annoti l'orario, scarichi/apri il file di log e cerchi quell'orario con errore 500 e vedi cosa trovi

  5. #5
    Utente di HTML.it
    Registrato dal
    Oct 2007
    residenza
    Trieste
    Messaggi
    790
    ...mah, qui non c'è niente. Il file contiene righe fin dal 2018, ma nulla nel momento che ho replicato l'errore.

  6. #6
    Quote Originariamente inviata da stardom Visualizza il messaggio
    ...mah, qui non c'è niente. Il file contiene righe fin dal 2018, ma nulla nel momento che ho replicato l'errore.
    il che significa o che guardi il log sbagliato o che hai un livello di log troppo alto...
    Sarebbe utile a questo punto vedere la configurazione dei log di apache (direttiva CustomLog ed ErrorLog sia di Apache che del virtual host), sia verificare se wordpress imposta l'error reporting a zero.....che è un pelo più complicato capire DOVE lo fa, eventualmente

  7. #7
    Utente di HTML.it
    Registrato dal
    Oct 2007
    residenza
    Trieste
    Messaggi
    790
    Puoi indicarmi meglio dove guardare? Ho trovato un tutorial ma non so utilizzare la SHELL.
    Ho solo capacità da utente via WHM/cPanel ma non saprei dove trovare le cose che stai citando.
    Ultima modifica di stardom; 27-06-2022 a 21:56

  8. #8
    Quote Originariamente inviata da stardom Visualizza il messaggio
    Puoi indicarmi meglio dove guardare? Ho trovato un tutorial ma non so utilizzare la SHELL.
    Ho solo capacità da utente via WHM/cPanel ma non saprei dove trovare le cose che stai citando.
    Troppo complicato da fare attraverso un forum...
    Hai già provato, ovviamente dopo aver fatto un backup, a reinstallare il plugin che crea problemi?

  9. #9
    Utente di HTML.it
    Registrato dal
    Oct 2007
    residenza
    Trieste
    Messaggi
    790
    Eh si ho provato, anche perchè è il plugin delle impostazioni del tema, senza il quale non funziona nulla. Purtroppo è un plugin obsoleto, ma è inserito nel tema e non posso certo eliminarlo. Qualcuno l'ha anche inforchettato, ma non mi azzardo a sostituirlo.
    Ultima modifica di stardom; 28-06-2022 a 09:36

  10. #10
    Ah beh, allora ti conviene cambiare tema, credo ci sia poco da fare nel senso che magari oggi risolvi ma col prossimo aggiornamento di Wp sei punto e a capo

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2022 vBulletin Solutions, Inc. All rights reserved.