Visualizzazione dei risultati da 1 a 4 su 4
  1. #1

    [JAVA] Caricamento di GeoGebra fallisce in seguito all' installazione dell' openjdk-17

    Buongiorno, come da titolo il programma Geogebra non carica.
    Riporto dettagli errore sul caricamento di GeoGebra(ma anche con altre app)

    Exception in thread "main" java.lang.UnsatisfiedLinkError: Can't load library: /usr/lib/jvm/java-17-openjdk-amd64/lib/libawt_xawt.so
    at java.base/java.lang.ClassLoader.loadLibrary(ClassLoader.java :2393)
    at java.base/java.lang.Runtime.load0(Runtime.java:755)
    at java.base/java.lang.System.load(System.java:1953)
    at java.base/jdk.internal.loader.NativeLibraries.load(Native Method)
    at java.base/jdk.internal.loader.NativeLibraries$NativeLibraryI mpl.open(NativeLibraries.java:388)
    at java.base/jdk.internal.loader.NativeLibraries.loadLibrary(Na tiveLibraries.java:232)
    at java.base/jdk.internal.loader.NativeLibraries.loadLibrary(Na tiveLibraries.java:174)
    at java.base/jdk.internal.loader.NativeLibraries.findFromPaths( NativeLibraries.java:315)
    at java.base/jdk.internal.loader.NativeLibraries.loadLibrary(Na tiveLibraries.java:285)
    at java.base/java.lang.ClassLoader.loadLibrary(ClassLoader.java :2398)
    at java.base/java.lang.Runtime.loadLibrary0(Runtime.java:818)
    at java.base/java.lang.System.loadLibrary(System.java:1989)
    at java.desktop/java.awt.Toolkit$2.run(Toolkit.java:1392)
    at java.desktop/java.awt.Toolkit$2.run(Toolkit.java:1390)
    at java.base/java.security.AccessController.doPrivileged(Access Controller.java:318)
    at java.desktop/java.awt.Toolkit.loadLibraries(Toolkit.java:1389)
    at java.desktop/java.awt.Toolkit.initStatic(Toolkit.java:1427)
    at java.desktop/java.awt.Toolkit.<clinit>(Toolkit.java:1401)
    at geogebra.GeoGebra.main(GeoGebra.java:79)
    jabjoint

  2. #2
    Moderatore di Programmazione L'avatar di LeleFT
    Registrato dal
    Jun 2003
    Messaggi
    17,245
    Da una ricerca, quel tipo di problema può essere causato dall'installazione di openjdk-17-headless.
    Devi installare la versione openjdk-17-jdk.

    Ciao.
    "Perchè spendere anche solo 5 dollari per un S.O., quando posso averne uno gratis e spendere quei 5 dollari per 5 bottiglie di birra?" [Jon "maddog" Hall]
    Fatti non foste a viver come bruti, ma per seguir virtute e canoscenza

  3. #3
    Quote Originariamente inviata da LeleFT Visualizza il messaggio
    Da una ricerca, quel tipo di problema può essere causato dall'installazione di openjdk-17-headless.
    Devi installare la versione openjdk-17-jdk.

    Ciao.
    Ho capito...grazie ora tento.
    jabjoint

  4. #4
    Quote Originariamente inviata da LeleFT Visualizza il messaggio
    Da una ricerca, quel tipo di problema può essere causato dall'installazione di openjdk-17-headless.
    Devi installare la versione openjdk-17-jdk.

    Ciao.
    Funziona tutto come prima. Grazie.
    jabjoint

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2022 vBulletin Solutions, Inc. All rights reserved.