Pagina 1 di 2 1 2 ultimoultimo
Visualizzazione dei risultati da 1 a 10 su 12

Discussione: Postfix che non va...

  1. #1
    Utente di HTML.it L'avatar di Burns
    Registrato dal
    Nov 2002
    Messaggi
    160

    Postfix che non va...

    Stavo provando postfix, ma non va: non riesco ad inviare le email con mutt...
    ci sto sbattendo la testa da un paio di giorni ma non va

    Ho configurato tutto (credo) correttamente, compreso il file /etc/postfix/main.cf
    Semplicemente scrivo un messaggio con mutt, poi lo invio e mutt si blocca, dicendo soltanto
    "Spedisco il messaggio...".
    Dando postfix start o reload o check non c' nessun errore

    Cosa potrebbe essere?
    Devo settare qualcosa dentro il file ~/.muttrc (credo di no comunque)?
    Chiedo aiuto, visto che non ne sto venendo a capo

    Ovviamente c' avviato solo postfix, niente sendmail o altro

    I'm not a geek!
    I'm a level 12 Paladin.
    [Jabber|ICQ|GPG]

  2. #2
    Utente di HTML.it L'avatar di arsy
    Registrato dal
    Jul 2002
    Messaggi
    74
    io uso mutt con exim, se vuoi ti posso dare una mano
    da vicino nessuno normale

  3. #3
    Utente di HTML.it L'avatar di Burns
    Registrato dal
    Nov 2002
    Messaggi
    160
    Originariamente inviato da arsy
    io uso mutt con exim, se vuoi ti posso dare una mano
    Grazie dell'interessamento! Per adesso vorrei capire perch diamine non va postfix, mi sta tirando scemo
    I'm not a geek!
    I'm a level 12 Paladin.
    [Jabber|ICQ|GPG]

  4. #4
    Utente di HTML.it L'avatar di arsy
    Registrato dal
    Jul 2002
    Messaggi
    74
    per quanto ne sappia, mutt gira con exim, altrimenti devi fare dei cambi nel Muttrc..
    prendila con la pinza sta cosa, ma comunque in considerazione.
    se vuoi con exim in 5 minuti mandi mail, io sono qua


    da vicino nessuno normale

  5. #5
    Utente di HTML.it L'avatar di Burns
    Registrato dal
    Nov 2002
    Messaggi
    160
    Originariamente inviato da ciromosketta
    io uso mutt tranquillamente con postfix, per la configurazione trovi una buona guida qui
    Ho gi letto quella e anche un'altra, eppure non mi va...
    I'm not a geek!
    I'm a level 12 Paladin.
    [Jabber|ICQ|GPG]

  6. #6
    Utente di HTML.it
    Registrato dal
    Aug 2005
    Messaggi
    19
    postaci il maillog

  7. #7
    Utente di HTML.it L'avatar di Burns
    Registrato dal
    Nov 2002
    Messaggi
    160
    Originariamente inviato da Morfeus
    postaci il maillog
    Grazie, leggendo i log ho risolto questo piccolo problema... adesso le invia!
    Non ci avevo neanche pensato


    Ma ora il problema vero, che non riesco a risolvere in nessun modo

    In pratica nelle mie email, l'header sbagliato. O meglio, questi sono i miei dati
    utente che invia: cava (ma lo fa anche con root)
    hostname: hogwarts
    dominio: land (o hogwarts.land, come vuoi te )

    Adesso ti posto l'header di una mail che mi sono mandato a un mio account su yahoo, per provare ( una delle tre milioni di mail che mi sono mandato, visto che sto continuando a provare ma senza successo )
    Come puoi vedere, di errato c' il campo Return-Path, e anche altri... ma come
    diavolo faccio a mettere quello che voglio??


    codice:
    X-Apparently-To:	 matteox84@yahoo.it via 217.12.12.115; Wed, 12 May 2004 05:20:47 -0700
    Return-Path:	<cava@hogwarts.land>
    Received:	from 212.216.176.141 (EHLO vsmtp1.tin.it) (212.216.176.141) by mta102.mail.sc5.yahoo.com with SMTP; Wed, 12 May 2004 05:20:46 -0700
    Received:	from hogwarts.land (80.116.122.91) by vsmtp1.tin.it (7.0.027) id 4087242E0041F93C for matteox84@yahoo.it; Wed, 12 May 2004 14:20:45 +0200
    Received:	by hogwarts.land (Postfix, from userid 0) id 8B8DF15DDCF; Wed, 12 May 2004 14:20:46 +0200 (CEST)
    Data:	Wed, 12 May 2004 14:20:46 +0200
    Da:	"Matteo" <matteox84@yahoo.it>  Aggiungi alla Rubrica
    A:	matteox84@yahoo.it
    Oggetto:	prova
    Message-ID:	<20040512122046.GA2088@hogwarts>
    Rispondi:	matteox84@yahoo.it
    Mime-Version:	1.0
    Content-Type:	text/plain; charset=us-ascii
    Content-Disposition:	inline
    User-Agent:	Mutt/1.4.2.1i
    Content-Length:	34

    Aiuto che sono disperato
    I'm not a geek!
    I'm a level 12 Paladin.
    [Jabber|ICQ|GPG]

  8. #8
    Utente di HTML.it L'avatar di Burns
    Registrato dal
    Nov 2002
    Messaggi
    160
    Tra l'altro in
    /var/log/maillog
    c' una riga che potrebbe essere quella "incriminata"

    May 12 14:42:48 hogwarts postfix/qmgr[2063]: D822F15DDD8: from=<cava@hogwarts.land>, size=475, nrcpt=1 (queue active)

    e qmgr un file (non di conf) presente in
    /usr/libexec/postfix
    ma il problema che non so che farmene
    I'm not a geek!
    I'm a level 12 Paladin.
    [Jabber|ICQ|GPG]

  9. #9
    Utente di HTML.it
    Registrato dal
    Aug 2005
    Messaggi
    19
    Originariamente inviato da Burns
    Tra l'altro in
    /var/log/maillog
    c' una riga che potrebbe essere quella "incriminata"

    May 12 14:42:48 hogwarts postfix/qmgr[2063]: D822F15DDD8: from=<cava@hogwarts.land>, size=475, nrcpt=1 (queue active)

    e qmgr un file (non di conf) presente in
    /usr/libexec/postfix
    ma il problema che non so che farmene

    qmgr lascialo l dov': il binario che gestisce le code delle mail. Devi usare postqueue (come utente) o postsuper come root, ma non so che opzioni gli devi passare (casomai man postqueue). Ovviamente hai settato gli account in /etc/postfix/aliases vero?

  10. #10
    Utente di HTML.it L'avatar di Burns
    Registrato dal
    Nov 2002
    Messaggi
    160
    Originariamente inviato da Morfeus
    qmgr lascialo l dov': il binario che gestisce le code delle mail. Devi usare postqueue (come utente) o postsuper come root, ma non so che opzioni gli devi passare (casomai man postqueue). Ovviamente hai settato gli account in /etc/postfix/aliases vero?
    aliases settato
    Per il resto... credevo che fosse un po' pi semplice postfix! Ma non basta settare qualche variabile nel main.cf?
    I'm not a geek!
    I'm a level 12 Paladin.
    [Jabber|ICQ|GPG]

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.