Pagina 1 di 2 1 2 ultimoultimo
Visualizzazione dei risultati da 1 a 10 su 17
  1. #1
    Utente di HTML.it L'avatar di mschievano
    Registrato dal
    Jan 2002
    residenza
    Padova, Italy
    Messaggi
    1,048

    [KNX 3.3] quale kernel ?

    secondo voi cosa dovrei scaricare su una knoppix 3.3 aggiornata con kde 3.2 gcc 3.3 e tutto l'immaginabile per fargli vedere l'usb? (kernel? con apt-get? quale?)

    sono risucito ad installare alcuni giochi di windows, winmx, cinelerra, xine, xmms, ma non c'è modo di farlo stampare (canon s400 usb), e acquisire foto (kodak cx4230 usb)

    all'avvio sembra che testualmente scriva
    usb.c non accepting the id 2....
    trying 3...
    usb.c non accepting the id 3....
    trying 4.
    usb.c non accepting the id 4....
    backgrounding...


    Nuovo Sistema: iMac 24" dual core intel... e il virus non c'è più.
    un mio articolo su
    sognandolondra

  2. #2
    sicuro che venga caricato il giusto modulo usb all'avvio?
    comunque io andrei sul 2.6.3

  3. #3
    Utente di HTML.it L'avatar di mschievano
    Registrato dal
    Jan 2002
    residenza
    Padova, Italy
    Messaggi
    1,048

    scaricabile

    Originariamente inviato da almafer
    sicuro che venga caricato il giusto modulo usb all'avvio?
    comunque io andrei sul 2.6.3
    con apt-get ?
    con che sources?

    no, tra l'altro non sono sicuro che il modulo venga caricato....
    Nuovo Sistema: iMac 24" dual core intel... e il virus non c'è più.
    un mio articolo su
    sognandolondra

  4. #4
    appunto, magari dipende da quello
    che chipset ha la tua scheda madre?
    fai un po un
    dmesg
    e posta quello che riguarda l'usb

  5. #5
    Utente di HTML.it L'avatar di mschievano
    Registrato dal
    Jan 2002
    residenza
    Padova, Italy
    Messaggi
    1,048

    urca.....

    Linux version 2.4.22-xfs (root@Knoppix) (gcc version 2.95.4 20011002 (Debian pre
    release)) #1 SMP Fr Okt 3 20:36:25 CEST 2003
    BIOS-provided physical RAM map:
    BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
    BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
    BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
    BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
    BIOS-e820: 000000001fff0000 - 000000001fff3000 (ACPI NVS)
    BIOS-e820: 000000001fff3000 - 0000000020000000 (ACPI data)
    BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
    BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
    BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
    0MB HIGHMEM available.
    511MB LOWMEM available.
    found SMP MP-table at 000f4bc0
    hm, page 000f4000 reserved twice.
    hm, page 000f5000 reserved twice.
    hm, page 000f1000 reserved twice.
    hm, page 000f2000 reserved twice.
    On node 0 totalpages: 131056
    zone(0): 4096 pages.
    zone(1): 126960 pages.
    zone(2): 0 pages.
    Intel MultiProcessor Specification v1.4
    Virtual Wire compatibility mode.
    OEM ID: OEM00000 Product ID: PROD00000000 APIC at: 0xFEE00000
    Processor #0 Pentium(tm) Pro APIC version 17
    I/O APIC #2 Version 17 at 0xFEC00000.
    Enabling APIC mode: Flat. Using 1 I/O APICs
    Processors: 1
    Kernel command line: BOOT_IMAGE=Linux ro root=301 hda=scsi hdb=scsi hdc=scsi hdd
    =scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi apm=power-off nomce
    ide_setup: hda=scsi
    ide_setup: hdb=scsi
    ide_setup: hdc=scsi
    ide_setup: hdd=scsi
    ide_setup: hde=scsi
    ide_setup: hdf=scsi
    ide_setup: hdg=scsi
    ide_setup: hdh=scsi
    Initializing CPU#0
    Detected 1799.710 MHz processor.
    Console: colour dummy device 80x25
    Calibrating delay loop... 3591.37 BogoMIPS
    Memory: 515076k/524224k available (1262k kernel code, 8760k reserved, 534k data,
    132k init, 0k highmem)
    Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
    Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
    Mount cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer cache hash table entries: 32768 (order: 5, 131072 bytes)
    Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
    CPU: CLK_CTL MSR was 6003d22f. Reprogramming to 2003d22f
    CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
    CPU: L2 Cache: 256K (64 bytes/line)
    CPU: After generic, caps: 0383fbff c1c3fbff 00000000 00000000
    CPU: Common caps: 0383fbff c1c3fbff 00000000 00000000
    Enabling fast FPU save and restore... done.
    Enabling unmasked SIMD FPU exception support... done.
    Checking 'hlt' instruction... OK.
    Checking for popad bug... OK.
    POSIX conformance testing by UNIFIX
    mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
    mtrr: detected mtrr type: Intel
    CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
    CPU: L2 Cache: 256K (64 bytes/line)
    CPU: After generic, caps: 0383fbff c1c3fbff 00000000 00000000
    CPU: Common caps: 0383fbff c1c3fbff 00000000 00000000
    CPU0: AMD Athlon(tm) XP 2200+ stepping 01
    per-CPU timeslice cutoff: 731.49 usecs.
    enabled ExtINT on CPU#0
    ESR value before enabling vector: 00000000
    ESR value after enabling vector: 00000000
    Error: only one processor found.
    ENABLING IO-APIC IRQs
    Setting 2 in the phys_id_present_map
    ...changing IO-APIC physical APIC ID to 2 ... ok.
    init IO_APIC IRQs
    IO-APIC (apicid-pin) 2-0, 2-11, 2-18, 2-20, 2-21, 2-22, 2-23 not connected.
    ..TIMER: vector=0x31 pin1=2 pin2=0
    number of MP IRQ sources: 23.
    number of IO-APIC #2 registers: 24.
    testing the IO APIC.......................

    IO APIC #2......
    .... register #00: 02000000
    ....... : physical APIC id: 02
    ....... : Delivery Type: 0
    ....... : LTS : 0
    .... register #01: 00178002
    ....... : max redirection entries: 0017
    ....... : PRQ implemented: 1
    ....... : IO APIC version: 0002
    .... IRQ redirection table:
    NR Log Phy Mask Trig IRR Pol Stat Dest Deli Vect:
    ...
    IRQ to pin mappings:
    IRQ0 -> 0:2
    IRQ1 -> 0:1
    IRQ3 -> 0:3
    IRQ4 -> 0:4
    IRQ5 -> 0:5
    IRQ6 -> 0:6
    IRQ7 -> 0:7
    IRQ8 -> 0:8
    IRQ9 -> 0:9
    IRQ10 -> 0:10
    IRQ12 -> 0:12
    IRQ13 -> 0:13
    IRQ14 -> 0:14
    IRQ15 -> 0:15
    IRQ16 -> 0:16
    IRQ17 -> 0:17
    IRQ19 -> 0:19
    .................................... done.
    Using local APIC timer interrupts.
    calibrating APIC timer ...
    ..... CPU clock speed is 1799.7616 MHz.
    ..... host bus clock speed is 266.6312 MHz.
    cpu: 0, clocks: 2666312, slice: 1333156
    CPU0<T0:2666304,T1:1333136,D:12,S:1333156,C:266631 2>
    Waiting on wait_init_idle (map = 0x0)
    All processors have done init_idle
    PCI: PCI BIOS revision 2.10 entry at 0xfb440, last bus=1
    PCI: Using configuration type 1
    PCI: Probing PCI hardware
    PCI: Probing PCI hardware (bus 00)
    PCI: Using IRQ router default [1106/3099] at 00:00.0
    ...
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    Starting kswapd
    VFS: Disk quotas vdquot_6.5.1
    vesafb: framebuffer at 0xe0000000, mapped to 0xe080d000, size 3072k
    vesafb: mode is 1024x768x16, linelength=2048, pages=0
    vesafb: protected mode interface info at c000:c060
    vesafb: scrolling: redraw
    vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
    Console: switching to colour frame buffer device 128x48
    fb0: VESA VGA frame buffer device
    pty: 256 Unix98 ptys configured
    Floppy drive(s): fd0 is 1.44M
    FDC 0 is a post-1991 82077
    RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
    Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    ...
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: attached ide-disk driver.
    hda: host protected area => 1
    hda: 160086528 sectors (81964 MB) w/2048KiB Cache, CHS=9964/255/63
    hdb: attached ide-disk driver.
    hdb: host protected area => 1
    hdb: 39876480 sectors (20417 MB) w/418KiB Cache, CHS=2482/255/63
    ide-cd: passing drive hdc to ide-scsi emulation.
    ide-cd: passing drive hdd to ide-scsi emulation.
    hdc: attached ide-scsi driver.
    hdd: attached ide-scsi driver.
    Partition check:
    hda: hda1 hda2
    hdb: [LDM] hdb1
    ide: late registration of driver.
    Promise Fasttrak(tm) Softwareraid driver 0.03beta: No raid array found
    Highpoint HPT370 Softwareraid driver for linux version 0.02
    Guestimating sector 160085503 for superblock
    Guestimating sector 39875455 for superblock
    driver for Silicon Image(tm) Medley(tm) hardware version 0.0.1: No raid array fo
    und
    SCSI subsystem driver Revision: 1.00
    scsi0 : SCSI host adapter emulation for IDE ATAPI devices
    Vendor: PHILIPS Model: CDD7052 Rev: B1.2
    Type: CD-ROM ANSI SCSI revision: 02
    Vendor: LITEON Model: DVD-ROM LTD163D Rev: GHR3
    Type: CD-ROM ANSI SCSI revision: 02
    Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
    Attached scsi CD-ROM sr1 at scsi0, channel 0, id 1, lun 0
    sr0: scsi3-mmc drive: 52x/52x writer cd/rw xa/form2 cdda tray
    Uniform CD-ROM driver Revision: 3.12
    sr1: scsi3-mmc drive: 24x/48x cd/rw xa/form2 cdda tray
    Initializing Cryptographic API
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP, IGMP
    IP: routing cache hash table of 4096 buckets, 32Kbytes
    TCP: Hash tables configured (established 32768 bind 32768)
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    RAMDISK: Compressed image found at block 0
    Freeing initrd memory: 170k freed
    VFS: Mounted root (ext2 filesystem).
    FAT: bogus logical sector size 0
    reiserfs: found format "3.6" with standard journal
    reiserfs: checking transaction log (device ide0(3,1)) ...
    for (ide0(3,1))
    ide0(3,1):Using r5 hash to sort names
    VFS: Mounted root (reiserfs filesystem) readonly.
    Trying to move old root to /initrd ... okay
    Freeing unused kernel memory: 132k freed
    Adding Swap: 1911724k swap-space (priority -1)
    Real Time Clock Driver v1.10e
    apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16)
    usb.c: registered new driver usbdevfs
    usb.c: registered new driver hub
    usb-uhci.c: $Revision: 1.275 $ time 20:50:29 Oct 3 2003
    usb-uhci.c: High bandwidth mode enabled
    usb-uhci.c: USB UHCI at I/O 0xe000, IRQ 19
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 1
    hub.c: USB hub found
    hub.c: 2 ports detected
    usb-uhci.c: USB UHCI at I/O 0xe400, IRQ 19
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 2
    hub.c: USB hub found
    hub.c: 2 ports detected
    usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
    Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI IS
    APNP enabled
    ttyS00 at 0x03f8 (irq = 4) is a 16550A
    ttyS01 at 0x02f8 (irq = 3) is a 16550A
    Linux video capture interface: v1.00
    i2c-core.o: i2c core module
    i2c-algo-bit.o: i2c bit algorithm module
    bttv: driver version 0.7.107 loaded
    bttv: using 4 buffers with 2080k (8320k total) for capture
    bttv: Host bridge is VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
    bttv: Bt8xx card found (0).
    bttv0: Bt878 (rev 17) at 00:08.0, irq: 16, latency: 32, mmio: 0xee000000
    bttv0: using: BT878( *** UNKNOWN/GENERIC **) [card=0,autodetected]
    i2c-core.o: adapter bt848 #0 registered as adapter 0.
    bttv: readee error
    bttv0: using tuner=-1
    bttv0: i2c: checking for MSP34xx @ 0x80... not found
    bttv0: i2c: checking for TDA9875 @ 0xb0... not found
    bttv0: i2c: checking for TDA7432 @ 0x8a... not found
    bttv0: registered device video0
    bttv0: registered device vbi0
    hub.c: new USB device 00:11.2-2, assigned address 2
    i2c-core.o: driver i2c TV tuner driver registered.
    tuner: chip found @ 0xc0
    i2c-core.o: client [(tuner unset)] registered to adapter [bt848 #0](pos. 0).
    gameport0: Emu10k1 Gameport at 0xd800 size 8 speed 1217 kHz
    8139too Fast Ethernet driver 0.9.26
    eth0: SMC1211TX EZCard 10/100 (RealTek RTL8139) at 0xe0d4d000, 00:10:b5:06:4f:a2
    , IRQ 17
    eth0: Identified 8139 chip type 'RTL-8139A'
    Creative EMU10K1 PCI Audio Driver, version 0.20, 20:49:40 Oct 3 2003
    emu10k1: EMU10K1 rev 7 model 0x8040 found, IO at 0xd400-0xd41f, IRQ 19
    ac97_codec: AC97 Audio codec, id: 0x8384:0x7609 (SigmaTel STAC9721/23)
    Linux agpgart interface v0.99 (c) Jeff Hartmann
    agpgart: Maximum main memory to use for agp memory: 439M
    agpgart: Detected Via Apollo Pro KT266 chipset
    agpgart: AGP aperture is 64M @ 0xe8000000
    NTFS driver v1.1.22 [Flags: R/W MODULE]
    Journalled Block Device driver loaded
    SGI XFS snapshot 2.4.22-2003-09-03_04:09_UTC with ACLs, realtime, no debug enabl
    ed
    SGI XFS Quota Management subsystem
    EFS: 1.0a - http://aeschi.ch.eu.org/efs/
    md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
    LVM version 1.0.5+(22/07/2002) module loaded
    loop: loaded (max 8 devices)
    blk: queue c0334b60, I/O limit 4095Mb (mask 0xffffffff)
    blk: queue c0334ca8, I/O limit 4095Mb (mask 0xffffffff)
    usb_control/bulk_msg: timeout
    usb.c: USB device not accepting new address=2 (error=-110)
    hub.c: new USB device 00:11.2-2, assigned address 3
    usb_control/bulk_msg: timeout
    usb.c: USB device not accepting new address=3 (error=-110)
    NET4: Linux IPX 0.47 for NET4.0
    IPX Portions Copyright (c) 1995 Caldera, Inc.
    IPX Portions Copyright (c) 2000, 2001 Conectiva, Inc.
    CAPI-driver Rev 1.1.4.1: loaded
    capifs: Rev 1.1.4.1
    capi20: started up with major 68
    kcapi: capi20 attached
    capi20: Rev 1.1.4.2: started up with major 68 (middleware+capifs)
    b1: revision 1.1.4.1
    b1dma: revision 1.1.4.1
    b1pci: revision 1.1.4.1
    kcapi: driver b1pci attached
    b1pciv4: revision 1.1.4.1
    kcapi: driver b1pciv4 attached
    b1pci: NO B1-PCI card detected
    kcapi: driver b1pci detached
    kcapi: driver b1pciv4 detached
    b1: revision 1.1.4.1
    c4: revision 1.1.4.1
    kcapi: driver c4 attached
    c2: revision 1.1.4.1
    kcapi: driver c2 attached
    c4: NO C4/C2 card detected
    kcapi: driver c4 detached
    kcapi: driver c2 detached
    b1: revision 1.1.4.1
    c4: revision 1.1.4.1
    kcapi: driver c4 attached
    c2: revision 1.1.4.1
    kcapi: driver c2 attached
    c4: NO C4/C2 card detected
    kcapi: driver c4 detached
    kcapi: driver c2 detached
    b1: revision 1.1.4.1
    c4: revision 1.1.4.1
    kcapi: driver c4 attached
    c2: revision 1.1.4.1
    kcapi: driver c2 attached
    c4: NO C4/C2 card detected
    kcapi: driver c4 detached
    kcapi: driver c2 detached
    b1: revision 1.1.4.1
    c4: revision 1.1.4.1
    kcapi: driver c4 attached
    c2: revision 1.1.4.1
    kcapi: driver c2 attached
    c4: NO C4/C2 card detected
    kcapi: driver c4 detached
    kcapi: driver c2 detached
    parport0: PC-style at 0x378 [PCSPP,TRISTATE]
    parport0: irq 7 detected
    lp0: using parport0 (polling).
    lp0: console ready
    CSLIP: code copyright 1989 Regents of the University of California
    PPP generic driver version 2.4.2
    eth0: Setting 100mbps full-duplex based on auto-negotiated partner ability 41e1.
    PPP BSD Compression module registered
    PPP Deflate Compression module registered
    Nuovo Sistema: iMac 24" dual core intel... e il virus non c'è più.
    un mio articolo su
    sognandolondra

  6. #6
    il modulo che viene caricato è quello giusto, uhci su chipset via.
    queste periferiche sono collegate a delle prese sulle scheda madre o per caso c'è una scheda pc-usb o un hub? :master:

  7. #7
    dimenticavo...
    per la stampante usb serve anche il modulo usblp, prova a caricarlo e poi dal centro di controllo kde scegli i driver cups e prova a configurare la stampante.
    per la fotocamera digitale serve il modulo il modulo usb-storage

  8. #8
    Utente di HTML.it L'avatar di mschievano
    Registrato dal
    Jan 2002
    residenza
    Padova, Italy
    Messaggi
    1,048

    collegate

    al pc.

    con fedora usavo un hub, ho provato atoglierlo in knoppix, ma niente.

    ora ho scaricato è sto compilando il kernel 2.6.3

    vedo se intanto può servirmi (sono al make all, prima di dare make modules_install )
    Nuovo Sistema: iMac 24" dual core intel... e il virus non c'è più.
    un mio articolo su
    sognandolondra

  9. #9
    Utente di HTML.it L'avatar di mschievano
    Registrato dal
    Jan 2002
    residenza
    Padova, Italy
    Messaggi
    1,048

    ho lo stesso problema

    con la fotocamera digitale della kodak cx 4230.
    Con Fedora la vedevo subito. Con knoppix sono pippi!

    questo il dmesg relativo al boot odierno:

    codice:
    usb.c: registered new driver usbdevfs
    usb.c: registered new driver hub
    usb.c: deregistering driver usbdevfs
    usb.c: deregistering driver hub
    usb.c: registered new driver usbdevfs
    usb.c: registered new driver hub
    usb.c: deregistering driver usbdevfs
    usb.c: deregistering driver hub
    usb.c: registered new driver usbdevfs
    usb.c: registered new driver hub
    usb-uhci.c: $Revision: 1.275 $ time 01:17:44 Feb  4 2004
    usb-uhci.c: High bandwidth mode enabled
    usb-uhci.c: USB UHCI at I/O 0xe000, IRQ 19
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 1
    hub.c: USB hub found
    hub.c: 2 ports detected
    usb-uhci.c: USB UHCI at I/O 0xe400, IRQ 19
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 2
    hub.c: USB hub found
    hub.c: 2 ports detected
    usb-uhci.c: v1.275:USB Universal Host Controller Interface 
    driver
    Initializing USB Mass Storage driver...
    usb.c: registered new driver usb-storage
    USB Mass Storage support registered.
    hub.c: new USB device 00:11.2-2, assigned address 2
    usb_control/bulk_msg: timeout
    usb.c: USB device not accepting new address=2 (error=-110)
    hub.c: new USB device 00:11.2-2, assigned address 3
    usb_control/bulk_msg: timeout
    usb.c: USB device not accepting new address=3 (error=-110)
    e questo è il file /etc/modules

    codice:
     /etc/modules: kernel modules to load at boot time.
    rtc
    apm power_off=1
    usb-ohci
    ehci-hcd
    usb-uhci
    usb-storage
    serial
    emu10k1-gp
    8139too
    emu10k1
    agpgart
    ext3
    reiserfs
    xfs
    ntfs
    nls_iso8859-1
    minix
    hfs
    efs
    nls_cp437
    af_packet
    autofs4
    ppp_async
    bsd_comp
    ppp_deflate
    msdos
    e questo è lsusb

    root@ainex:~# lsusb
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 001: ID 0000:0000

    aiutatemi, mia moglie vuole farmi rimettere windows perchè non vede le foto del pupo!
    Nuovo Sistema: iMac 24" dual core intel... e il virus non c'è più.
    un mio articolo su
    sognandolondra

  10. #10
    Utente di HTML.it
    Registrato dal
    Jun 2002
    Messaggi
    371
    Senti mi sembra che nei moduli usb che hai caricato ci siano diversi errori, per prima cosa se hai un chip intel il modulo da caricare è "usb-uhci"(per kernel 2.4.x)o "uhci-hcd"(per kernel 2.6.x) mentre se il chip è via o sis il modulo da caricare è "usb-ohci" o "ohci-hcd" in ogni caso o uno o l'altro in base al chip che hai e il kernel usato

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.