Pagina 2 di 2 primaprima 1 2
Visualizzazione dei risultati da 11 a 17 su 17

Discussione: problema grafica

  1. #11
    Utente di HTML.it
    Registrato dal
    Nov 2003
    Messaggi
    1,308
    ...

    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corp."
    BoardName "NVIDIA GeForce2 DDR (generic)"
    Driver "nv"
    Option "DPMS"
    EndSection


    ...



    Devi mettere "nvidia" al posto di "nv" come driver.

  2. #12
    Originariamente inviato da Enrico81
    ...

    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corp."
    BoardName "NVIDIA GeForce2 DDR (generic)"
    Driver "nv"
    Option "DPMS"
    EndSection


    ...



    Devi mettere "nvidia" al posto di "nv" come driver.
    Si mi sono scordato di dire,il problema lo dà appunto con i nuovi driver (quando metto nvidia) poi per farlo funzionare ho rimesso nv

  3. #13
    Cmq il problema è scritto pure nel README

    Q: My X server fails to start, and my X log file contains the error:

    "(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!"

    A: Nothing will work if the NVIDIA kernel module does not function
    properly. If you see anything in the X log file like "(EE)
    NVIDIA(0): Failed to initialize the NVIDIA kernel module!" then
    there is most likely a problem with the NVIDIA kernel module.
    First, you should verify that if you installed from rpm that
    the rpm was built specifically for the kernel you are using.
    You should also check that the module is loaded ('/sbin/lsmod');
    if it is not loaded try loading it explicitly with 'insmod' or
    'modprobe' (be sure to exit the X server before installing a new
    kernel module). If you receive errors about unresolved symbols,
    then the kernel module has most likely been built using header files
    for a different kernel revision than what you are running. You can
    explicitly control what kernel header files are used when building
    the NVIDIA kernel module with the --kernel-include-dir option (see
    `sh NVIDIA-Linux-x86-1.0-6629-pkg1.run --advanced-options`
    for details).

    Please note that the convention for the location of kernel header
    files changed approximately at the time of the 2.4.0 kernel release,
    as did the location of kernel modules. If the kernel module fails to
    load properly, modprobe/insmod may be trying to load an older kernel
    module (assuming you have upgraded). cd'ing into the directory with
    the new kernel module and doing 'insmod ./nvidia.o' may help.

    Another cause may be that the /dev/nvidia* device files may be missing.

    Finally, the NVIDIA kernel module may print error messages indicating
    a problem -- to view these messages please check /var/log/messages, or
    wherever syslog is directed to place kernel messages. These messages
    are prepended with "NVRM".
    ma ho provato a fare prima di startx :
    insmod /sbin/lsmod
    oppure
    modprobe /sbin/lsmod

    ma nessuno dei due funge

  4. #14
    prova a scrivere nvidia in

    /etc/modprobe.preload


    mettici anche il modulo dell'agp della tua mobo

    modprobe -l | grep agp
    per sapere quelli disponibili
    es


    intel-agp
    via-agp

  5. #15
    Originariamente inviato da andy caps
    prova a scrivere nvidia in

    /etc/modprobe.preload


    mettici anche il modulo dell'agp della tua mobo

    modprobe -l | grep agp
    per sapere quelli disponibili
    es


    intel-agp
    via-agp
    allora, facendo
    modprobe -l | grep agp

    trova

    codice:
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/via-agp.ko.gz
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/sworks-agp.ko.gz
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/sis-agp.ko.gz
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/nvidia-agp.ko.gz
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/intel-agp.ko.gz
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/intel-mch-agp.ko.gz
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/ati-agp.ko.gz
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/amd64-agp.ko.gz
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/efficeon-agp.ko.gz
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/ali-agp.ko.gz
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/agpgart.ko.gz
    /lib/modules/2.6.8.1-10mdk/kernel/drivers/char/agp/amd-k7-agp.ko.gz
    All'/etc/modprobe.preload ho aggiunto le ultime tre voci:


    codice:
    # /etc/modprobe.preload: kernel modules to load at boot time.
    #
    # This file should contain the names of kernel modules that are
    # to be loaded at boot time, one per line.  Comments begin with
    # a `#', and everything on the line after them are ignored.
    # this file is for module-init-tools (kernel 2.5 and above) ONLY
    # for old kernel use /etc/modules
    
    via-agp
    intel-agp
    nvidia
    nvidia-agp
    ma niente..

  6. #16
    devi mettere solo quello della tua scheda madre

    se hai chipset intel quello intel se ha via il suo e nvidia-agp se ha nforce

    prova a mettere nel file di conf una riga nella sezione dei driver

    Section "Device"
    Identifier "Generic Video Card"
    Driver "nvidia"
    Option "NvAGP" "1"
    EndSection

    altrimenti io proverei a scaricare i driver di nvidia precedenti

  7. #17
    grazie adesso funziona! (anche se va un pò lento e la grafica non è un granchè) non è che devo installare altro per migliorarla?

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.