Pagina 1 di 2 1 2 ultimoultimo
Visualizzazione dei risultati da 1 a 10 su 14

Discussione: startx con SID

  1. #1

    startx con SID

    Uso SID da un 2 mesetti circa, ogni giorno eseguo un dist-upgrade e tutto sempre andato bene e alla perfezione.

    Oggi non so per quale strano motivo, ma appena lancio startx, sta li in attesa, mi esce per 4 volte di seguito il messaggio:

    Xauth: timeout in locking authority file /home/user1/.Xauthority

    Dopo che rimango in attesa per un minuto circa vedendo solo questo messaggio per quattro volte, mi entra in X e tutto sembra normale come al solito.

    Cosa pu essere?

    Da root startx funziona subito e perfettamente. Sono con l'utente normale mi ritarda la partenza.

    Idee???

  2. #2
    prima di avviare X dai il comando
    xauth merge /home/user1/.Xauthority


  3. #3
    Ho lanciato il comando che mi hai detto ma rimane li in attesa e poi mi butto fuori lo stesso errore...

  4. #4
    Ho constatato che non funziona il download di firefox... se mi loggo come root invece il download di firefox funziona... come mai??

  5. #5
    Con l'aggiornamento di oggi (ogni giorno controllo e faccio gli aggiornamenti a SID) non funzionano un po' di cose.

    Per esempio oltre all'errore di Xauth, non funziona il download di firefox e non mi funziona l'audio. In tutti i casi sembra che ci siano degli errori di access denied. Cosa pu essere? qualcuno ha riscontrato gli stessi errori dopo aver effettuato un aggiornamento della SID??

    Tutto invece funziona perfettamente sotto root...

    HELP

  6. #6
    io oggi non ho ancora fatto nessun upgrade e visto i prob che hai non lo faccio

    mi spiace ma per i tuoi prob non so cosa potrebbe essere

  7. #7
    creando un nuovo utente tutto sembra funzionare su quell'utente, ma sul mio utente niente da fare...

  8. #8
    rimuovi la dir .kde nella home dell'utente che non va
    puo darsi che l'aggiornamento abbia cambiato qualche file di configurazione

    al riavvio di kde se la ricrea anche se perdi le impostazioni p la posta se usi kmail

  9. #9
    Ciao Andy... prima di tutto grazie per essere intervenuto. Secondo io non uso KDE ma fluxbox. Fluxbox parte perch nel file .xinitrc nella home dell'utente c' inserito il comando exec fluxbox. Ho provato a togliere exec fluxbox e tutti gli altri comandi ma niente. Startx fatica a partire buttandomi fuori quei messaggi.

    Tra l'altro, lo stesso messaggio me lo restituisce se lancio il comando 'xauth -v'

    Se creo un nuovo utente e lancio il comando startx, X parte subito e funziona anche il download di firefox. Da root tutto perfetto come prima.

    Inoltre se cancello il mio utente conservando la home e poi lo ricreo l'errore persiste.

    Una cosa che ho notato che se lancio questo comando:

    startx 2> error dalla mia home directory mi da un permission denied.

    se lo stessto comando lo lancio da l'utente appena creato o da root, mi crea il file error.

    Sembra che ci siano dei conflitti nei permessi con il mio utente.

    HELPPPPPPPPPPPP

  10. #10
    qualche file di conf nella tua home

    prova a rinominare .Xauthority e riavviare l'utente

    al limite butta la home dell'utente che ha problemi
    e ricrealo dopo esserti salvato i file importanti

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2020 vBulletin Solutions, Inc. All rights reserved.