Pagina 1 di 3 1 2 3 ultimoultimo
Visualizzazione dei risultati da 1 a 10 su 26
  1. #1
    Utente di HTML.it
    Registrato dal
    Mar 2004
    Messaggi
    88

    Problema dopo ricompilazione del kernel 2.6 con slack10 e lilo!

    Salve a tutti.

    Ho ricompilato il kernel 2.6.7 per aggiungerci alcuni moduli seguendo una guida ke ho preso da slacky e tutto è andato bene, tutto bene fino al riavvio del pc! Dopo che ho riavviato il pc ed è apparsa la solita schermata di lilo, ho scelto la nuova slack, quindi è comparso la scritta: Loading Slack10_002...
    e poi basta ! Non viene caricato + niente...non capisco proprio dovo abbia sbagliato, ho seguito passo passo anke questa volta la stessa guida!

    Avete qualke idea di cosa possa aver sbagliato??

  2. #2
    Moderatore di Linux e software L'avatar di francofait
    Registrato dal
    Aug 2001
    Messaggi
    13,643

    Re: Problema dopo ricompilazione del kernel 2.6 con slack10 e lilo!

    Originariamente inviato da mross
    Salve a tutti.

    Ho ricompilato il kernel 2.6.7 per aggiungerci alcuni moduli seguendo una guida ke ho preso da slacky e tutto è andato bene, tutto bene fino al riavvio del pc! Dopo che ho riavviato il pc ed è apparsa la solita schermata di lilo, ho scelto la nuova slack, quindi è comparso la scritta: Loading Slack10_002...
    e poi basta ! Non viene caricato + niente...non capisco proprio dovo abbia sbagliato, ho seguito passo passo anke questa volta la stessa guida!

    Avete qualke idea di cosa possa aver sbagliato??
    hai ricreato anche initrd.gz ed riaggiornato il bootloader

    qualunque interveto sul kernel lo richiede .


  3. #3
    Utente di HTML.it
    Registrato dal
    Mar 2004
    Messaggi
    88
    Ok grazie francofait per la risposta tempestiva adesso ci provo!

  4. #4
    Utente di HTML.it
    Registrato dal
    Mar 2004
    Messaggi
    88
    Niente di fatto!
    Ho dato: mkinitrd -c -k 2.6.7 -m jbd:ext3 -f ext3 -r /dev/hda2 da console di slack, che mi ha generato initrd.gz, poi ho aggiunto a lilo.conf: initrd = /boot/initrd.gz, per diventare complessivamente:

    image = /boot/vmlinuz
    initrd = /boot/initrd.gz
    root = /dev/hda2
    label = Slack_X_2.6-002
    read-only # Non-UMSDOS filesystems should be mounted read-only for checking

    poi ho dato lilo -v come al solito, ma niente!

  5. #5
    Utente di HTML.it L'avatar di Trusty
    Registrato dal
    Dec 2004
    Messaggi
    642
    anche io ho questo problema nel mio 3° pc,, come si fa a risolverlo??
    http://www.oilproject.org/ -->La Scuola On-LIne degli smanettoni!

  6. #6
    Utente di HTML.it L'avatar di chaosd
    Registrato dal
    Mar 2004
    Messaggi
    1,282
    ma quando compili, poi fai "make modules_install" ?
    <Girls are like Internet Domains: the ones you like are already taken, but you can still get one from a strange country!>

    Computers are like conditioned air: they stop work properly when you open windows

    Livin' on: Kubuntu + 2.6.24.2

  7. #7
    Utente di HTML.it
    Registrato dal
    Mar 2004
    Messaggi
    88
    Si si certo ke l'ho fatto!

  8. #8
    Non serve crearsi l'initrd, ricompila il kernel inserendo il supporto a ext3 built in, e vedi se funziona!
    Powered by Slackware64 on Intel i7 920!

  9. #9
    Utente di HTML.it L'avatar di gigyz
    Registrato dal
    Oct 2003
    Messaggi
    1,447
    Originariamente inviato da mross
    N
    label = Slack_X_2.6-002
    ma sicuro che il lilo non ti da errore con quella label .... a occhio mi pare un po lunga

  10. #10
    Utente di HTML.it
    Registrato dal
    Mar 2004
    Messaggi
    88
    @ gigyz: si si sono sicuro se no mi avrebbe avvisato.

    @ trotto81: ma 6 sicuro? no xkè io ho solo ricompilato a partire da un .config in cui prima andava tutto ok con l'ext3....ma ok mettiamo ke sia per questo, in ke sezione posso impostare il supporto per l'ext3 come builtin??

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2019 vBulletin Solutions, Inc. All rights reserved.