PDA

Visualizza la versione completa : installare nvidia in mandriva 2006


mykol
27-06-2006, 16:57
Ciao,
mi vergogno a porre un quesito del genere (se ne è parlato chissà quante volte), ma non riesco a venirne a capo.
Quando lancio l'installer di nvidia la compilazione fallisce.

Al successivo riavvio compare un messaggio che mi dice che i moduli nvidia e libasf non possono essere caricati perchè il kernel-source-2.6.12-12mdk non è installato ecc ...

Sto usando il kernel-2.6.12-12mdk, ma se do

[root@localhost giorgio]# urpmi -y kernel-source
nessun pacchetto denominato kernel-source
I seguenti pacchetti contengono kernel-source:
dkms-libafs
kernel-source-2.6
kernel-source-stripped-2.6
[root@localhost giorgio]#

[root@localhost giorgio]# urpmi -y kernel-source-2.6 kernel-source-stripped-2.6 dkms-libafs -a
E' già tutto installato
[root@localhost giorgio]#

non esiste un kernel-source-2.6.1.2-12mdk da installare !

Cosa mi consigliate ?

Grazie

(spero di risolvere perchè muoio dalla voglia di veder volare tux !)

andy caps
27-06-2006, 19:43
guarda cosa hai in /usr/src
ls -ls /usr/src

devi installare solo un sorgente non due
urpmi kernel-source-2.6 lo installa
se non lo installa vuol dire che è gia installato

dai comunque
urpmi kernel per vedere cosa ai disponibile

nelle ultime versioni adesso si chiama linus e nelle precedenti linux

mykol
28-06-2006, 17:11
Ecco

[root@localhost giorgio]# ls -ls /usr/src
totale 2
1 drwxr-xr-x 8 root root 904 mag 29 17:20 apache_1.3.33/
0 drwxr-xr-x 4 root root 344 giu 17 14:50 libafs-1.3.87/
0 lrwxrwxrwx 1 root root 23 giu 17 15:48 linux -> linux-2.6.12-12.mm.1mdk/
1 drwxr-xr-x 20 root root 768 giu 27 18:15 linux-2.6.12-12.mm.1mdk/
1 drwxr-xr-x 21 root root 760 giu 28 16:05 linux-2.6.12-22mdk/
1 drwxr-xr-x 2 root root 800 giu 17 20:17 nvidia-8762-0.1.20060plf/
0 drwxr-xr-x 7 root root 168 set 15 2005 RPM/
[root@localhost giorgio]#

Ho installato il kernel 2.6.12-22mdk

[root@localhost giorgio]# uname -a
Linux localhost 2.6.12-22mdk #1 Tue May 23 17:26:47 MDT 2006 i686 AMD Athlon(tm) XP 2000+ unknown GNU/Linux
[root@localhost giorgio]#

ho modificato xorg.conf sosstituendo "nv" con "nvidia", al boot mi carica il modulo "libafs" (ad ogni boot) (avvio dkms: libafs ..... installing module ... poi mi dice che non l'ha potuto installare.

[root@localhost giorgio]# lsmod |grep nvidia
nvidia 4528084 8
agpgart 29032 2 nvidia,via_agp
i2c_core 17360 8 nvidia,tuner,tvaudio,bttv,i2c_algo_bit,tveeprom,td a9887,tda7432
[root@localhost giorgio]#

Però il modulo nvidia è caricato ...

Durante il caricamento compare il logo nVIDIA, ma se do un

$ glxinfo

X va in crash e mi ripresenta la schermata di login grafico.

Questo è il mio xorg.conf, dopo aver dato un "nvidia.xconf

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Mon May 15 13:23:42 PDT 2006

# File generated by XFdrake.
# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1" 0 0
EndSection

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

# allows the server to start up even if the mouse doesn't work
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" ""
EndSection

Section "Monitor"
# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
Identifier "monitor1"
VendorName "Plug'n Play"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 75.0
ModeLine "1024x480" 65.0 1024 1032 1176 1344 480 488 494 563 -hsync -vsync
ModeLine "1280x800" 147.9 1280 1376 1512 1744 800 801 804 848
ModeLine "1680x1050" 214.5 1680 1800 1984 2288 1050 1051 1054 1103
ModeLine "1920x1200" 230.0 1920 1936 2096 2528 1200 1201 1204 1250 +hsync +vsync
ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corp."
BoardName "NVIDIA GeForce2 DDR (generic)"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
Option "DPMS"
EndSection

mykol
28-06-2006, 17:14
anche se lancio un gioco che usi l'accelerazione 3D (come ppracer o chromium, X crasha).

mykol
28-06-2006, 18:54
Vittoria ! Finalmente TUX vola ! Ho dovuto disinstallare il kernel, il kernel-source, rimettere tutto, reinstallare il driver NVIDIA e fargli riconfigurare xorg.conf.

Ultimo problema: al boot avvia dkms e tenta di installare il modulo libasf, poi, verso la fine abortisce dicendo che è già caricato.

Come posso evitare questo tentativo di caricamento ?

Ultimissima cosa, poi spero di non rompervi più con questo problema: per installare il driver nvidia negli altri Kernel che ho è sufficiente riavviare con i vari kernel e ripetere l'installazione del driver ? Oppure è necessario installare anche gli altri kernel-source ? Ma in questo caso non rifarà casini ?

Comunque in attesa di una autorevole risposta ... me ne sto tranquillo e mi godo TUX !

Grazie ancora.

andy caps
28-06-2006, 19:02
puoi provare a disinstallare libasf e dkms poi reinstallare dkms

se lo hai installato singolarmente libasf potrebbe avere generato questo problema

il kernel sources viene aggiornato automaticamente quando da urpmi --auto-select quello che non viene aggiornato semmai è il kernel immagine

puoi avere tranquillamente magari un kernel source 2.6.17 e un kernel immagine 2.6.12
aggiornando il kernel immagine alla versione corrente in futuro poi dkms fa tutto da se
al boot compila il driver e lo installa nel nuovo kernel

mykol
29-06-2006, 12:26
il problema è che tenta di ricompilarlo ad ogni boot. Ho provato a togliere dkms-nvidia (urpme dkms-nvidiia) e non funzionava più il driver nvidia, l'ho ricompilato ed ora funziona, ma comunque ad ogni boot tenta di ricompilare libasf. Ora non sono sul mio PC, oggi proverò a disinstallare di nuovo dpkms e libasf. (cioè, anche se l'ho tolto ... c'è ancora. non capisco come mai ...)

Loading