PDA

Visualizza la versione completa : Spostare cartella doc root di apache


Sechi Paolo
28-06-2006, 08:20
Salve a tutti.

StÚ cercando di spostare la cartella DocumentRoot di Apache.

Ho aperto il file 000-default presente in questo percorso:
/media/hda3/etc/apache2/sites-enabled/
Per sicurezza, magari ho sbagliato qualcosa, vi mostro l'intero file:


NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost

DocumentRoot /media/hda5/Apache
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /media/hda5/Apache/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# Uncomment this directive is you want to see apache2's
# default start page (in /apache2-default) when you go to /
#RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>


E ho inserito il percorso di una partizione fat32. Alla cartella ho anche impostato i permessi 777 (sudo chmod 777 /media/.....).
Ma quando su firefox digito "localhost", questa Ť la risposta:


Forbidden

You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.55 (Ubuntu) PHP/5.1.2 Server at localhost Port 80

Cosa faccio???

Grazie :ciauz:

P.S.: Uso il Kubuntu 6.06

mxa
28-06-2006, 11:20
io non sono riuscito a far andare apache con la root su fat32, in quanto su fat32 tutti i file sono di root, e non ci sono santi di cambiarne il proprietario.

Sechi Paolo
28-06-2006, 20:17
Quindi se utilizzo firefox dal root e digito "localhost" in teoria dovrebbe fungere?

iox84
29-06-2006, 09:26
Hai provato a cambiare i permessi della document root con il comando


chown -c proprietario:gruppo /cartella


per maggiori info:


man chown


oppure:


chown --help

pop killer
29-06-2006, 09:55
per modificare il proprietario delle altre partizioni devi agire su fstab... io proverei ad aggiungere alle opzioni della partizione

user

Loading