PDA

Visualizza la versione completa : [PHP] Dove sono gli eseguibili e le estenzioni?


Gionnico
04-07-2006, 02:07
Ho il php4 su debian.

Mi chiedo dove siano i binari, i moduli (di apache) e soprattutto le estenzioni!!

Aiuto..

Gionnico
11-07-2006, 20:16
(le ext di PHP!!!)

NON LE TROVO....

osvi
11-07-2006, 20:37
sicuro che siano installate?
non come su win che son fornite tutte nello zip di php
devi installarti php-mysql php-gd ecc :)

cmq se guardi in php stanno in "extension_dir"
da me = a /usr/lib/php4/20050606

Gionnico
12-07-2006, 03:49
Originariamente inviato da osvi
sicuro che siano installate?
non come su win che son fornite tutte nello zip di php

Ah! E' vero!!


devi installarti php-mysql php-gd ecc :)

Infatti. Ma su php4-mysql c' anche mysqli? Perch non l'ho trovata..


cmq se guardi in php stanno in "extension_dir"

Mi serviva per impostare questo parametro!!


da me = a /usr/lib/php4/20050606
Grazie! Io ho una data differente: prima in effetti era vuota, ma durante l'installazione ha attivato da solo l'ext ed impostato la cartella suddetta. :)

osvi
12-07-2006, 08:53
si la data quella di compilazione
io con php4-mysql ho solo mysql.o

Gionnico
12-07-2006, 14:53
Originariamente inviato da osvi
si la data quella di compilazione
io con php4-mysql ho solo mysql.o
Ecco, quindi se manca mysqli.o vuol dire che manca l'ext..

A me manca. :zizi:

Forse su stable non c' ancora?

osvi
12-07-2006, 18:25
http://packages.debian.org/cgi-bin/search_packages.pl?keywords=mysqli&searchon=names&subword=1&version=stable&release=all
esatto non c'

anche su ubuntu :master: c' per per php5, non che stato aggiunto con php5?
ho usato sempre e solo mysql.o :stordita: non so

Gionnico
13-07-2006, 02:50
Mentre per i binari di apache (htpasswd ecc)? Grazie!

Gionnico
14-07-2006, 15:45
up

osvi
14-07-2006, 15:52
locate htpasswd? :stordita:

Loading